FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Debian > Debian KDE

 
 
LinkBack Thread Tools
 
Old 09-11-2010, 10:36 AM
George Kiagiadakis
 
Default KDE SC 4.5.1 packages available

On Sat, Sep 11, 2010 at 1:12 PM, Tobias Schula <tobias@schula.org> wrote:
> Am Samstag 11. September 2010, 11:07:45 schrieb George Kiagiadakis:
>
>> What exactly is missing? The systemsettings layout has changed in 4.5,
>> maybe it confuses you, but other than that, all modules are still
>> there. Note that some of them may be in the lost+found section
>> (because they come from 4.4 packages and are not aware of this layout)
>> which is not in the visible area by default, you need to scroll down a
>> bit.
>
> It's strange, there were virtually all modules missing except "Application
> Appearance", "Window Behavior", "Network Settings", "Input Devices" and "Date
> and Time". First I thought there's something wrong with my configuration files
> in ~/.kde. But even after moving them and starting with an empty ~/.kde the
> modules were still missing.
>
> So I purged all kde apps
>> aptitude purge ~nkde
> and reinstalled kde
>> aptitude install -t experimental-snapshots kde-standard
>
> Now all the missing systemsetting modules are back. It's still strange because
> for the reinstalling it didn't download any new files at all, there were all
> from my local cache. I guess there was something wrong with the global
> configuration files I removed by purging all kde packages.
>

Probably a rebuild of the kde configuration cache was needed:
$ kbuildsycoca4 --noincremental

This should happen automatically though, but...


--
To UNSUBSCRIBE, email to debian-kde-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: AANLkTikK_E0a_6KCongvYZ1018ThhS40EjtUbSuHAvWt@mail .gmail.com">http://lists.debian.org/AANLkTikK_E0a_6KCongvYZ1018ThhS40EjtUbSuHAvWt@mail .gmail.com
 
Old 09-11-2010, 02:34 PM
Dietz Pröpper
 
Default KDE SC 4.5.1 packages available

Zsolt Rizsanyi:
> It is a segfault.
>
> Not sure how did glib get into this backtrace I don't have time to
> now to try to find out.
> BTW which version of Qt are you using? My Qt version is 4:4.6.3-1+b1
> and libglib2.0-0 2.24.1-1. I can try some other versions if needed.

qt 4:4.6.3-2 and glib 2.24.1-1 (both from unstable I think).


--
To UNSUBSCRIBE, email to debian-kde-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 201009111634.02270.dietz@rotfl.franken.de">http://lists.debian.org/201009111634.02270.dietz@rotfl.franken.de
 
Old 09-11-2010, 03:01 PM
Martin Steigerwald
 
Default KDE SC 4.5.1 packages available

Am Samstag 11 September 2010 schrieb George Kiagiadakis:
> On Sat, Sep 11, 2010 at 12:51 AM, Martin Steigerwald
>
> <Martin@lichtvoll.de> wrote:
> > Am Donnerstag 09 September 2010 schrieb George Kiagiadakis:
> >> Hello,
> >
> > Hi George,
> >
> >> Semi-official KDE SC 4.5.1 packages are now available at
> >> http://qt-kde.debian.net/. Enjoy!
> >
> > do you plan to provide updates to localization packages aka
> > kde-l10n-de?
> >
> > Thanks,
>
> As my first message explains, some packages are still not prepared and
> it will take some time until I prepare them all. kde-l10n is one of
> them. As soon as it is prepared, I will upload it.

Thanks, I appreciate it.

--
Martin 'Helios' Steigerwald - http://www.Lichtvoll.de
GPG: 03B0 0D6C 0040 0710 4AFA B82F 991B EAAC A599 84C7
 
Old 09-12-2010, 11:21 AM
George Kiagiadakis
 
Default KDE SC 4.5.1 packages available

On Sat, Sep 11, 2010 at 12:20 PM, George Kiagiadakis
<kiagiadakis.george@gmail.com> wrote:
> On Fri, Sep 10, 2010 at 11:04 PM, Modestas Vainius <modestas@vainius.eu> wrote:
>> Hello,
>>
>> On penktadienis 10 RugsÄ—jis 2010 19:47:25 George Kiagiadakis wrote:
>>> On Fri, Sep 10, 2010 at 5:54 PM, Zsolt Rizsanyi
>>>
>>> <rizsanyi@users.sourceforge.net> wrote:
>>> > On Fri, Sep 10, 2010 at 4:34 PM, Martin Steigerwald <Martin@lichtvoll.de>
>> wrote:
>>> >> Digikam again with glib dbg package installed. This crash might be
>>> >> related to the marble crash as well. At least that marble widget
>>> >> appears in this
>>> >
>>> >> backtrace, too:
>>> > Hmm, I have found a cure. Checking digikam I have seen, that digikam
>>> > depends on libmarblewidget4 (which is kde 4.4.5) and marble depends on
>>> > libmarblewidget10 (which is kde 4.5.1).
>>> > After removing libmarblewidget4 (including digikam) now marble does not
>>> > crash.
>>>
>>> Thanks, that must be the problem. I will investigate it.
>>> libmarblewidget4 should not be installed on the system, it is replaced
>>> by libmarblewidget10 now. Obviously digikam needs a rebuild and
>>> probably something needs to conflict with libmarblewidget4, but not
>>> sure what yet.
>>
>> There is no good solution for such a case except binNMU. The recent failed
>> libjpeg transition was another example of how messy such things could get.
>> Unfortunately, Breaks would complicate migration to testing unnecessarily.
>>
>
> Right, so in the digikam case, digikam links to libmarblewidget4 and
> loads plugins which link to libmarblewidget10. In this case it is
> reasonable to crash and I agree that the correct solution is a binNMU.
> But what happens in the case of marble itself? It links against
> libmarblewidget10 and the plugins as well, but when libmarblewidget4
> is installed, it crashes and there is nothing mentioning
> libmarblewidget4 in the backtrace. That doesn't make much sense to me.
> Ideas?
>

fwiw, I cannot reproduce the marble crash with libmarblewidget4 installed.


--
To UNSUBSCRIBE, email to debian-kde-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: AANLkTinza45YAm=Gt5E9O8tKmzNTgrATaCZOvFRb3206@mail .gmail.com">http://lists.debian.org/AANLkTinza45YAm=Gt5E9O8tKmzNTgrATaCZOvFRb3206@mail .gmail.com
 
Old 09-12-2010, 10:06 PM
Zsolt Rizsanyi
 
Default KDE SC 4.5.1 packages available

Hi,

On Sun, Sep 12, 2010 at 1:21 PM, George Kiagiadakis
<kiagiadakis.george@gmail.com> wrote:
> fwiw, I cannot reproduce the marble crash with libmarblewidget4 installed.

Very interesting indeed!

Tried installing libmarblewidget4 (without digikam) and marble did not
crash at startup.

Then I have installed digikam (it pulled in only digikam-data,
liblensfun0 and liblensfun-data) and marble now crashes for me again.
Very very strange!

Then for further surprises: removed only digikam (leaving the above 3
dependencies installed) and marble is working again.

Regards,
Zsolt


--
To UNSUBSCRIBE, email to debian-kde-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: AANLkTi=oGqM6-kCFzvBw3raAA3zuUPUNK2NYtNidj_kP@mail.gmail.com">ht tp://lists.debian.org/AANLkTi=oGqM6-kCFzvBw3raAA3zuUPUNK2NYtNidj_kP@mail.gmail.com
 
Old 09-12-2010, 10:08 PM
Zsolt Rizsanyi
 
Default KDE SC 4.5.1 packages available

Hi,

On Mon, Sep 13, 2010 at 12:06 AM, Zsolt Rizsanyi
<rizsanyi@users.sourceforge.net> wrote:
> Then for further surprises: removed only digikam (leaving the above 3
> dependencies installed) and marble is working again.

Sorry for replying to myself, but found out that digikam supplies a
marble plugin:
/usr/lib/kde4/plugins/marble/ExternalDraw.so

So this has to be the culprit.

Regards,
Zsolt


--
To UNSUBSCRIBE, email to debian-kde-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: AANLkTi=RheacKyLHspwp2a1DmCRgDDuLmqsaYmdJfDu3@mail .gmail.com">http://lists.debian.org/AANLkTi=RheacKyLHspwp2a1DmCRgDDuLmqsaYmdJfDu3@mail .gmail.com
 
Old 09-12-2010, 10:13 PM
George Kiagiadakis
 
Default KDE SC 4.5.1 packages available

On Mon, Sep 13, 2010 at 1:08 AM, Zsolt Rizsanyi
<rizsanyi@users.sourceforge.net> wrote:
> Hi,
>
> On Mon, Sep 13, 2010 at 12:06 AM, Zsolt Rizsanyi
> <rizsanyi@users.sourceforge.net> wrote:
>> Then for further surprises: removed only digikam (leaving the above 3
>> dependencies installed) and marble is working again.
>
> Sorry for replying to myself, but found out that digikam supplies a
> marble plugin:
> /usr/lib/kde4/plugins/marble/ExternalDraw.so
>
> So this has to be the culprit.
>
> Regards,
> Zsolt
>

Bingo!


--
To UNSUBSCRIBE, email to debian-kde-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: AANLkTikAVzhaUH75FBwsx5xYBmNmXKd_GpUm44_0fsEq@mail .gmail.com">http://lists.debian.org/AANLkTikAVzhaUH75FBwsx5xYBmNmXKd_GpUm44_0fsEq@mail .gmail.com
 
Old 09-13-2010, 09:04 PM
George Kiagiadakis
 
Default KDE SC 4.5.1 packages available

FYI, I have uploaded digikam 2:1.2.0-7+b1 on qt-kde.debian.net that
fixes these crashes.

I did not upload the digikam 1.4.0 package that Mark supplied because
I have trouble rebuilding it and besides that, there seem to be some
potential issues with its mysql usage that I would like to investigate
first. However, if you have already installed digikam 1.4.0 and it's
working for you, there is no need to downgrade.

Regards,
George


--
To UNSUBSCRIBE, email to debian-kde-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: AANLkTimQeye0B9YwoBrzaXpTW3CEoKX7wFQkr80TpV3W@mail .gmail.com">http://lists.debian.org/AANLkTimQeye0B9YwoBrzaXpTW3CEoKX7wFQkr80TpV3W@mail .gmail.com
 
Old 09-14-2010, 10:09 AM
Torsten Grote
 
Default KDE SC 4.5.1 packages available

Hi,

thanks a lot for the great work!

I seem to have problems with the signed packages. pkg-kde-archive-keyring
is installed and apt-key gives me:

$ apt-key list | grep -C 2 "debian-qt-kde"

pub 4096R/E79C8BAB 2010-03-05
uid Debian pkg-kde repository signing key (http://pkg-
kde.alioth.debian.org/) <debian-qt-kde@lists.debian.org>

But when trying to install, I just get:

WARNING: untrusted versions of the following packages will be installed!
Untrusted packages could compromise your system's security.

Have the packages been properly signed? Is anybody else having this problem?

Another note on security:
pkg-kde-archive-keyring seems to be hosted on the same repository it is
supposed to verify the trustworthiness of and it is not signed with an already
trusted key. Installing an untrusted key and trust that for all KDE packages
is pointless for security.

Thanks in advance,
Torsten

PS. I'm not on this list, so please include me in replies.


--
To UNSUBSCRIBE, email to debian-kde-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 201009141209.37571.Torsten.Grote@gmx.de">http://lists.debian.org/201009141209.37571.Torsten.Grote@gmx.de
 
Old 09-14-2010, 11:01 AM
George Kiagiadakis
 
Default KDE SC 4.5.1 packages available

On Tue, Sep 14, 2010 at 1:09 PM, Torsten Grote <Torsten.Grote@gmx.de> wrote:
> Hi,
>
> thanks a lot for the great work!
>
> I seem to have problems with the signed packages. pkg-kde-archive-keyring
> is installed and apt-key gives me:
>
> $ apt-key list | grep -C 2 "debian-qt-kde"
>
> pub * 4096R/E79C8BAB 2010-03-05
> uid * * * * * * * * *Debian pkg-kde repository signing key (http://pkg-
> kde.alioth.debian.org/) <debian-qt-kde@lists.debian.org>
>
> But when trying to install, I just get:
>
> WARNING: untrusted versions of the following packages will be installed!
> Untrusted packages could compromise your system's security.
>
> Have the packages been properly signed? Is anybody else having this problem?

Try running aptitude/apt-get update again.


> Another note on security:
> pkg-kde-archive-keyring seems to be hosted on the same repository it is
> supposed to verify the trustworthiness of and it is not signed with an already
> trusted key. Installing an untrusted key and trust that for all KDE packages
> is pointless for security.
>
> Thanks in advance,
> Torsten
>
> PS. I'm not on this list, so please include me in replies.
>
>
> --
> To UNSUBSCRIBE, email to debian-kde-REQUEST@lists.debian.org
> with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
> Archive: http://lists.debian.org/201009141209.37571.Torsten.Grote@gmx.de
>
>


--
To UNSUBSCRIBE, email to debian-kde-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: AANLkTim0CjaQAff4KYb8z75LabeynDYcZYSSht4H85Ee@mail .gmail.com">http://lists.debian.org/AANLkTim0CjaQAff4KYb8z75LabeynDYcZYSSht4H85Ee@mail .gmail.com
 

Thread Tools




All times are GMT. The time now is 07:48 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright ©2007 - 2008, www.linux-archive.org