FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Debian > Debian KDE

 
 
LinkBack Thread Tools
 
Old 09-10-2010, 08:04 PM
Modestas Vainius
 
Default KDE SC 4.5.1 packages available

Hello,

On penktadienis 10 Rugsėjis 2010 19:47:25 George Kiagiadakis wrote:
> On Fri, Sep 10, 2010 at 5:54 PM, Zsolt Rizsanyi
>
> <rizsanyi@users.sourceforge.net> wrote:
> > On Fri, Sep 10, 2010 at 4:34 PM, Martin Steigerwald <Martin@lichtvoll.de>
wrote:
> >> Digikam again with glib dbg package installed. This crash might be
> >> related to the marble crash as well. At least that marble widget
> >> appears in this
> >
> >> backtrace, too:
> > Hmm, I have found a cure. Checking digikam I have seen, that digikam
> > depends on libmarblewidget4 (which is kde 4.4.5) and marble depends on
> > libmarblewidget10 (which is kde 4.5.1).
> > After removing libmarblewidget4 (including digikam) now marble does not
> > crash.
>
> Thanks, that must be the problem. I will investigate it.
> libmarblewidget4 should not be installed on the system, it is replaced
> by libmarblewidget10 now. Obviously digikam needs a rebuild and
> probably something needs to conflict with libmarblewidget4, but not
> sure what yet.

There is no good solution for such a case except binNMU. The recent failed
libjpeg transition was another example of how messy such things could get.
Unfortunately, Breaks would complicate migration to testing unnecessarily.

--
Modestas Vainius <modestas@vainius.eu>


--
To UNSUBSCRIBE, email to debian-kde-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 201009102304.42542.modestas@vainius.eu">http://lists.debian.org/201009102304.42542.modestas@vainius.eu
 
Old 09-10-2010, 09:51 PM
Martin Steigerwald
 
Default KDE SC 4.5.1 packages available

Am Donnerstag 09 September 2010 schrieb George Kiagiadakis:
> Hello,

Hi George,

> Semi-official KDE SC 4.5.1 packages are now available at
> http://qt-kde.debian.net/. Enjoy!

do you plan to provide updates to localization packages aka kde-l10n-de?


Thanks,
--
Martin 'Helios' Steigerwald - http://www.Lichtvoll.de
GPG: 03B0 0D6C 0040 0710 4AFA B82F 991B EAAC A599 84C7
 
Old 09-10-2010, 10:44 PM
Tobias Schula
 
Default KDE SC 4.5.1 packages available

Am Donnerstag 09 September 2010, 21:57:14 schrieb George Kiagiadakis:
> Hello,
>
> Semi-official KDE SC 4.5.1 packages are now available at
> http://qt-kde.debian.net/. Enjoy!

Thanks for packaging!

> Unfortunately not all of the packages are ready yet, so you may notice
> that some things are missing. The missing source packages at the
> moment are kdeaccessibility, kdeadmin, kdegames, kdemultimedia,
> kdebindings, kdetoys, kdewebdev and kde-l10n as well as meta-kde (the
> kde-standard and misc metapackages).

Is this the reason why so many modules are missing from systemsettings?

Regards

Tobias


--
To UNSUBSCRIBE, email to debian-kde-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 201009110044.53989.tobias@schula.org">http://lists.debian.org/201009110044.53989.tobias@schula.org
 
Old 09-10-2010, 11:02 PM
Facundo Aguilera
 
Default KDE SC 4.5.1 packages available

El Viernes 10 Septiembre 2010 19:44:53 Tobias Schula <tobias@schula.org>
escribi:

> Is this the reason why so many modules are missing from systemsettings?
>
> Regards
>
> Tobias

You must make a full-upgrade of kde packages.

Regards.

fa


--
To UNSUBSCRIBE, email to debian-kde-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 201009102002.04552.budinero@gmail.com">http://lists.debian.org/201009102002.04552.budinero@gmail.com
 
Old 09-10-2010, 11:08 PM
Tobias Schula
 
Default KDE SC 4.5.1 packages available

Am Samstag 11 September 2010, 01:02:02 schrieb Facundo Aguilera:

> You must make a full-upgrade of kde packages.

Hmm,
> aptitude -t experimental-snapshots full-upgrade
isn't enough?


Regards

Tobias


--
To UNSUBSCRIBE, email to debian-kde-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 201009110108.01833.tobias@schula.org">http://lists.debian.org/201009110108.01833.tobias@schula.org
 
Old 09-11-2010, 01:36 AM
Kete
 
Default KDE SC 4.5.1 packages available

On Thursday September 9, 2010 3:57:14 pm George Kiagiadakis wrote:
> I hope
> you understand the reasons behind this (getting squeeze ready, work,
> real life, summer vacations, few active people in the team, etc...)
I totally understand. Thanks for everything. The only problem so far was
trying to send an e-mail draft I made before the upgrade.


--
To UNSUBSCRIBE, email to debian-kde-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 201009102136.05114.kwfj@suddenlink.net">http://lists.debian.org/201009102136.05114.kwfj@suddenlink.net
 
Old 09-11-2010, 09:05 AM
George Kiagiadakis
 
Default KDE SC 4.5.1 packages available

On Sat, Sep 11, 2010 at 12:51 AM, Martin Steigerwald
<Martin@lichtvoll.de> wrote:
> Am Donnerstag 09 September 2010 schrieb George Kiagiadakis:
>> Hello,
>
> Hi George,
>
>> Semi-official KDE SC 4.5.1 packages are now available at
>> http://qt-kde.debian.net/. Enjoy!
>
> do you plan to provide updates to localization packages aka kde-l10n-de?
>
>
> Thanks,

As my first message explains, some packages are still not prepared and
it will take some time until I prepare them all. kde-l10n is one of
them. As soon as it is prepared, I will upload it.


--
To UNSUBSCRIBE, email to debian-kde-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: AANLkTi=6yWYPVDnpFW4Gruj+YeDDvHv8=eR9Ypz0Tuud@mail .gmail.com">http://lists.debian.org/AANLkTi=6yWYPVDnpFW4Gruj+YeDDvHv8=eR9Ypz0Tuud@mail .gmail.com
 
Old 09-11-2010, 09:07 AM
George Kiagiadakis
 
Default KDE SC 4.5.1 packages available

On Sat, Sep 11, 2010 at 1:44 AM, Tobias Schula <tobias@schula.org> wrote:
> Am Donnerstag 09 September 2010, 21:57:14 schrieb George Kiagiadakis:
>> Hello,
>>
>> Semi-official KDE SC 4.5.1 packages are now available at
>> http://qt-kde.debian.net/. Enjoy!
>
> Thanks for packaging!
>
>> Unfortunately not all of the packages are ready yet, so you may notice
>> that some things are missing. The missing source packages at the
>> moment are kdeaccessibility, kdeadmin, kdegames, kdemultimedia,
>> kdebindings, kdetoys, kdewebdev and kde-l10n as well as meta-kde (the
>> kde-standard and misc metapackages).
>
> Is this the reason why so many modules are missing from systemsettings?
>
> Regards
>
> Tobias
>

What exactly is missing? The systemsettings layout has changed in 4.5,
maybe it confuses you, but other than that, all modules are still
there. Note that some of them may be in the lost+found section
(because they come from 4.4 packages and are not aware of this layout)
which is not in the visible area by default, you need to scroll down a
bit.


--
To UNSUBSCRIBE, email to debian-kde-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: AANLkTimCCNjLqT10nk2L751NSbcyiOLWDsJcSj1Gfzu2@mail .gmail.com">http://lists.debian.org/AANLkTimCCNjLqT10nk2L751NSbcyiOLWDsJcSj1Gfzu2@mail .gmail.com
 
Old 09-11-2010, 09:20 AM
George Kiagiadakis
 
Default KDE SC 4.5.1 packages available

On Fri, Sep 10, 2010 at 11:04 PM, Modestas Vainius <modestas@vainius.eu> wrote:
> Hello,
>
> On penktadienis 10 Rugsėjis 2010 19:47:25 George Kiagiadakis wrote:
>> On Fri, Sep 10, 2010 at 5:54 PM, Zsolt Rizsanyi
>>
>> <rizsanyi@users.sourceforge.net> wrote:
>> > On Fri, Sep 10, 2010 at 4:34 PM, Martin Steigerwald <Martin@lichtvoll.de>
> wrote:
>> >> Digikam again with glib dbg package installed. This crash might be
>> >> related to the marble crash as well. At least that marble widget
>> >> appears in this
>> >
>> >> backtrace, too:
>> > Hmm, I have found a cure. Checking digikam I have seen, that digikam
>> > depends on libmarblewidget4 (which is kde 4.4.5) and marble depends on
>> > libmarblewidget10 (which is kde 4.5.1).
>> > After removing libmarblewidget4 (including digikam) now marble does not
>> > crash.
>>
>> Thanks, that must be the problem. I will investigate it.
>> libmarblewidget4 should not be installed on the system, it is replaced
>> by libmarblewidget10 now. Obviously digikam needs a rebuild and
>> probably something needs to conflict with libmarblewidget4, but not
>> sure what yet.
>
> There is no good solution for such a case except binNMU. The recent failed
> libjpeg transition was another example of how messy such things could get.
> Unfortunately, Breaks would complicate migration to testing unnecessarily.
>

Right, so in the digikam case, digikam links to libmarblewidget4 and
loads plugins which link to libmarblewidget10. In this case it is
reasonable to crash and I agree that the correct solution is a binNMU.
But what happens in the case of marble itself? It links against
libmarblewidget10 and the plugins as well, but when libmarblewidget4
is installed, it crashes and there is nothing mentioning
libmarblewidget4 in the backtrace. That doesn't make much sense to me.
Ideas?


--
To UNSUBSCRIBE, email to debian-kde-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: AANLkTim1qX_oYyTUfFB28+TtNX4s2oRzCPj6JnZp32-4@mail.gmail.com">http://lists.debian.org/AANLkTim1qX_oYyTUfFB28+TtNX4s2oRzCPj6JnZp32-4@mail.gmail.com
 
Old 09-11-2010, 10:12 AM
Tobias Schula
 
Default KDE SC 4.5.1 packages available

Am Samstag 11. September 2010, 11:07:45 schrieb George Kiagiadakis:

> What exactly is missing? The systemsettings layout has changed in 4.5,
> maybe it confuses you, but other than that, all modules are still
> there. Note that some of them may be in the lost+found section
> (because they come from 4.4 packages and are not aware of this layout)
> which is not in the visible area by default, you need to scroll down a
> bit.

It's strange, there were virtually all modules missing except "Application
Appearance", "Window Behavior", "Network Settings", "Input Devices" and "Date
and Time". First I thought there's something wrong with my configuration files
in ~/.kde. But even after moving them and starting with an empty ~/.kde the
modules were still missing.

So I purged all kde apps
> aptitude purge ~nkde
and reinstalled kde
> aptitude install -t experimental-snapshots kde-standard

Now all the missing systemsetting modules are back. It's still strange because
for the reinstalling it didn't download any new files at all, there were all
from my local cache. I guess there was something wrong with the global
configuration files I removed by purging all kde packages.



--
To UNSUBSCRIBE, email to debian-kde-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 201009111212.20456.tobias@schula.org">http://lists.debian.org/201009111212.20456.tobias@schula.org
 

Thread Tools




All times are GMT. The time now is 09:56 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org