Linux Archive

Linux Archive (http://www.linux-archive.org/)
-   Debian KDE (http://www.linux-archive.org/debian-kde/)
-   -   Qtcreator (http://www.linux-archive.org/debian-kde/402066-qtcreator.html)

Fathi Boudra 07-21-2010 09:16 AM

Qtcreator
 
> Nokia released a new version of qtcreator. I have seen that if you download
> from nokia, the package contain qt 4.6.3 and qtcreator 2.0.

Please, could you point me to the package you have downloaded on Nokia website ?
I could then take a look because I have doubt on used Qt version.

> However, qtcreator have the dependency > 4.7 of qtlibs. Someone of you could
> explain why? Just asking because it could be an interesting package to
> squeeze.

simply because Qt Creator check for Qt version 4.7, see qtcreator.pro:
#version check qt
contains(QT_VERSION, ^4.[0-6]..*) {
message("Cannot build Qt Creator with Qt version $${QT_VERSION}.")
error("Use at least Qt 4.7.")
}

As far as I know, Qt Creator doesn't build against Qt 4.6 (I bet it
needs Qt Declarative introduced in Qt 4.7).

Cheers,

Fathi


--
To UNSUBSCRIBE, email to debian-kde-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: AANLkTik9CDTayeOI8JfCNetO2DgpSblC87b7THnRugfW@mail .gmail.com">http://lists.debian.org/AANLkTik9CDTayeOI8JfCNetO2DgpSblC87b7THnRugfW@mail .gmail.com

Leopold Palomo-Avellaneda 07-21-2010 10:34 AM

Qtcreator
 
A Dimecres 21 Juliol 2010, Fathi Boudra va escriure:
> > Nokia released a new version of qtcreator. I have seen that if you
> > download from nokia, the package contain qt 4.6.3 and qtcreator 2.0.
>
> Please, could you point me to the package you have downloaded on Nokia
> website ? I could then take a look because I have doubt on used Qt version.

http://qt.nokia.com/downloads

on the tab lgpl:

Qt SDK: Complete Development Environment

Qt SDK Icon
The Qt SDK includes the tools you need to build cross-platform applications
with Qt in a single install.
Qt libraries version 4.6.3.
Qt Creator IDE version 2.0.0
Qt development tools

> > However, qtcreator have the dependency > 4.7 of qtlibs. Someone of you
> > could explain why? Just asking because it could be an interesting package
> > to squeeze.
>
> simply because Qt Creator check for Qt version 4.7, see qtcreator.pro:
> #version check qt
> contains(QT_VERSION, ^4.[0-6]..*) {
> message("Cannot build Qt Creator with Qt version $${QT_VERSION}.")
> error("Use at least Qt 4.7.")
> }
>
> As far as I know, Qt Creator doesn't build against Qt 4.6 (I bet it
> needs Qt Declarative introduced in Qt 4.7).
>

I don't know if they provide qt creator 2.0 compiled to a different version
than the qt sdk. Maybe it's a mistake in the web page. Obviously if the
qtcreator.pro says that is for something, no?

Regards,

Leo





--
To UNSUBSCRIBE, email to debian-kde-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 201007211234.10560.leo@alaxarxa.net">http://lists.debian.org/201007211234.10560.leo@alaxarxa.net


All times are GMT. The time now is 05:48 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.