FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Debian > Debian KDE

 
 
LinkBack Thread Tools
 
Old 06-13-2010, 11:31 PM
Martin gren
 
Default Squeeze KDE unusable: no taskbar or decorations, missing shortcut key

Hi!

After a recent upgrade of squeeze -- but I have also been removing
some packages since my last working reboot -- I no longer have a
usable installation of kde. I get a very basic plasma desktop with the
calculator and dictionary (as configured by me) apart from the
"Desktop Folder". No window decorations on the "Desktop Folder", no
taskbar, no anything. Just a white background and these three windows.

Some applications, notably Amarok and the network manager, seem to
start but they do not show anywhere (as the taskbar is indeed gone).
Going Alt+F2 -> "System Activity" and right-clicking e.g., amarok and
selecting "Show Application Window" doesn't do anything. (I admit I
don't know if it's supposed to. )

By pressing Meta+O, I can trigger Amarok's On-Screen Display, but
similarly, Meta+K does not start an instance of Konsole, as I have it
configured to.

I have moved my ~/.kde/ aside and logged in, but it basically just
leads to the same non-usable situation (of course, with default
appearances, e.g., no calculator+dictionary configuration). I have
tried installing kde-full, thinking that there might be some missing
dependency, but that didn't improve anything as far as I could see.
plasma-desktop is running and killing it makes everything pure
black...

I would really appreciate any pointers as to what could be the
problem. I don't really know which information to provide in order to
bring more light on this, and would be glad to provide anything deemed
interesting.

Take care,
Martin


--
To UNSUBSCRIBE, email to debian-kde-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: AANLkTikWjjdAjKGcghHd2jbS5NzQla-ZdpKGAO8CBY9n@mail.gmail.com">http://lists.debian.org/AANLkTikWjjdAjKGcghHd2jbS5NzQla-ZdpKGAO8CBY9n@mail.gmail.com
 
Old 06-13-2010, 11:48 PM
John Varouhakis
 
Default Squeeze KDE unusable: no taskbar or decorations, missing shortcut key

I had the same problem on my testing/unstable installation and I solved
it when I realised that kdelibs5 had not been updated (in my case it was held
back by kdelibs5-dbg, so upgrading these two simultaneously from unstable,
solved my problem).


So, if you installed kde 4.4.4 from unstable make sure you got the whole
thing.

In my case the error became obvious when I tried to run systemsettings
and got this output:

systemsettings(24094) SettingsBase::initApplication: "View load error: The
plugin 'classic_mode' uses an incompatible KDE library (4.4.4 (KDE 4.4.4))."


Hope this helps.


John Varouhakis.-

Στις Δευτ*ρα 14 Ιουνίου 2010 02:31:45 Martin Ågren γράψατε:
> Hi!
>
> After a recent upgrade of squeeze -- but I have also been removing
> some packages since my last working reboot -- I no longer have a
> usable installation of kde. I get a very basic plasma desktop with the
> calculator and dictionary (as configured by me) apart from the
> "Desktop Folder". No window decorations on the "Desktop Folder", no
> taskbar, no anything. Just a white background and these three windows.
>
> Some applications, notably Amarok and the network manager, seem to
> start but they do not show anywhere (as the taskbar is indeed gone).
> Going Alt+F2 -> "System Activity" and right-clicking e.g., amarok and
> selecting "Show Application Window" doesn't do anything. (I admit I
> don't know if it's supposed to. )
>
> By pressing Meta+O, I can trigger Amarok's On-Screen Display, but
> similarly, Meta+K does not start an instance of Konsole, as I have it
> configured to.
>
> I have moved my ~/.kde/ aside and logged in, but it basically just
> leads to the same non-usable situation (of course, with default
> appearances, e.g., no calculator+dictionary configuration). I have
> tried installing kde-full, thinking that there might be some missing
> dependency, but that didn't improve anything as far as I could see.
> plasma-desktop is running and killing it makes everything pure
> black...
>
> I would really appreciate any pointers as to what could be the
> problem. I don't really know which information to provide in order to
> bring more light on this, and would be glad to provide anything deemed
> interesting.
>
> Take care,
> Martin


--
To UNSUBSCRIBE, email to debian-kde-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 201006140248.21693.johnvarouhakis@gmail.com">http://lists.debian.org/201006140248.21693.johnvarouhakis@gmail.com
 
Old 06-14-2010, 06:13 AM
Thilo Six
 
Default Squeeze KDE unusable: no taskbar or decorations, missing shortcut key

Huang, Tao wrote the following on 14.06.2010 05:33

Hello


you don't go from stable to testing, or from testing to unstable, when
you encounter problems in software packages.
at least you shouldn't offer this as a solution to other users.


Tao


In Debian there is a well known concept of "transitions". To get the fix for
this specific case one doesnt have use unstable, but when you dont youll
probably end up getting the fix much later.

In the end the packages you install are the same.

--
bye Thilo

4096R/0xC70B1A8F
721B 1BA0 095C 1ABA 3FC6 7C18 89A4 A2A0 C70B 1A8F



--
To UNSUBSCRIBE, email to debian-kde-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: hv4hak$nea$1@dough.gmane.org">http://lists.debian.org/hv4hak$nea$1@dough.gmane.org
 
Old 06-14-2010, 06:23 AM
Thilo Six
 
Default Squeeze KDE unusable: no taskbar or decorations, missing shortcut key

<snip>

Hello

forwarding mail from Modestas Vainius:

> retitle 585751 KDE is broken in testing, do not upgrade!

> On sekmadienis 13 Birželis 2010 19:43:34 Alexandre LISSY wrote:
>> > I've just got informed of a workaround on IRC. Installing libkdecore5
>> > from Sid solves the issue, at least temporarly.
> Yes, it is a known problem. I recommend not to upgrade but if you did, you
> may do the following to fix it:

>
> 1) Add unstable to /etc/apt/sources.list:
>
> # echo "deb http://ftp.de.debian.org/debian unstable main" >>
/etc/apt/sources.list

>
> 2) aptitude (or apt-get) update
> # aptitude update
>
> 3) Upgrade installed binary packages from kde4libs source package:
>
> # aptitude --without-recommends install '?source-package(kde4libs)~i'/unstable
>
> In fact, you only need libkdecore5 4:4.4.4-1 to fix this but installing this
> package alone will cause dependency issues. It is harder to achieve the same
> effect with apt-get, but you may try:
>
> # apt-cache showsrc kde4libs | sed -n '/^Binary:/ { s/^Binary:s+//;
s/,/
/g; p}' | sort -u | xargs
> dpkg-query -l | grep ^ii | awk '{print $2}' | xargs apt-get -y -t unstable
install

>
> 4) Remove unstable from sources.list.
>
> We are working to fix this in a proper way but it probably won't be easy
> or fast solution.
>
> -- Modestas Vainius <modestas@vainius.eu>



--
bye Thilo

4096R/0xC70B1A8F
721B 1BA0 095C 1ABA 3FC6 7C18 89A4 A2A0 C70B 1A8F



--
To UNSUBSCRIBE, email to debian-kde-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: hv4hse$nea$2@dough.gmane.org">http://lists.debian.org/hv4hse$nea$2@dough.gmane.org
 

Thread Tools




All times are GMT. The time now is 07:09 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org