FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Debian > Debian KDE

 
 
LinkBack Thread Tools
 
Old 06-06-2010, 01:12 PM
George Kiagiadakis
 
Default plasma-netbook not auto-starting on a fresh install

On Sun, Jun 6, 2010 at 3:50 PM, Brendon Higgins <blhiggins@gmail.com> wrote:
> Hi list,
>
> I hope posting this here is appropriate. I just got myself a new Eee PC
> recently and installed Debian on it. I decided I'd give plasma-netbook a try,
> so I installed that package, rather than plasma-desktop, along with the rest
> of a typical workspace (kde-standard and several others).
>
> I quite like using plasma-netbook, but the problem is that it never starts
> automatically when I log in. I always have to alt-F2 and use krunner to launch
> it. Google found me a couple of work-arounds that will probably do the job,
> but I'm not sure what the "correct" approach is.
>
> It ought to start on its own, right? It's basically a fresh install, so I'm
> not sure what the problem is. Anyone with similar experience, or know what I
> should do in this situation?
>
> Peace,
> Brendon
>

Sounds like a bug. Try going to systemsettings->Desktop->Workspace and
make sure it says Form factor: Netbook. Maybe it doesn't correctly
detect the absence of plasma-desktop and tries to launch it instead of
launching plasma-netbook.

Regards,
George


--
To UNSUBSCRIBE, email to debian-kde-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: AANLkTilhilvvnfGjuV5Jk1arx3U-AOQDndYSIEDq7wjY@mail.gmail.com">http://lists.debian.org/AANLkTilhilvvnfGjuV5Jk1arx3U-AOQDndYSIEDq7wjY@mail.gmail.com
 
Old 06-07-2010, 02:32 AM
Brendon Higgins
 
Default plasma-netbook not auto-starting on a fresh install

Hi George

George Kiagiadakis wrote (2010-06-06 23:12):
> Try going to systemsettings->Desktop->Workspace and
> make sure it says Form factor: Netbook.

I had a look at that. The options were grayed-out and disabled, but it did say
Netbook.

> Maybe it doesn't correctly
> detect the absence of plasma-desktop and tries to launch it instead of
> launching plasma-netbook.

Possible, I guess. Would there be a way to tell if this was the case?

> Sounds like a bug.

That's my suspicion, too. The next question is, is it a bug that has anything
to do with the packaging, or is it an upstream bug?

Peace,
Brendon


--
To UNSUBSCRIBE, email to debian-kde-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 201006071232.18470.blhiggins@gmail.com">http://lists.debian.org/201006071232.18470.blhiggins@gmail.com
 
Old 06-07-2010, 12:39 PM
Brendon Higgins
 
Default plasma-netbook not auto-starting on a fresh install

Hi list,

I think I've found a reason why plasma-netbook doesn't autostart.
/usr/share/autostart/plasma-netbook.desktop doesn't exist. The equivalent,
plasma-desktop.desktop, does exist (in the plasma-desktop package).
Presumably, this is why plasma-desktop will autostart, whereas plasma-netbook
won't.

Now I don't know if plasma-netbook.desktop ought to exist given upstream
sources, or not. A quick search in KDE sources doesn't find anything, yet
apparently there is such a file in Ubuntu (Lucid). :-S

I guess the Ubuntu file could be distro custom. I should file a bug with KDE,
perhaps?

Peace,
Brendon


--
To UNSUBSCRIBE, email to debian-kde-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 201006072239.46730.blhiggins@gmail.com">http://lists.debian.org/201006072239.46730.blhiggins@gmail.com
 
Old 06-07-2010, 01:35 PM
George Kiagiadakis
 
Default plasma-netbook not auto-starting on a fresh install

Package: plasma-netbook
Version: 4:4.4.4-1
Severity: important

On Mon, Jun 7, 2010 at 3:39 PM, Brendon Higgins <blhiggins@gmail.com> wrote:
> Hi list,
>
> I think I've found a reason why plasma-netbook doesn't autostart.
> /usr/share/autostart/plasma-netbook.desktop doesn't exist. The equivalent,
> plasma-desktop.desktop, does exist (in the plasma-desktop package).
> Presumably, this is why plasma-desktop will autostart, whereas plasma-netbook
> won't.
>
> Now I don't know if plasma-netbook.desktop ought to exist given upstream
> sources, or not. A quick search in KDE sources doesn't find anything, yet
> apparently there is such a file in Ubuntu (Lucid). :-S
>
> I guess the Ubuntu file could be distro custom. I should file a bug with KDE,
> perhaps?
>
> Peace,
> Brendon

I'm turning this email into a bug report, since this seems to be a
packaging problem.

The relevant kubuntu patch seems to be this one [1] and it seems it
has been removed from the 4.5 beta packages, with a changelog message
indicating it has been fixed upstream, although I see no
plasma-netbook.desktop in their plasma-netbook.install file.

I don't fully understand though how this is going to work when one has
both plasma-desktop and plasma-netbook installed... are they both
going to be autostarted? Also, why does plasma-netbook autostart when
plasma-desktop is installed and a "netbook" form factor is selected in
systemsettings? (I had tried that once)

[1]. http://bazaar.launchpad.net/~kubuntu-members/kdebase-workspace/ubuntu/annotate/340/debian/patches/kubuntu_102_plasma_netbook_no_autostart.diff


--
To UNSUBSCRIBE, email to debian-kde-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: AANLkTikkc8yPxDrH14T3heILwOUVm12MLhNMyL33AOR_@mail .gmail.com">http://lists.debian.org/AANLkTikkc8yPxDrH14T3heILwOUVm12MLhNMyL33AOR_@mail .gmail.com
 

Thread Tools




All times are GMT. The time now is 10:46 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org