FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Debian > Debian KDE

 
 
LinkBack Thread Tools
 
Old 04-07-2010, 05:49 PM
Michael Schuerig
 
Default Konqueror doesn't show when launched from Kickoff or panel

First things first, this problem only occurs for my "normal" user
account, it's not there for a fresh user.

When I launch Konqueror as Web Browser from Kickoff or from its Panel
icon, internally kfmclient openProfile webbrowsing is executed, which in
turn starts konqueror --silent. This Konqueror instance remains totally
silent, it doesn't show a window or give any other outward signs of
being alive. I've tried this, too, with another

When I start konqueror --silent from the command line, it just sits
there read-polling on /tmp/.X11-unix/X0. By contrast, konqueror without
any options opens a browser window.

As I understand it, and I may be wrong, silent konqueror processes are a
performance boost configurable in Settings > Configure Konqueror >
Performance. In my case, 1 instance is meant to be kept around (no
preloading). konqueror --silent, presumably, is intended to explicitly
start such a spare instance. However, in my case this spare instance is
never used as each new launch of Konqueror from Kickoff results in a new
konqueror --silent process.

I've exchanged konquerorrc and webbrowsing for copies from the fresh
account, but this didn't make a difference. Therefore, I take it, the
problem is hidden in some other part of my configuration

Michael

--
Michael Schuerig
mailto:michael@schuerig.de
http://www.schuerig.de/michael/


--
To UNSUBSCRIBE, email to debian-kde-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 201004071949.53111.michael@schuerig.de">http://lists.debian.org/201004071949.53111.michael@schuerig.de
 
Old 04-07-2010, 06:41 PM
jedd
 
Default Konqueror doesn't show when launched from Kickoff or panel

On Wednesday 07 April 2010 18:49:52 Michael Schuerig wrote:
> First things first, this problem only occurs for my "normal" user
> account, it's not there for a fresh user.

I'd be trying (just in case) grep -Ri silent ~/.kde/

> When I start konqueror --silent from the command line, it just sits
> there read-polling on /tmp/.X11-unix/X0. By contrast, konqueror without
> any options opens a browser window.

If you're happy to use strace (speculating) you could try to
check what other files it is deferring to on startup.

j.


--
To UNSUBSCRIBE, email to debian-kde-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 201004071941.36015.jedd@progsoc.org">http://lists.debian.org/201004071941.36015.jedd@progsoc.org
 
Old 04-07-2010, 09:04 PM
Michael Schuerig
 
Default Konqueror doesn't show when launched from Kickoff or panel

On Wednesday 07 April 2010, jedd wrote:
> On Wednesday 07 April 2010 18:49:52 Michael Schuerig wrote:
> > First things first, this problem only occurs for my "normal" user
> > account, it's not there for a fresh user.
>
> I'd be trying (just in case) grep -Ri silent ~/.kde/

Nothing there.

> > When I start konqueror --silent from the command line, it just sits
> > there read-polling on /tmp/.X11-unix/X0. By contrast, konqueror
> > without any options opens a browser window.
>
> If you're happy to use strace (speculating) you could try to
> check what other files it is deferring to on startup.

I've already found out the polling mentioned above through strace.
Unfortunately, it didn't help me much.

Michael

--
Michael Schuerig
mailto:michael@schuerig.de
http://www.schuerig.de/michael/


--
To UNSUBSCRIBE, email to debian-kde-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 201004072304.43304.michael@schuerig.de">http://lists.debian.org/201004072304.43304.michael@schuerig.de
 

Thread Tools




All times are GMT. The time now is 11:16 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org