FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Debian > Debian KDE

 
 
LinkBack Thread Tools
 
Old 03-22-2010, 01:11 PM
Sugo
 
Default kipi-plugins wants libkdcraw7 and libkipi6

I have to install kipi-plugins for work with scanner and gwenview. The
problem is that kipi-plugins wants libkdcraw7 and libkipi6 instead of
libkdcraw8 and libkipi7. It needs to recompile also kipi-plugins to work
with kde 4.4. Kipi-plugins is needed also from digikam.


Cheers
Andrej


--
To UNSUBSCRIBE, email to debian-kde-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 4BA77A87.6050301@gmail.com">http://lists.debian.org/4BA77A87.6050301@gmail.com
 
Old 03-22-2010, 01:59 PM
Valerio Passini
 
Default kipi-plugins wants libkdcraw7 and libkipi6

Alle luned́ 22 marzo 2010, Sugo ha scritto:
> I have to install kipi-plugins for work with scanner and gwenview.
> The problem is that kipi-plugins wants libkdcraw7 and libkipi6
> instead of libkdcraw8 and libkipi7. It needs to recompile also
> kipi-plugins to work with kde 4.4. Kipi-plugins is needed also from
> digikam.
>
> Cheers
> Andrej

They have been already recompiled, what you need to do is explicitely
tell aptitude to install digikam from experimental-snapshots that is the
same repository from where you got KDE 4.4.1.

aptitude -t experimental-snapshots install digikam


--
To UNSUBSCRIBE, email to debian-kde-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 201003221559.03627.valerio.passini@unicam.it">http ://lists.debian.org/201003221559.03627.valerio.passini@unicam.it
 
Old 03-22-2010, 04:39 PM
Sugo
 
Default kipi-plugins wants libkdcraw7 and libkipi6

Valerio wrote:

>They have been already recompiled, what you need to do is explicitely
>tell aptitude to install digikam from experimental-snapshots that is >the
>same repository from where you got KDE 4.4.1.
>
>aptitude -t experimental-snapshots install digikam

Yes, ok. But when I try to install kipi-plugins, it ask a dependency
with libkdcraw7 and libkipi6, which is not present in exp-snapshots
repository, and I have a conflict with kdegraphics-libs-data 4.4.1.


# aptitude install -t experimental-snapshots kipi-plugins
[cut]
The following packages have unmet dependencies:
kdegraphics-libs-data: Conflicts: libkdcraw7 but 4:4.3.4-1+b1 is to
be installed.
Conflicts: libkipi6 but 4:4.3.4-1+b1 is to be
installed.

The following actions will resolve these dependencies:

Keep the following packages at their current version:
1) kipi-plugins [Not Installed]
2) libkdcraw7 [Not Installed]
3) libkipi6 [Not Installed]

# aptitude show -t experimental-snapshots kipi-plugins
Unable to find an archive "experimental-snapshots" for the package
"kipi-plugins"

Package: kipi-plugins
New: yes
State: not installed
Version: 1.1.0-1
Priority: optional
Section: kde
Maintainer: Debian KDE Extras Team <pkg-kde-extras@lists.alioth.debian.org>
Uncompressed Size: 19.8M
Depends: kdebase-runtime (>= 4:4.3.0), kdelibs5 (>= 4:4.3.4),
kdepimlibs5 (>= 4:4.3.4), libc6 (>= 2.3.2), libexpat1 (>= 1.95.8),
libgcc1 (>= 1:4.1.1), libgl1-mesa-glx | libgl1, libglu1-mesa | libglu1,
libjpeg62, libkdcraw7 (>= 4:4.3.4), libkexiv2-7 (>= 4:4.3.4), libkipi6
(>= 4:4.3.4), libksane0 (>= 4:4.3.4), libphonon4 (>= 4:4.2.0),
libpng12-0 (>= 1.2.13-4), libqca2, libqt4-dbus (>= 4:4.5.3),
libqt4-network (>= 4:4.5.3), libqt4-opengl (>= 4:4.5.3), libqt4-svg (>=
4:4.5.3), libqt4-xml (>= 4:4.5.3), libqtcore4 (>= 4:4.5.3), libqtgui4
(>= 4:4.5.3), libstdc++6 (>= 4.1.1), libtiff4, libx11-6, libxau6,
libxdmcp6, libxext6, libxml2 (>= 2.7.4), libxrandr2 (>= 4.3), libxslt1.1
(>= 1.1.18), phonon (>= 4:4.5.2), zlib1g (>= 1:1.1.4)


Andrej


--
To UNSUBSCRIBE, email to debian-kde-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 4BA7AB58.6040706@gmail.com">http://lists.debian.org/4BA7AB58.6040706@gmail.com
 
Old 03-22-2010, 07:27 PM
Mark Purcell
 
Default kipi-plugins wants libkdcraw7 and libkipi6

On Tuesday 23 March 2010 04:39:36 Sugo wrote:
> >aptitude -t experimental-snapshots install digikam
>
> Yes, ok. But when I try to install kipi-plugins, it ask a dependency
> with libkdcraw7 and libkipi6, which is not present in exp-snapshots
> repository, and I have a conflict with kdegr

We have rebuilt digikam to work with experimental-snapshots and it is available in the new archive.

We have not yet rebuilt kipi-plugins.

You can do this yourself with the following commands:

Add a deb-src line to your /etc/apt/sources.list for unstable.

Then

# apt-get build-dep kipi-plugins
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following NEW packages will be installed:
libxrandr-dev x11proto-randr-dev
0 upgraded, 2 newly installed, 0 to remove and 5 not upgraded.
Need to get 71.8kB of archives.
After this operation, 332kB of additional disk space will be used.
Do you want to continue [Y/n]?
[...]
Goes away and install build-deps
[...]

/tmp$ apt-get -b source kipi-plugins
Reading package lists... Done
Building dependency tree
Reading state information... Done
Need to get 6,135kB of source archives.
Get:1 http://ftp.iinet.net.au sid/main kipi-plugins 1.1.0-1 (dsc) [1,674B]
Get:2 http://ftp.iinet.net.au sid/main kipi-plugins 1.1.0-1 (tar) [6,117kB]
Get:3 http://ftp.iinet.net.au sid/main kipi-plugins 1.1.0-1 (diff) [16.7kB]
Fetched 6,135kB in 24s (246kB/s)
dpkg-source: info: extracting kipi-plugins in kipi-plugins-1.1.0
dpkg-source: info: unpacking kipi-plugins_1.1.0.orig.tar.gz
dpkg-source: info: applying kipi-plugins_1.1.0-1.diff.gz
dpkg-buildpackage: set CFLAGS to default value: -g -O2
dpkg-buildpackage: set CPPFLAGS to default value:
[...]
GOes away and does rest of the build
[...]


# dpkg -i ../kipi-plugins*deb

Mark
 
Old 03-22-2010, 08:27 PM
Sugo
 
Default kipi-plugins wants libkdcraw7 and libkipi6

Il 22/03/2010 21:27, Mark Purcell ha scritto:
[cut]


# dpkg -i ../kipi-plugins*deb

Mark



Thanks, it works.
Just to clear something for the others. Some packages like
libqt4-opengl-dev and others has to be fetched from experimental.
The dev package of libkipi7 is not libkipi7-dev but only libkipi-dev,
the same for libkdcraw8, which is libkdcraw-dev.


Andrej


--
To UNSUBSCRIBE, email to debian-kde-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 4BA7E0D1.6050706@gmail.com">http://lists.debian.org/4BA7E0D1.6050706@gmail.com
 

Thread Tools




All times are GMT. The time now is 09:29 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright ©2007 - 2008, www.linux-archive.org