FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Debian > Debian KDE

 
 
LinkBack Thread Tools
 
Old 03-09-2010, 01:01 PM
Valerio Passini
 
Default Need for help in patching and packaging kdebase

Dear Developers,

I'm trying to help debugging nepomuk and Sebastian Trueg has sent a
patch. What it's needed is to apply it, if I have understood, to kdebase
(see below) and then to recompile and to install the package. This patch
should add debug output feature to strigi service.
Has anybody here the patience and the will to help me in doing this job
the Debian way with clear instructions? Because: 1) I really would like
to avoid to mix sources and Debian binary packages in my system, 2) I
dislike to download and compile a whole SVN KDE 4.4; and 3) the last
time I have recompiled a Debian package from deb-src was at least 4
years ago and it was a sad experience. Actually, just the kernel is
the only thing that I regularly compile on my system.
Here below is what Sebastian Trueg told to do.
Many thanks to everybody

Valerio



> https://bugs.kde.org/show_bug.cgi?id=226895
>
>
>
>
>
> --- Comment #9 from Sebastian Trueg <trueg k3b org> 2010-03-09
> 13:01:21 --- Created an attachment (id=41473)
> --> (http://bugs.kde.org/attachment.cgi?id=41473)
> Patch adds debug output to the strigi service
>
> Please apply this bug to kdebase and then recompile
> kdebase/runtime/nepomuk/services/strigi.
> Then please run the service manually from command line to see which
> files are removed and which are analyzed. This should give us more
> information on the issues.


--
To UNSUBSCRIBE, email to debian-kde-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 201003091501.25903.valerio.passini@unicam.it">http ://lists.debian.org/201003091501.25903.valerio.passini@unicam.it
 
Old 03-09-2010, 01:19 PM
Sune Vuorela
 
Default Need for help in patching and packaging kdebase

On 2010-03-09, Valerio Passini <valerio.passini@unicam.it> wrote:
> Dear Developers,
>
> I'm trying to help debugging nepomuk and Sebastian Trueg has sent a
> patch. What it's needed is to apply it, if I have understood, to kdebase
> (see below) and then to recompile and to install the package. This patch
> should add debug output feature to strigi service.
> Has anybody here the patience and the will to help me in doing this job
> the Debian way with clear instructions? Because: 1) I really would like

For the kde packages,
sudo apt-get install build-essential
apt-get source sourcepackage
sudo apt-get build-dep sourcepakage
cd sourcepackage-version
cp ../patch.diff debian/patches
echo patch.diff >> debian/patches/series
dpkg-buildpackage (-jnumberofcores)

you have now packages in ..

/Sune

> to avoid to mix sources and Debian binary packages in my system, 2) I
> dislike to download and compile a whole SVN KDE 4.4; and 3) the last
> time I have recompiled a Debian package from deb-src was at least 4
> years ago and it was a sad experience. Actually, just the kernel is
> the only thing that I regularly compile on my system.
> Here below is what Sebastian Trueg told to do.
> Many thanks to everybody
>
> Valerio
>
>
>
>> https://bugs.kde.org/show_bug.cgi?id=226895
>>
>>
>>
>>
>>
>> --- Comment #9 from Sebastian Trueg <trueg k3b org> 2010-03-09
>> 13:01:21 --- Created an attachment (id=41473)
>> --> (http://bugs.kde.org/attachment.cgi?id=41473)
>> Patch adds debug output to the strigi service
>>
>> Please apply this bug to kdebase and then recompile
>> kdebase/runtime/nepomuk/services/strigi.
>> Then please run the service manually from command line to see which
>> files are removed and which are analyzed. This should give us more
>> information on the issues.
>
>


--
To UNSUBSCRIBE, email to debian-kde-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: slrnhpcm7i.nfa.nospam@sshway.ssh.pusling.com">http ://lists.debian.org/slrnhpcm7i.nfa.nospam@sshway.ssh.pusling.com
 
Old 03-09-2010, 05:36 PM
Valerio Passini
 
Default Need for help in patching and packaging kdebase

Alle martedý 09 marzo 2010, Sune Vuorela ha scritto:
> cp ../patch.diff debian/patches
> echo patch.diff >> debian/patches/series
> dpkg-buildpackage (-jnumberofcores)

Sune, thank you very much for replying. I have built the packages, but I
can't install kdebase-runtime-dbg_4.4.1-0rc2_amd64.deb.
There are broken dependencies with kdelibs5-dbg. I don't know if it's
needed since I'm not facing a crash in strigi, but just in case, is
there anyway to install it?

Selecting previously deselected package kdebase-runtime-dbg.
(Reading database ... 292122 files and directories currently installed.)
Unpacking kdebase-runtime-dbg (from kdebase-runtime-
dbg_4.4.1-0rc2_amd64.deb) ...
dpkg: dependency problems prevent configuration of kdebase-runtime-dbg:
kdebase-runtime-dbg depends on kdelibs5-dbg; however:
Package kdelibs5-dbg is not installed.
dpkg: error processing kdebase-runtime-dbg (--install):
dependency problems - leaving unconfigured
Errors were encountered while processing:
kdebase-runtime-dbg


--
To UNSUBSCRIBE, email to debian-kde-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 201003091936.22374.valerio.passini@unicam.it">http ://lists.debian.org/201003091936.22374.valerio.passini@unicam.it
 
Old 03-09-2010, 06:55 PM
George Kiagiadakis
 
Default Need for help in patching and packaging kdebase

On Tue, Mar 9, 2010 at 8:36 PM, Valerio Passini
<valerio.passini@unicam.it> wrote:
> Alle marted─Ť 09 marzo 2010, Sune Vuorela ha scritto:
>> cp ../patch.diff debian/patches
>> echo patch.diff >> debian/patches/series
>> dpkg-buildpackage (-jnumberofcores)
>
> Sune, thank you very much for replying. I have built the packages, but I
> can't install kdebase-runtime-dbg_4.4.1-0rc2_amd64.deb.
> There are broken dependencies with kdelibs5-dbg. I don't know if it's
> needed since I'm not facing a crash in strigi, but just in case, is
> there anyway to install it?
>
> Selecting previously deselected package kdebase-runtime-dbg.
> (Reading database ... 292122 files and directories currently installed.)
> Unpacking kdebase-runtime-dbg (from kdebase-runtime-
> dbg_4.4.1-0rc2_amd64.deb) ...
> dpkg: dependency problems prevent configuration of kdebase-runtime-dbg:
> ┬*kdebase-runtime-dbg depends on kdelibs5-dbg; however:
> ┬*Package kdelibs5-dbg is not installed.
> dpkg: error processing kdebase-runtime-dbg (--install):
> ┬*dependency problems - leaving unconfigured
> Errors were encountered while processing:
> ┬*kdebase-runtime-dbg

Have you actually read the error message? It explains everything.
kdebase-runtime-dbg depends on kdelibs5-dbg but kdelibs5-dbg is not
installed. All you have to do is to install kdelibs5-dbg. Note that
dpkg does not automatically resolve dependencies, if that's what you
were expecting. You need a higher level tool for that, like apt-get
and aptitude.

So,
# aptitude install kdelibs5-dbg
# dpkg -i kdebase-runtime-dbg_4.4.1-0rc2_amd64.deb

Note that it is not necessary to install those -dbg packages if you do
not intend to provide a backtrace of a crash to upstream developers.

Regards,
George


--
To UNSUBSCRIBE, email to debian-kde-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: ba4a6e221003091155l26a6e4c0g8d42e394fdaa1976@mail. gmail.com">http://lists.debian.org/ba4a6e221003091155l26a6e4c0g8d42e394fdaa1976@mail. gmail.com
 
Old 03-09-2010, 08:49 PM
Valerio Passini
 
Default Need for help in patching and packaging kdebase

Alle martedý 09 marzo 2010, George Kiagiadakis ha scritto:
> Have you actually read the error message? It explains everything.
> kdebase-runtime-dbg depends on kdelibs5-dbg but kdelibs5-dbg is not
> installed. All you have to do is to install kdelibs5-dbg. Note that
> dpkg does not automatically resolve dependencies, if that's what you
> were expecting. You need a higher level tool for that, like apt-get
> and aptitude.

Sorry George, I meant that the dependencies were not automatically
resolvable by apt or aptitude. This is the output from aptitude:

The following NEW packages will be installed:
kdelibs5-dbg{b}
0 packages upgraded, 1 newly installed, 0 to remove and 5 not upgraded.
Need to get 103MB of archives. After unpacking 285MB will be used.
The following packages have unmet dependencies:
kdelibs5-dbg: Depends: libqt4-dbg (>= 4:4.6) but it is not going to be
installed.
The following actions will resolve these dependencies:

Keep the following packages at their current version:
1) kdelibs5-dbg [Not Installed]

Tier: Cancel all user actions (20000)

Accept this solution? [Y/n/q/?]

With N, aptitude ask to downgrade KDE that is against the purpose of
testing strigi.


--
To UNSUBSCRIBE, email to debian-kde-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 201003092249.17439.valerio.passini@unicam.it">http ://lists.debian.org/201003092249.17439.valerio.passini@unicam.it
 
Old 03-09-2010, 09:58 PM
George Kiagiadakis
 
Default Need for help in patching and packaging kdebase

On Tue, Mar 9, 2010 at 11:49 PM, Valerio Passini
<valerio.passini@unicam.it> wrote:
> Alle martedý 09 marzo 2010, George Kiagiadakis ha scritto:
>> Have you actually read the error message? It explains everything.
>> kdebase-runtime-dbg depends on kdelibs5-dbg but kdelibs5-dbg is not
>> installed. All you have to do is to install kdelibs5-dbg. Note that
>> dpkg does not automatically resolve dependencies, if that's what you
>> were expecting. You need a higher level tool for that, like apt-get
>> and aptitude.
>
> Sorry George, I meant that the dependencies were not automatically
> resolvable by apt or aptitude. This is the output from aptitude:
>
> The following NEW packages will be installed:
> *kdelibs5-dbg{b}
> 0 packages upgraded, 1 newly installed, 0 to remove and 5 not upgraded.
> Need to get 103MB of archives. After unpacking 285MB will be used.
> The following packages have unmet dependencies:
> *kdelibs5-dbg: Depends: libqt4-dbg (>= 4:4.6) but it is not going to be
> installed.
> The following actions will resolve these dependencies:
>
> * * Keep the following packages at their current version:
> 1) * * kdelibs5-dbg [Not Installed]
>
> * * Tier: Cancel all user actions (20000)
>
> Accept this solution? [Y/n/q/?]
>
> With N, aptitude ask to downgrade KDE that is against the purpose of
> testing strigi.

aptitude sometimes is too stupid to do the correct thing. The problem
is that the version of libqt4-dbg that it needs is in experimental, so
it avoids installing it by all possible means... Try "aptitude -t
experimental install libqt4-dbg" first and see if that helps.


--
To UNSUBSCRIBE, email to debian-kde-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: ba4a6e221003091458n1f4a85b5qcc223e9de38cb335@mail. gmail.com">http://lists.debian.org/ba4a6e221003091458n1f4a85b5qcc223e9de38cb335@mail. gmail.com
 
Old 03-09-2010, 11:49 PM
Valerio Passini
 
Default Need for help in patching and packaging kdebase

Alle martedý 09 marzo 2010, George Kiagiadakis ha scritto:
> On Tue, Mar 9, 2010 at 11:49 PM, Valerio Passini
>
> <valerio.passini@unicam.it> wrote:
> > Alle martedý 09 marzo 2010, George Kiagiadakis ha scritto:
> >> Have you actually read the error message? It explains everything.
> >> kdebase-runtime-dbg depends on kdelibs5-dbg but kdelibs5-dbg is
> >> not installed. All you have to do is to install kdelibs5-dbg.
> >> Note that dpkg does not automatically resolve dependencies, if
> >> that's what you were expecting. You need a higher level tool for
> >> that, like apt-get and aptitude.
> >
> > Sorry George, I meant that the dependencies were not automatically
> > resolvable by apt or aptitude. This is the output from aptitude:
> >
> > The following NEW packages will be installed:
> > kdelibs5-dbg{b}
> > 0 packages upgraded, 1 newly installed, 0 to remove and 5 not
> > upgraded. Need to get 103MB of archives. After unpacking 285MB
> > will be used. The following packages have unmet dependencies:
> > kdelibs5-dbg: Depends: libqt4-dbg (>= 4:4.6) but it is not going
> > to be installed.
> > The following actions will resolve these dependencies:
> >
> > Keep the following packages at their current version:
> > 1) kdelibs5-dbg [Not Installed]
> >
> > Tier: Cancel all user actions (20000)
> >
> > Accept this solution? [Y/n/q/?]
> >
> > With N, aptitude ask to downgrade KDE that is against the purpose
> > of testing strigi.
>
> aptitude sometimes is too stupid to do the correct thing. The problem
> is that the version of libqt4-dbg that it needs is in experimental,
> so it avoids installing it by all possible means... Try "aptitude -t
> experimental install libqt4-dbg" first and see if that helps.

Thank you, it worked.
Finally I have been able to produce this log Sebastian Trueg was looking
for to debug strigi. Really thanks for your help.

Valerio


--
To UNSUBSCRIBE, email to debian-kde-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 201003100149.51281.valerio.passini@unicam.it">http ://lists.debian.org/201003100149.51281.valerio.passini@unicam.it
 
Old 03-10-2010, 09:17 AM
Modestas Vainius
 
Default Need for help in patching and packaging kdebase

Hello,

On tre─Źiadienis 10 Kovas 2010 00:58:53 George Kiagiadakis wrote:
> > The following NEW packages will be installed:
> > kdelibs5-dbg{b}
> > 0 packages upgraded, 1 newly installed, 0 to remove and 5 not upgraded.
> > Need to get 103MB of archives. After unpacking 285MB will be used.
> > The following packages have unmet dependencies:
> > kdelibs5-dbg: Depends: libqt4-dbg (>= 4:4.6) but it is not going to be
> > installed.
> > The following actions will resolve these dependencies:
> >
> > Keep the following packages at their current version:
> > 1) kdelibs5-dbg [Not Installed]
> >
> > Tier: Cancel all user actions (20000)
> >
> > Accept this solution? [Y/n/q/?]
> >
> > With N, aptitude ask to downgrade KDE that is against the purpose of
> > testing strigi.
>
> aptitude sometimes is too stupid to do the correct thing. The problem
> is that the version of libqt4-dbg that it needs is in experimental, so
> it avoids installing it by all possible means... Try "aptitude -t
> experimental install libqt4-dbg" first and see if that helps.

Actually, aptitude is not stupid, but rather way more predictable now. The
solution you are looking for would be in tier 50000 so what was needed just
pressing N a couple of times.


--
Modestas Vainius <modestas@vainius.eu>
 

Thread Tools




All times are GMT. The time now is 04:07 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright ę2007 - 2008, www.linux-archive.org