FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Debian > Debian Java

 
 
LinkBack Thread Tools
 
Old 05-02-2012, 08:30 AM
Mathieu Malaterre
 
Default /usr/bin/fop: Unable to locate servlet-api in /usr/share/java

Hi there,

I am getting this annoying warning again:

[warning] /usr/bin/fop: Unable to locate servlet-api in /usr/share/java

I used to fix it by installing libservlet2.4-java, now that we have
switch to libservlet2.5-java in fop it does not work anymore. In fact:

$ grep servlet /usr/bin/fop
find_jars batik-all commons-logging servlet-api xercesImpl xmlgraphics-commons

However the package does not provide a version-less jar anymore:

$ ls -al /usr/share/java/servlet-api*.jar
-rw-r--r-- 1 root root 88360 Apr 14 18:02 /usr/share/java/servlet-api-2.5.jar

Is this really an issue ? Who should I report this issue to ?

Thanks much,
-M


--
To UNSUBSCRIBE, email to debian-java-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: CA+7wUszbccj=gSrUh7Hk+Wk_DBVPNtYcVBLizj1SXeyXUnsbD Q@mail.gmail.com">http://lists.debian.org/CA+7wUszbccj=gSrUh7Hk+Wk_DBVPNtYcVBLizj1SXeyXUnsbD Q@mail.gmail.com
 
Old 05-02-2012, 05:41 PM
Onkar Shinde
 
Default /usr/bin/fop: Unable to locate servlet-api in /usr/share/java

On Wed, May 2, 2012 at 2:00 PM, Mathieu Malaterre <malat@debian.org> wrote:
> Hi there,
>
> *I am getting this annoying warning again:
>
> [warning] /usr/bin/fop: Unable to locate servlet-api in /usr/share/java
>
> *I used to fix it by installing libservlet2.4-java, now that we have
> switch to libservlet2.5-java in fop it does not work anymore. In fact:
>
> $ grep servlet /usr/bin/fop
> find_jars batik-all commons-logging servlet-api xercesImpl xmlgraphics-commons
>
> However the package does not provide a version-less jar anymore:
>
> $ ls -al /usr/share/java/servlet-api*.jar
> -rw-r--r-- 1 root root 88360 Apr 14 18:02 /usr/share/java/servlet-api-2.5.jar
>
> Is this really an issue ? Who should I report this issue to ?

This seems to be a minor mistake left over during transition from
libservlet2.4-java to libservlet2.5-java.
In my opinion, 'servlet-api' should be removed from the launcher
script. This library is only required by the few servlets included in
fop.

Please feel free to file a minor bug in Debian BTS.

Cheers,
Onkar
--
Passion - Some people climb mountains - others write Free software.
Don't ask why - the reason is the same.


--
To UNSUBSCRIBE, email to debian-java-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: CAKBPJyjqVwCD_MPGLUdoPcH1u1yaN==5VsnkHz9xdzqQ+Rjp= A@mail.gmail.com">http://lists.debian.org/CAKBPJyjqVwCD_MPGLUdoPcH1u1yaN==5VsnkHz9xdzqQ+Rjp= A@mail.gmail.com
 

Thread Tools




All times are GMT. The time now is 06:45 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org