FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Debian > Debian Java

 
 
LinkBack Thread Tools
 
Old 01-20-2012, 10:34 AM
Jörg Kurlbaum
 
Default Bug#656599: default-jdk: Java JDK not installable on squeeze

Package: default-jdk
Severity: important

On my very basic squeeze installation default-jdk and other java packages are
not installable due to dependecy problems. The packages openjdk-6-jdk is also not installable

Output:

root@fff:~# LANG=C apt-get install openjdk-6-jdk
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
openjdk-6-jdk : Depends: openjdk-6-jre (>= 6b18-1.8.10-0+squeeze2) but it is not going to be installed
E: Broken packages

I suspect some misconfiguration of apt. But could not find any hints


-- System Information:
Debian Release: 6.0.3
APT prefers stable
APT policy: (990, 'stable')
Architecture: amd64 (x86_64)

Kernel: Linux 2.6.32-5-amd64 (SMP w/2 CPU cores)
Locale: LANG=de_DE.UTF-8, LC_CTYPE=de_DE.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

--
Jörg Kurlbaum (joerg.kurlbaum@neuland-bfi.de) neuland:::Büro für Informatik
GPG-ID: 10FDA31F Konsul-Smidt Str. 8g
T: 0421/380107-55 28217 Bremen



--
To UNSUBSCRIBE, email to debian-java-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 20120120113028.14187.19424.reportbug@hybris-app-live1">http://lists.debian.org/20120120113028.14187.19424.reportbug@hybris-app-live1
 
Old 01-20-2012, 11:24 AM
Xerxes Rånby
 
Default Bug#656599: default-jdk: Java JDK not installable on squeeze

2012-01-20 12:34, Jörg Kurlbaum skrev:
> Package: default-jdk
> Severity: important
>
> On my very basic squeeze installation default-jdk and other java packages are
> not installable due to dependecy problems. The packages openjdk-6-jdk is also not installable
>
> Output:
>
> root@fff:~# LANG=C apt-get install openjdk-6-jdk
> Reading package lists... Done
> Building dependency tree
> Reading state information... Done
> Some packages could not be installed. This may mean that you have
> requested an impossible situation or if you are using the unstable
> distribution that some required packages have not yet been created
> or been moved out of Incoming.
> The following information may help to resolve the situation:
>
> The following packages have unmet dependencies:
> openjdk-6-jdk : Depends: openjdk-6-jre (>= 6b18-1.8.10-0+squeeze2) but it is not going to be installed
> E: Broken packages

6b18-1.8.10-0+squeeze2 are currently found in the Debian security repository.
http://security.debian.org/debian-security/pool/updates/main/o/openjdk-6/

>
> I suspect some misconfiguration of apt. But could not find any hints

try add
deb http://security.debian.org/ squeeze/updates main contrib non-free
to /etc/apt/sources.list

and then re-run
apt-get update
apt-get install openjdk-6-jdk

Cheers
Xerxes



--
To UNSUBSCRIBE, email to debian-java-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 4F195D18.6000306@zafena.se">http://lists.debian.org/4F195D18.6000306@zafena.se
 
Old 01-21-2012, 12:11 PM
peter green
 
Default Bug#656599: default-jdk: Java JDK not installable on squeeze

Jörg Kurlbaum wrote:
>The following packages have unmet dependencies:
> openjdk-6-jdk : Depends: openjdk-6-jre (>= 6b18-1.8.10-0+squeeze2)
but it is not going to be installed

> E: Broken packages
>
>I suspect some misconfiguration of apt. But could not find any hints

Can you post the complete contents of your /etc/apt/sources.list

I would guess that either you don't have a regular mirror configured at all
or the regular mirror you have configured is out of date.

Xerxes Rånby wrote:
>try add
>deb http://security.debian.org/ squeeze/updates main contrib non-free
>to /etc/apt/sources.list
It's pretty clear he already has the security archive in his sources.list.
If he didn't then he wouldn't be trying to install a version of
openjdk-6-jdk

with that depends line.

Note that "is not going to be installed" does not mean a package is
not available, it simply means apt is not planning to install it for some
reason.



--
To UNSUBSCRIBE, email to debian-java-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 4F1AB992.7080502@p10link.net">http://lists.debian.org/4F1AB992.7080502@p10link.net
 
Old 01-26-2012, 10:33 AM
Jörg Kurlbaum
 
Default Bug#656599: default-jdk: Java JDK not installable on squeeze

On Sat, Jan 21, 2012 at 01:11:46PM +0000, peter green wrote:
> Can you post the complete contents of your /etc/apt/sources.list

I've only files in sources.list.d.

root@fff:/etc/apt/sources.list.d# cat *
deb http://192.168.200.130/debian squeeze main
deb http://ftp.de.debian.org/debian/ stable main contrib non-free
deb-src http://ftp.de.debian.org/debian/ stable main contrib non-free

deb http://security.debian.org/ stable/updates main
deb-src http://security.debian.org/ stable/updates main


The local debian Repo has only one or two self-made packages, not
related to any java package.

We had some proxies configured and i thought, that this could be the
reason, maybe some outdated Release file. But after removing all proxy
configuration, the effect is the same.

Here is the complete "apt-config dump"
APT "";
APT::Architecture "amd64";
APT::Build-Essential "";
APT::Build-Essential:: "build-essential";
APT::Install-Recommends "1";
APT::Install-Suggests "0";
APT::Acquire "";
APT::Acquire::Translation "environment";
APT::Authentication "";
APT::Authentication::TrustCDROM "true";
APT::NeverAutoRemove "";
APT::NeverAutoRemove:: "^firmware-linux.*";
APT::NeverAutoRemove:: "^linux-firmware$";
APT::NeverAutoRemove:: "^linux-image.*";
APT::NeverAutoRemove:: "^kfreebsd-image.*";
APT::NeverAutoRemove:: "^linux-restricted-modules.*";
APT::NeverAutoRemove:: "^linux-ubuntu-modules-.*";
APT::Never-MarkAuto-Sections "";
APT::Never-MarkAuto-Sections:: "metapackages";
APT::Never-MarkAuto-Sections:: "restricted/metapackages";
APT::Never-MarkAuto-Sections:: "universe/metapackages";
APT::Never-MarkAuto-Sections:: "multiverse/metapackages";
APT::Never-MarkAuto-Sections:: "oldlibs";
APT::Never-MarkAuto-Sections:: "restricted/oldlibs";
APT::Never-MarkAuto-Sections:: "universe/oldlibs";
APT::Never-MarkAuto-Sections:: "multiverse/oldlibs";
APT::Periodic "";
APT::Periodic::Enable "1";
APT::Periodic::Update-Package-Lists "1";
APT:efault-Release "stable";
Dir "/";
Dir::State "var/lib/apt/";
Dir::State::lists "lists/";
Dir::State::cdroms "cdroms.list";
Dir::State::mirrors "mirrors/";
Dir::State::extended_states "extended_states";
Dir::State::status "/var/lib/dpkg/status";
Dir::Cache "var/cache/apt/";
Dir::Cache::archives "archives/";
Dir::Cache::srcpkgcache "srcpkgcache.bin";
Dir::Cache:kgcache "pkgcache.bin";
Dir::Etc "etc/apt/";
Dir::Etc::sourcelist "sources.list";
Dir::Etc::sourceparts "sources.list.d";
Dir::Etc::vendorlist "vendors.list";
Dir::Etc::vendorparts "vendors.list.d";
Dir::Etc::main "apt.conf";
Dir::Etc::netrc "auth.conf";
Dir::Etc:arts "apt.conf.d";
Dir::Etc:references "preferences";
Dir::Etc:referencesparts "preferences.d";
Dir::Etc::trusted "trusted.gpg";
Dir::Etc::trustedparts "trusted.gpg.d";
Dir::Bin "";
Dir::Bin::methods "/usr/lib/apt/methods";
Dir::Bin::dpkg "/usr/bin/dpkg";
Dir::Media "";
Dir::Media::MountPath "/media/cdrom";
Dir::Log "var/log/apt";
Dir::Log::Terminal "term.log";
Dir::Log::History "history.log";
Dir::Ignore-Files-Silently "";
Dir::Ignore-Files-Silently:: "~$";
Dir::Ignore-Files-Silently:: ".disabled$";
Dir::Ignore-Files-Silently:: ".bak$";
Dir::Ignore-Files-Silently:: ".dpkg-[a-z]+$";
Acquire "";
Acquire::cdrom "";
Acquire::cdrom::mount "/media/cdrom";
Acquire::Languages "";
Acquire::Languages:: "environment";
Acquire::Languages:: "de";
Acquire::Languages:: "en";
DPkg "";
DPkg::Pre-Invoke "";
DPkg::Pre-Invoke:: "if [ -x /usr/sbin/etckeeper ]; then etckeeper
pre-install; fi";
DPkg::Post-Invoke "";
DPkg::Post-Invoke:: "if [ -x /usr/sbin/etckeeper ]; then etckeeper
post-install; fi";
DPkg::Pre-Install-Pkgs "";
DPkg::Pre-Install-Pkgs:: "/usr/sbin/dpkg-preconfigure --apt || true";
RPM "";
RPM::Pre-Invoke "";
RPM::Pre-Invoke:: "if [ -x /usr/sbin/etckeeper ]; then etckeeper
pre-install; fi";
RPM::Post-Invoke "";
RPM::Post-Invoke:: "if [ -x /usr/sbin/etckeeper ]; then etckeeper
post-install; fi";
CommandLine "";
CommandLine::AsString "apt-config dump";


I've no preferences file


Do you have any more hints?

apt version is: 0.8.10.3+squeeze1
dpkg version is: 1.15.8.11


Maybe this bug should be moved to apt or dpkg, since i think it's not
related to the java packages, or is it?


Best regards,
Jörg :-)




--
Jörg Kurlbaum (jkur@corsario.org)
GPG-ID: CAC40EA9 Fingerprint: D4D4 9F5E D3C7 86B2 0D7F 67F9 9B22 7396 CAC4 0EA9



--
To UNSUBSCRIBE, email to debian-java-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 20120126113315.GA5075@kropotkin.neuland-bfi.de">http://lists.debian.org/20120126113315.GA5075@kropotkin.neuland-bfi.de
 
Old 02-26-2012, 01:28 PM
Matthias Klose
 
Default Bug#656599: default-jdk: Java JDK not installable on squeeze

> The following packages have unmet dependencies:
> openjdk-6-jdk : Depends: openjdk-6-jre (>= 6b18-1.8.10-0+squeeze2)
> but it is not going to be installed
> E: Broken packages

try to install openjdk-6-jre directly, and every package with such a message
until you see the cause of the issue.




--
To UNSUBSCRIBE, email to debian-java-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 4F4A4174.5020103@debian.org">http://lists.debian.org/4F4A4174.5020103@debian.org
 

Thread Tools




All times are GMT. The time now is 09:37 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright ©2007 - 2008, www.linux-archive.org