FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Debian > Debian Java

 
 
LinkBack Thread Tools
 
Old 01-05-2012, 12:52 PM
Mathieu Malaterre
 
Default Please upload fop (svn)

Hi DDs,

Happy New Year !

I'd appreciate if someone could upload the latest (and greatest) of
fop debian package. My last commit split the package into two separate
packages. I am not allowed to upload this kind of changes as DM.

I am interested in feedback on the fop binary package. I am hoping I
did everything right for transition from squeeze.

Thanks
--
Mathieu


--
To UNSUBSCRIBE, email to debian-java-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: CA+7wUsy2oiO-UBWgUWWwtTgFSupUN9LZy+XRWQKGKf8qrdMqvg@mail.gmail. com">http://lists.debian.org/CA+7wUsy2oiO-UBWgUWWwtTgFSupUN9LZy+XRWQKGKf8qrdMqvg@mail.gmail. com
 
Old 01-09-2012, 08:39 PM
"Damien Raude-Morvan"
 
Default Please upload fop (svn)

Le jeudi 05 janvier 2012 14:52:37, Mathieu Malaterre a écrit :
> Hi DDs,

Salut Mathieu

> Happy New Year !

Thanks ! Happy debian hacking for this new year

> I'd appreciate if someone could upload the latest (and greatest) of
> fop debian package. My last commit split the package into two separate
> packages. I am not allowed to upload this kind of changes as DM.
>
> I am interested in feedback on the fop binary package. I am hoping I
> did everything right for transition from squeeze.

Since you moved files from fop to libfop-java, I think you should add :
Replaces: fop (<< 1:1.0.dfsg2-6)
Breaks: fop (<< 1:1.0.dfsg2-6)
to libfop-java ?

Cheers,
--
Damien


--
To UNSUBSCRIBE, email to debian-java-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 201201092239.44206.drazzib@drazzib.com">http://lists.debian.org/201201092239.44206.drazzib@drazzib.com
 
Old 01-11-2012, 06:30 AM
Mathieu Malaterre
 
Default Please upload fop (svn)

Salut Damien,

On Mon, Jan 9, 2012 at 10:39 PM, Damien Raude-Morvan
<drazzib@drazzib.com> wrote:
> Le jeudi 05 janvier 2012 14:52:37, Mathieu Malaterre a écrit :
>> Hi DDs,
>
> Salut Mathieu
>
>> * Happy New Year !
>
> Thanks ! Happy debian hacking for this new year
>
>> * I'd appreciate if someone could upload the latest (and greatest) of
>> fop debian package. My last commit split the package into two separate
>> packages. I am not allowed to upload this kind of changes as DM.
>>
>> * I am interested in feedback on the fop binary package. I am hoping I
>> did everything right for transition from squeeze.
>
> Since you moved files from fop to libfop-java, I think you should add :
> Replaces: fop (<< 1:1.0.dfsg2-6)
> Breaks: fop (<< 1:1.0.dfsg2-6)
> to libfop-java ?

I did apply you change on the svn however I still worried this is not
correct. fop package is still available it now has a new Depends:
libfop-java. I can see why libfop-java 1:1.0.dfsg2-6 and fop
1:1.0.dfsg2-5 will not work nicely together. But I fails to see a
relation of Breaks and Replaces. Shouldn't it be a Conflicts: ?

Thanks for your comments,
--
Mathieu


--
To UNSUBSCRIBE, email to debian-java-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: CA+7wUsymh0JkxxCGXXRX1Ure4K2AugU8F-yKL=wtTPYKjCcu3A@mail.gmail.com">http://lists.debian.org/CA+7wUsymh0JkxxCGXXRX1Ure4K2AugU8F-yKL=wtTPYKjCcu3A@mail.gmail.com
 
Old 01-11-2012, 01:55 PM
Vincent Fourmond
 
Default Please upload fop (svn)

Hello,

On Wed, Jan 11, 2012 at 8:30 AM, Mathieu Malaterre
<mathieu.malaterre@gmail.com> wrote:
>> Since you moved files from fop to libfop-java, I think you should add :
>> Replaces: fop (<< 1:1.0.dfsg2-6)
>> Breaks: fop (<< 1:1.0.dfsg2-6)
>> to libfop-java ?
>
> I did apply you change on the svn however I still worried this is not
> correct. fop package is still available it now has a new Depends:
> libfop-java. I can see why libfop-java 1:1.0.dfsg2-6 and fop
> 1:1.0.dfsg2-5 will not work nicely together. But I fails to see a
> relation of Breaks and Replaces. Shouldn't it be a Conflicts: ?

Breaks is a less strong requirement than Conflicts and is the
correct choice in this case. Quoting policy 7.3:

Many of the cases where Breaks should be used were previously handled
with Conflicts because Breaks did not yet exist. Many Conflicts fields
should now be Breaks. See Conflicting binary packages - Conflicts,
Section 7.4 for more information about the differences.

Cheers,

Vincent


--
To UNSUBSCRIBE, email to debian-java-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: CAEnRq5O0fjeSrbCkdXCh7sQYT6YSXFLWuB5FhhaGyofmNJdxc w@mail.gmail.com">http://lists.debian.org/CAEnRq5O0fjeSrbCkdXCh7sQYT6YSXFLWuB5FhhaGyofmNJdxc w@mail.gmail.com
 
Old 01-11-2012, 08:58 PM
"Damien Raude-Morvan"
 
Default Please upload fop (svn)

Le mercredi 11 janvier 2012 08:30:08, Mathieu Malaterre a écrit :
> > Since you moved files from fop to libfop-java, I think you should add :
> > Replaces: fop (<< 1:1.0.dfsg2-6)
> > Breaks: fop (<< 1:1.0.dfsg2-6)
> > to libfop-java ?
>
> I did apply you change on the svn however I still worried this is not
> correct. fop package is still available it now has a new Depends:
> libfop-java. I can see why libfop-java 1:1.0.dfsg2-6 and fop
> 1:1.0.dfsg2-5 will not work nicely together. But I fails to see a
> relation of Breaks and Replaces. Shouldn't it be a Conflicts: ?

I've just followed Debian Policy here (see §7.6.1) :

if a package foo is split into foo and foo-data starting at version 1.2-3,
foo-data would have the fields

Replaces: foo (<< 1.2-3)
Breaks: foo (<< 1.2-3)
in its control file. The new version of the package foo would normally have the
field

Depends: foo-data (>= 1.2-3)
(or possibly Recommends or even Suggests if the files moved into foo-data are
not required for normal operation).

See,
http://www.debian.org/doc/debian-policy/ch-relationships.html#s-conflicts
and
http://www.debian.org/doc/debian-policy/ch-relationships.html#s-replaces

Cheers,
--
Damien


--
To UNSUBSCRIBE, email to debian-java-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 201201112258.56279.drazzib@drazzib.com">http://lists.debian.org/201201112258.56279.drazzib@drazzib.com
 
Old 01-15-2012, 09:14 AM
Mathieu Malaterre
 
Default Please upload fop (svn)

On Wed, Jan 11, 2012 at 10:58 PM, Damien Raude-Morvan
<drazzib@drazzib.com> wrote:
> Le mercredi 11 janvier 2012 08:30:08, Mathieu Malaterre a écrit :
>> > Since you moved files from fop to libfop-java, I think you should add :
>> > Replaces: fop (<< 1:1.0.dfsg2-6)
>> > Breaks: fop (<< 1:1.0.dfsg2-6)
>> > to libfop-java ?
>>
>> I did apply you change on the svn however I still worried this is not
>> correct. fop package is still available it now has a new Depends:
>> libfop-java. I can see why libfop-java 1:1.0.dfsg2-6 and fop
>> 1:1.0.dfsg2-5 will not work nicely together. But I fails to see a
>> relation of Breaks and Replaces. Shouldn't it be a Conflicts: ?
>
> I've just followed Debian Policy here (see §7.6.1) :
>
> if a package foo is split into foo and foo-data starting at version 1.2-3,
> foo-data would have the fields
>
> * * Replaces: foo (<< 1.2-3)
> * * Breaks: foo (<< 1.2-3)
> in its control file. The new version of the package foo would normally have the
> field
>
> * * Depends: foo-data (>= 1.2-3)
> (or possibly Recommends or even Suggests if the files moved into foo-data are
> not required for normal operation).
>
> See,
> http://www.debian.org/doc/debian-policy/ch-relationships.html#s-conflicts
> and
> http://www.debian.org/doc/debian-policy/ch-relationships.html#s-replaces

Thanks everyone for the confirmation. I feel confident the package is
in good shape now.
Could anyone (DD) please upload the latest from fop (pkg-java svn). I
have just dch -r'ed it.

Thanks,
--
Mathieu


--
To UNSUBSCRIBE, email to debian-java-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: CA+7wUswGsBt6_UF7AV21ADFDwAPTAnokY4rqnk-_d6JeQb8Ygg@mail.gmail.com">http://lists.debian.org/CA+7wUswGsBt6_UF7AV21ADFDwAPTAnokY4rqnk-_d6JeQb8Ygg@mail.gmail.com
 
Old 01-15-2012, 10:27 AM
"Damien Raude-Morvan"
 
Default Please upload fop (svn)

Hi Mathieu,

Le dimanche 15 janvier 2012 11:14:41, Mathieu Malaterre a écrit :
> On Wed, Jan 11, 2012 at 10:58 PM, Damien Raude-Morvan
> Thanks everyone for the confirmation. I feel confident the package is
> in good shape now.
> Could anyone (DD) please upload the latest from fop (pkg-java svn). I
> have just dch -r'ed it.

Hop... uploaded!

Cheers,
--
Damien


--
To UNSUBSCRIBE, email to debian-java-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 201201151227.19256.drazzib@drazzib.com">http://lists.debian.org/201201151227.19256.drazzib@drazzib.com
 

Thread Tools




All times are GMT. The time now is 02:24 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright ©2007 - 2008, www.linux-archive.org