FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Debian > Debian Java

 
 
LinkBack Thread Tools
 
Old 12-15-2011, 12:28 PM
Thomas Koch
 
Default Set version automatically in maven-repo-helper

Hi,

I use jh_maven_repo_helper to install .jar and pom.xml files[1]. I hoped that
maven-repo-helper would set the version automatically according to the debian
package version, but it apparently doesn't.

Is is possible and recommended to handle this with:

UPSTREAM-VERSION := $(shell dpkg-parsechangelog | sed -rne 's,^Version:
([^-+]+).*,1,p')

override_mh_install:
--set-version=$(UPSTREAM-VERSION)

[1] http://anonscm.debian.org/gitweb/?p=pkg-
scala/packages/scala.git;a=tree;h=refs/heads/thkoch_pls_review

Regards,

Thomas Koch, http://www.koch.ro


--
To UNSUBSCRIBE, email to debian-java-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 201112151428.51448.thomas@koch.ro">http://lists.debian.org/201112151428.51448.thomas@koch.ro
 
Old 12-15-2011, 09:39 PM
Ludovic Claude
 
Default Set version automatically in maven-repo-helper

Yes, that is an option supported by mh_install.

You should write in d/rules:

UPSTREAM-VERSION := $(shell dpkg-parsechangelog | sed -rne 's,^Version:
([^-+]+).*,1,p')

override_mh_install:
mh_install --set-version=$(UPSTREAM-VERSION)

The man page of mh_install lists all options supported by this tool.

Ludovic

On 15/12/2011 14:28, Thomas Koch wrote:
> Hi,
>
> I use jh_maven_repo_helper to install .jar and pom.xml files[1]. I hoped that
> maven-repo-helper would set the version automatically according to the debian
> package version, but it apparently doesn't.
>
> Is is possible and recommended to handle this with:
>
> UPSTREAM-VERSION := $(shell dpkg-parsechangelog | sed -rne 's,^Version:
> ([^-+]+).*,1,p')
>
> override_mh_install:
> --set-version=$(UPSTREAM-VERSION)
>
> [1] http://anonscm.debian.org/gitweb/?p=pkg-
> scala/packages/scala.git;a=tree;h=refs/heads/thkoch_pls_review
>
> Regards,
>
> Thomas Koch, http://www.koch.ro
>
>


--
To UNSUBSCRIBE, email to debian-java-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 4EEA7709.1070509@laposte.net">http://lists.debian.org/4EEA7709.1070509@laposte.net
 

Thread Tools




All times are GMT. The time now is 11:33 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org