FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Debian > Debian Java

 
 
LinkBack Thread Tools
 
Old 08-30-2011, 04:11 PM
shirish शिरीष
 
Default Unable to install icedtea-plugin

Hi all,
I am on sid/unstable. I have three openjdk packages installed.

i openjdk-6-jre - OpenJDK Java
runtime, using Hotspot JIT
i openjdk-6-jre-headless - OpenJDK Java
runtime, using Hotspot JIT (headless)
i openjdk-6-jre-lib - OpenJDK Java
runtime (architecture independent libraries)

Now I have been trying to install icedtea-plugin (for using java in a
web-browser for sites which use java) but have been unable to install
as it gives a conflict.

$ sudo aptitude install icedtea-plugin
The following NEW packages will be installed:
icedtea-netx{a} icedtea-plugin xulrunner-1.9.1{ab}
0 packages upgraded, 3 newly installed, 0 to remove and 1 not upgraded.
Need to get 8,642 kB/9,103 kB of archives. After unpacking 26.5 MB will be used.
The following packages have unmet dependencies:
openjdk-6-jre-headless: Conflicts: icedtea-netx (< 1.1.1-2~) but
1.1-1 is to be installed.
xulrunner-1.9.1: Depends: libmozjs2d (= 1.9.1.16-6) but 1.9.1.16-9
is installed.
The following actions will resolve these dependencies:

Keep the following packages at their current version:
1) icedtea-netx [Not Installed]
2) icedtea-plugin [Not Installed]
3) xulrunner-1.9.1 [Not Installed]



Accept this solution? [Y/n/q/?] n
The following actions will resolve these dependencies:

Downgrade the following packages:
1) default-jre [1:1.6-43 (now, unstable) -> 1:1.6-40 (stable,
testing)]
2) default-jre-headless [1:1.6-43 (now, unstable) -> 1:1.6-40
(stable, testing)]
3) icedtea-6-jre-cacao [6b23~pre8-2 (now, unstable) -> 6b23~pre7-1
(testing)]
4) icedtea-6-jre-jamvm [6b23~pre8-2 (now, unstable) -> 6b23~pre7-1
(testing)]
5) libmozjs2d [1.9.1.16-9 (now) -> 1.9.1.16-6 (stable)]
6) openjdk-6-jre [6b23~pre8-2 (now, unstable) -> 6b23~pre7-1
(testing)]
7) openjdk-6-jre-headless [6b23~pre8-2 (now, unstable) ->
6b23~pre7-1 (testing)]



Accept this solution? [Y/n/q/?] n
The following actions will resolve these dependencies:

Remove the following packages:
1) icedtea-6-jre-jamvm

Downgrade the following packages:
2) default-jre [1:1.6-43 (now, unstable) -> 1:1.6-40 (stable,
testing)]
3) default-jre-headless [1:1.6-43 (now, unstable) -> 1:1.6-40
(stable, testing)]
4) icedtea-6-jre-cacao [6b23~pre8-2 (now, unstable) -> 6b23~pre7-1
(testing)]
5) libmozjs2d [1.9.1.16-9 (now) -> 1.9.1.16-6 (stable)]
6) openjdk-6-jre [6b23~pre8-2 (now, unstable) -> 6b23~pre7-1
(testing)]
7) openjdk-6-jre-headless [6b23~pre8-2 (now, unstable) ->
6b23~pre7-1 (testing)]

Leave the following dependencies unresolved:
8) openjdk-6-jre-headless recommends icedtea-6-jre-jamvm (=
6b23~pre7-1)


Accept this solution? [Y/n/q/?] n
The following actions will resolve these dependencies:

Remove the following packages:
1) default-jre

Downgrade the following packages:
2) default-jre-headless [1:1.6-43 (now, unstable) -> 1:1.6-40
(stable, testing)]
3) icedtea-6-jre-cacao [6b23~pre8-2 (now, unstable) -> 6b23~pre7-1
(testing)]
4) icedtea-6-jre-jamvm [6b23~pre8-2 (now, unstable) -> 6b23~pre7-1
(testing)]
5) libmozjs2d [1.9.1.16-9 (now) -> 1.9.1.16-6 (stable)]
6) openjdk-6-jre [6b23~pre8-2 (now, unstable) -> 6b23~pre7-1
(testing)]
7) openjdk-6-jre-headless [6b23~pre8-2 (now, unstable) ->
6b23~pre7-1 (testing)]



Accept this solution? [Y/n/q/?] n
The following actions will resolve these dependencies:

Remove the following packages:
1) default-jre
2) icedtea-6-jre-jamvm

Downgrade the following packages:
3) default-jre-headless [1:1.6-43 (now, unstable) -> 1:1.6-40
(stable, testing)]
4) icedtea-6-jre-cacao [6b23~pre8-2 (now, unstable) -> 6b23~pre7-1
(testing)]
5) libmozjs2d [1.9.1.16-9 (now) -> 1.9.1.16-6 (stable)]
6) openjdk-6-jre [6b23~pre8-2 (now, unstable) -> 6b23~pre7-1
(testing)]
7) openjdk-6-jre-headless [6b23~pre8-2 (now, unstable) ->
6b23~pre7-1 (testing)]

Leave the following dependencies unresolved:
8) openjdk-6-jre-headless recommends icedtea-6-jre-jamvm (=
6b23~pre7-1)


Accept this solution? [Y/n/q/?] n
The following actions will resolve these dependencies:

Remove the following packages:
1) icedtea-6-jre-cacao

Downgrade the following packages:
2) default-jre [1:1.6-43 (now, unstable) -> 1:1.6-40 (stable,
testing)]
3) default-jre-headless [1:1.6-43 (now, unstable) -> 1:1.6-40
(stable, testing)]
4) icedtea-6-jre-jamvm [6b23~pre8-2 (now, unstable) -> 6b23~pre7-1
(testing)]
5) libmozjs2d [1.9.1.16-9 (now) -> 1.9.1.16-6 (stable)]
6) openjdk-6-jre [6b23~pre8-2 (now, unstable) -> 6b23~pre7-1
(testing)]
7) openjdk-6-jre-headless [6b23~pre8-2 (now, unstable) ->
6b23~pre7-1 (testing)]

Leave the following dependencies unresolved:
8) openjdk-6-jre-headless recommends icedtea-6-jre-cacao (=
6b23~pre7-1)


Accept this solution? [Y/n/q/?] q
Abandoning all efforts to resolve these dependencies.
Abort.
21:34:57 shirish@deb-home:~$ sudo aptitude install icedtea-plugin
openjdk-6-jre-headless
The following NEW packages will be installed:
icedtea-netx{a} icedtea-plugin xulrunner-1.9.1{ab}
0 packages upgraded, 3 newly installed, 0 to remove and 1 not upgraded.
Need to get 8,642 kB/9,103 kB of archives. After unpacking 26.5 MB will be used.
The following packages have unmet dependencies:
openjdk-6-jre-headless: Conflicts: icedtea-netx (< 1.1.1-2~) but
1.1-1 is to be installed.
xulrunner-1.9.1: Depends: libmozjs2d (= 1.9.1.16-6) but 1.9.1.16-9
is installed.
The following actions will resolve these dependencies:

Keep the following packages at their current version:
1) icedtea-netx [Not Installed]
2) icedtea-plugin [Not Installed]
3) xulrunner-1.9.1 [Not Installed]



Accept this solution? [Y/n/q/?] q
Abandoning all efforts to resolve these dependencies.
Abort.

Sorry for the noise but that's the way it is. Can somebody share how I
can have java both for the desktop and java-plugin for the web.

Looking forward for info.
--
* * * * * Regards,
* * * * * Shirish Agarwal* शिरीष अग्रवाल
* My quotes in this email licensed under CC 3.0
http://creativecommons.org/licenses/by-nc/3.0/
http://flossexperiences.wordpress.com
065C 6D79 A68C E7EA 52B3* 8D70 950D 53FB 729A 8B17


--
To UNSUBSCRIBE, email to debian-java-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: CADdDZRnXfJQqG+_4Vr71M3SBmPskHBQqci88MtFTUNQ02vngs g@mail.gmail.com">http://lists.debian.org/CADdDZRnXfJQqG+_4Vr71M3SBmPskHBQqci88MtFTUNQ02vngs g@mail.gmail.com
 
Old 08-30-2011, 05:24 PM
Mehdi Dogguy
 
Default Unable to install icedtea-plugin

On 30/08/2011 18:11, shirish शिरीष wrote:
> Hi all,
> I am on sid/unstable. I have three openjdk packages installed.
>
> i openjdk-6-jre - OpenJDK Java
> runtime, using Hotspot JIT
> i openjdk-6-jre-headless - OpenJDK Java
> runtime, using Hotspot JIT (headless)
> i openjdk-6-jre-lib - OpenJDK Java
> runtime (architecture independent libraries)
>
> Now I have been trying to install icedtea-plugin (for using java in a
> web-browser for sites which use java) but have been unable to install
> as it gives a conflict.
>
>[…]
>
> Sorry for the noise but that's the way it is. Can somebody share how I
> can have java both for the desktop and java-plugin for the web.
>

I guess you should have a look at
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=636514

HTH,

--
Mehdi Dogguy مهدي الدڤي
http://dogguy.org/


--
To UNSUBSCRIBE, email to debian-java-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 4E5D1CEA.2050707@dogguy.org">http://lists.debian.org/4E5D1CEA.2050707@dogguy.org
 

Thread Tools




All times are GMT. The time now is 01:19 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org