FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Debian > Debian Java

 
 
LinkBack Thread Tools
 
Old 06-01-2011, 06:16 AM
Onkar Shinde
 
Default RFS: excalibur-logkit 2.0-5

Hi,

I am looking for sponsorship for excalibur-logkit 2.0-5. This revision
does a lot of cleanup/refresh to the package. The packaging bits are
updated in pkg-java svn

Latest changelog for reference.
excalibur-logkit (2.0-5) unstable; urgency=low

* Use libgeronimo-jms-1.1-spec-java instead of libjboss-j2ee-java as build
dependency.
* Use javahelper to set classpath and dependencies.
* Add -doc package containing API documentation.
* Add DEP-3 headers to all patches.
* Update standards version to 3.9.2.


Cheers,
Onkar
--
Passion - Some people climb mountains - others write Free software.
Don't ask why - the reason is the same.


--
To UNSUBSCRIBE, email to debian-java-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: BANLkTinQ0-ogh83YrhDaNDUHKQ7sCUygsA@mail.gmail.com">http://lists.debian.org/BANLkTinQ0-ogh83YrhDaNDUHKQ7sCUygsA@mail.gmail.com
 
Old 06-03-2011, 05:31 PM
tony mancill
 
Default RFS: excalibur-logkit 2.0-5

Hi Onkar,

I'll sponsor the upload, but 1 small thing with this update.

The new package ships 2 separate JAR files in usr/share/java/ instead of
the JAR and a symlink:

excalibur-logkit-2.0.jar
excalibur-logkit.jar

Could you take a look at this?

Thanks,
tony

On 05/31/2011 11:16 PM, Onkar Shinde wrote:
> Hi,
>
> I am looking for sponsorship for excalibur-logkit 2.0-5. This revision
> does a lot of cleanup/refresh to the package. The packaging bits are
> updated in pkg-java svn
>
> Latest changelog for reference.
> excalibur-logkit (2.0-5) unstable; urgency=low
>
> * Use libgeronimo-jms-1.1-spec-java instead of libjboss-j2ee-java as build
> dependency.
> * Use javahelper to set classpath and dependencies.
> * Add -doc package containing API documentation.
> * Add DEP-3 headers to all patches.
> * Update standards version to 3.9.2.
>
>
> Cheers,
> Onkar


--
To UNSUBSCRIBE, email to debian-java-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 4DE91A8D.1000301@debian.org">http://lists.debian.org/4DE91A8D.1000301@debian.org
 
Old 06-03-2011, 06:42 PM
Vincent Fourmond
 
Default RFS: excalibur-logkit 2.0-5

On Fri, Jun 3, 2011 at 7:31 PM, tony mancill <tmancill@debian.org> wrote:
> Hi Onkar,
>
> I'll sponsor the upload, but 1 small thing with this update.
>
> The new package ships 2 separate JAR files in usr/share/java/ instead of
> the JAR and a symlink:
>
> * * * *excalibur-logkit-2.0.jar
> * * * *excalibur-logkit.jar
>
> Could you take a look at this?

This is a problem in javahelper, see bug #626329. Once this is
fixed, a simple rebuild should do the trick. I unfortunately suspect
many packages are affected by this problem.

I'll write a lintian tag to detect that.

Cheers,

Vincent


--
To UNSUBSCRIBE, email to debian-java-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: BANLkTikXh4X_82V9e=_p2Gohjv1ExsNV8g@mail.gmail.com ">http://lists.debian.org/BANLkTikXh4X_82V9e=_p2Gohjv1ExsNV8g@mail.gmail.com
 
Old 06-04-2011, 06:21 AM
Onkar Shinde
 
Default RFS: excalibur-logkit 2.0-5

On 6/4/11, Vincent Fourmond <fourmond@gmail.com> wrote:
> On Fri, Jun 3, 2011 at 7:31 PM, tony mancill <tmancill@debian.org> wrote:
>> Hi Onkar,
>>
>> I'll sponsor the upload, but 1 small thing with this update.
>>
>> The new package ships 2 separate JAR files in usr/share/java/ instead of
>> the JAR and a symlink:
>>
>> excalibur-logkit-2.0.jar
>> excalibur-logkit.jar
>>
>> Could you take a look at this?
>
> This is a problem in javahelper, see bug #626329. Once this is
> fixed, a simple rebuild should do the trick. I unfortunately suspect
> many packages are affected by this problem.
>
> I'll write a lintian tag to detect that.

I initially thought this was some weird conflict between dh_install
and jh_installlibs. So I have updated the package to use only
javahelper scripts. The updated packaging bits are committed in svn.

The bug that Vincent mentioned seems to be fixed in javatools git
repository. Perhaps javatools package should be uploaded first.

On a side note the cdk package is also affected by this bug.

Cheers,
Onkar
--
Passion - Some people climb mountains - others write Free software.
Don't ask why - the reason is the same.


--
To UNSUBSCRIBE, email to debian-java-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: BANLkTim+LK10mTXPSmPrv=ie4Y5EyqySVw@mail.gmail.com ">http://lists.debian.org/BANLkTim+LK10mTXPSmPrv=ie4Y5EyqySVw@mail.gmail.com
 
Old 06-04-2011, 11:36 AM
Niels Thykier
 
Default RFS: excalibur-logkit 2.0-5

On 2011-06-04 08:21, Onkar Shinde wrote:
> On 6/4/11, Vincent Fourmond <fourmond@gmail.com> wrote:
>> On Fri, Jun 3, 2011 at 7:31 PM, tony mancill <tmancill@debian.org> wrote:
>>> Hi Onkar,
>>>
>>> I'll sponsor the upload, but 1 small thing with this update.
>>>
>>> The new package ships 2 separate JAR files in usr/share/java/ instead of
>>> the JAR and a symlink:
>>>
>>> excalibur-logkit-2.0.jar
>>> excalibur-logkit.jar
>>>
>>> Could you take a look at this?
>>
>> This is a problem in javahelper, see bug #626329. Once this is
>> fixed, a simple rebuild should do the trick. I unfortunately suspect
>> many packages are affected by this problem.
>>
>> I'll write a lintian tag to detect that.
>
> I initially thought this was some weird conflict between dh_install
> and jh_installlibs. So I have updated the package to use only
> javahelper scripts. The updated packaging bits are committed in svn.
>
> The bug that Vincent mentioned seems to be fixed in javatools git
> repository. Perhaps javatools package should be uploaded first.
>
> On a side note the cdk package is also affected by this bug.
>
> Cheers,
> Onkar

Hey,

I just finished up the upload of javahelper 0.36 carrying this patch.

~Niels


--
To UNSUBSCRIBE, email to debian-java-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 4DEA18A1.3020401@thykier.net">http://lists.debian.org/4DEA18A1.3020401@thykier.net
 
Old 06-04-2011, 04:24 PM
tony mancill
 
Default RFS: excalibur-logkit 2.0-5

On 06/04/2011 04:36 AM, Niels Thykier wrote:
> On 2011-06-04 08:21, Onkar Shinde wrote:
>> On 6/4/11, Vincent Fourmond <fourmond@gmail.com> wrote:
>>> On Fri, Jun 3, 2011 at 7:31 PM, tony mancill <tmancill@debian.org> wrote:
>>>> Hi Onkar,
>>>>
>>>> I'll sponsor the upload, but 1 small thing with this update.
>>>>
>>>> The new package ships 2 separate JAR files in usr/share/java/ instead of
>>>> the JAR and a symlink:
>>>>
>>>> excalibur-logkit-2.0.jar
>>>> excalibur-logkit.jar
>>>>
>>>> Could you take a look at this?
>>>
>>> This is a problem in javahelper, see bug #626329. Once this is
>>> fixed, a simple rebuild should do the trick. I unfortunately suspect
>>> many packages are affected by this problem.
>>>
>>> I'll write a lintian tag to detect that.
>>
>> I initially thought this was some weird conflict between dh_install
>> and jh_installlibs. So I have updated the package to use only
>> javahelper scripts. The updated packaging bits are committed in svn.
>>
>> The bug that Vincent mentioned seems to be fixed in javatools git
>> repository. Perhaps javatools package should be uploaded first.
>>
>> On a side note the cdk package is also affected by this bug.
>>
>> Cheers,
>> Onkar
>
> Hey,
>
> I just finished up the upload of javahelper 0.36 carrying this patch.
>
> ~Niels

Looks like I'm still waiting for a mirror pulse here in the backwoods of the
internet-thingee... I'll rebuild and upload the package later this weekend.

Cheers,
tony
 
Old 06-04-2011, 08:41 PM
tony mancill
 
Default RFS: excalibur-logkit 2.0-5

On 06/03/2011 11:21 PM, Onkar Shinde wrote:
> On 6/4/11, Vincent Fourmond <fourmond@gmail.com> wrote:
>> On Fri, Jun 3, 2011 at 7:31 PM, tony mancill <tmancill@debian.org> wrote:
>>> Hi Onkar,
>>>
>>> I'll sponsor the upload, but 1 small thing with this update.
>>>
>>> The new package ships 2 separate JAR files in usr/share/java/ instead of
>>> the JAR and a symlink:
>>>
>>> excalibur-logkit-2.0.jar
>>> excalibur-logkit.jar
>>>
>>> Could you take a look at this?
>>
>> This is a problem in javahelper, see bug #626329. Once this is
>> fixed, a simple rebuild should do the trick. I unfortunately suspect
>> many packages are affected by this problem.
>>
>> I'll write a lintian tag to detect that.
>
> I initially thought this was some weird conflict between dh_install
> and jh_installlibs. So I have updated the package to use only
> javahelper scripts. The updated packaging bits are committed in svn.
>
> The bug that Vincent mentioned seems to be fixed in javatools git
> repository. Perhaps javatools package should be uploaded first.
>
> On a side note the cdk package is also affected by this bug.
>
> Cheers,
> Onkar

I have rebuilt cdk against javahelper 0.36 and uploaded it. (It cuts down on
the size of the resulting .deb by 5MB...)

Thanks,
tony
 
Old 06-06-2011, 01:14 PM
Onkar Shinde
 
Default RFS: excalibur-logkit 2.0-5

On Sun, Jun 5, 2011 at 2:11 AM, tony mancill <tmancill@debian.org> wrote:
> On 06/03/2011 11:21 PM, Onkar Shinde wrote:
>> On 6/4/11, Vincent Fourmond <fourmond@gmail.com> wrote:
>>> On Fri, Jun 3, 2011 at 7:31 PM, tony mancill <tmancill@debian.org> wrote:
>>>> Hi Onkar,
>>>>
>>>> I'll sponsor the upload, but 1 small thing with this update.
>>>>
>>>> The new package ships 2 separate JAR files in usr/share/java/ instead of
>>>> the JAR and a symlink:
>>>>
>>>> * * * *excalibur-logkit-2.0.jar
>>>> * * * *excalibur-logkit.jar
>>>>
>>>> Could you take a look at this?
>>>
>>> * This is a problem in javahelper, see bug #626329. Once this is
>>> fixed, a simple rebuild should do the trick. I unfortunately suspect
>>> many packages are affected by this problem.
>>>
>>> * I'll write a lintian tag to detect that.
>>
>> I initially thought this was some weird conflict between dh_install
>> and jh_installlibs. So I have updated the package to use only
>> javahelper scripts. The updated packaging bits are committed in svn.
>>
>> The bug that Vincent mentioned seems to be fixed in javatools git
>> repository. Perhaps javatools package should be uploaded first.
>>
>> On a side note the cdk package is also affected by this bug.
>>
>> Cheers,
>> Onkar
>
> I have rebuilt cdk against javahelper 0.36 and uploaded it. *(It cuts down on
> the size of the resulting .deb by 5MB...)

Thanks for taking care of both the packages.

Cheers,
Onkar
--
Passion - Some people climb mountains - others write Free software.
Don't ask why - the reason is the same.


--
To UNSUBSCRIBE, email to debian-java-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: BANLkTinOWbkckEGmgttXWWp3p4y=xhzZ3Q@mail.gmail.com ">http://lists.debian.org/BANLkTinOWbkckEGmgttXWWp3p4y=xhzZ3Q@mail.gmail.com
 

Thread Tools




All times are GMT. The time now is 03:53 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org