FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Debian > Debian Java

 
 
LinkBack Thread Tools
 
Old 04-11-2010, 09:54 AM
Torsten Werner
 
Default the removal of java-gcj-compat will cause FTBFS errors

Hi,

the source package java-gcj-compat just got removed from unstable. That
breaks quite a number of other packages but the fix should be trivial in
most cases: change the Build-Depends to default-jdk. Please DON'T use
default-jdk-builddep except you know what you are doing.

Cheers,
Torsten
 
Old 04-12-2010, 05:58 AM
Michael Tautschnig
 
Default the removal of java-gcj-compat will cause FTBFS errors

> Hi,
>
> the source package java-gcj-compat just got removed from unstable. That
> breaks quite a number of other packages but the fix should be trivial in
> most cases: change the Build-Depends to default-jdk. Please DON'T use
> default-jdk-builddep except you know what you are doing.
>

Would you mind explaining why one should not use default-jdk-builddep? The name
pretty much suggests to use it that way.

Thanks,
Michael
 
Old 04-12-2010, 06:09 AM
Niels Thykier
 
Default the removal of java-gcj-compat will cause FTBFS errors

Michael Tautschnig wrote:
>> Hi,
>>
>> the source package java-gcj-compat just got removed from unstable. That
>> breaks quite a number of other packages but the fix should be trivial in
>> most cases: change the Build-Depends to default-jdk. Please DON'T use
>> default-jdk-builddep except you know what you are doing.
>>
>
> Would you mind explaining why one should not use default-jdk-builddep? The name
> pretty much suggests to use it that way.
>
> Thanks,
> Michael
>

Hi

Because the name is very poorly chosen. default-jdk-builddep pulls 2
JDKs on most archs and should only be used to ensure you can build
"-gcj" packages. However, most source packages do not have these.
A simple build-rdeps on it suggests that some 87 packages B-D on it
but we surely do not have that many packages actually providing -gcj
packages.

~Niels
 
Old 04-12-2010, 09:24 AM
Torsten Werner
 
Default the removal of java-gcj-compat will cause FTBFS errors

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Hi,

Michael Tautschnig schrieb:
> Would you mind explaining why one should not use default-jdk-builddep?

I don't really know but the name was probably chosen because
default-jdk-builddep is only used as a Build-Depends whereas it makes
sense to install default-jdk on the user's system.

We should check every B-D: default-jdk-builddep and fix it.

Viele Gre,
Torsten
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.10 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iEYEARECAAYFAkvC5sQACgkQfY3dicTPjsNdFACcCS9zdcAUkP Em73iq0LQXNuq/
xNUAnA4u+K6ksu67Mvx7/CirP+3WsYhx
=Bmqy
-----END PGP SIGNATURE-----


--
To UNSUBSCRIBE, email to debian-java-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 4BC2E6C4.3000604@googlemail.com">http://lists.debian.org/4BC2E6C4.3000604@googlemail.com
 

Thread Tools




All times are GMT. The time now is 11:02 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org