FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Debian > Debian Java

 
 
LinkBack Thread Tools
 
Old 03-27-2010, 02:53 AM
Matthias Klose
 
Default Integrating the FOSDEM 06 Draft into the Java

On 26.03.2010 23:03, Mehdi Dogguy wrote:

Niels Thykier wrote:


Personally I disagree here, openjdk-6 comes with a webplugin
(icedtea6-plugin) that works very well for me.



It may work with common Java applets but doesn't work well for
cryptographic stuff. Ask any french guy that pays his taxes online


I fail to see your bug report. did you check with plugin in unstable?

Matthias


--
To UNSUBSCRIBE, email to debian-java-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 4BAD8125.6060602@ubuntu.com">http://lists.debian.org/4BAD8125.6060602@ubuntu.com
 
Old 03-27-2010, 03:38 AM
Matthias Klose
 
Default Integrating the FOSDEM 06 Draft into the Java

On 27.03.2010 01:24, Matthew Johnson wrote:

On Fri Mar 26 21:47, Eric Lavarde wrote:

OK, I'm not exactly enthusiastic, but I can live with this, as long as
the wording of the policy is adapted accordingly.

Why I'm not enthusiastic: should I manage to get into Debian yet another
Java runtime, which is not compatible with either gcj, nor with openjdk,
then the result could be that quite a lot of packages wouldn't be policy
compliant anymore, because they wouldn't work with "all" JRE anymore.


I personally view adding more JREs as a bad plan. I believe we should be aiming
to reduce their number, ideally to one (at least, to one that behaves as
/usr/bin/java and that packages depend on; or - one that is _supported_ as
/usr/bin/java).

After all, despite multiple python interpreters, only one of them is supported
as /usr/bin/python.


there is more than one which is supported. only one of them is supported as the
default. yes, using alternatives would break the dependencies of packages.


the handling of the java* binaries via alternatives bothers me. we do have
update-java-alternatives to help people to ensure consistency with all links,
but we cannot rely on these links to build stuff (all our packaging is based on
a JAVA_HOME set). Various helpers and scripts do their own selection of the jvm
used.


Ideally, every platform should build openjdk-6 (the last build added was the SH4
port), but it requires some porting work which needs to be done (hppa), or
backported/merged (bsd). Any help?


Even in openjdk-6 we currently have four different jvm's:

- hotspot jit, used on x86 and sparc, with sparc not having upstream
support, and unbuildable with b19

- the zero port, an interpreter which is somehow platform independent
(except for hppa).

- shark (a jit extending zero), currently packaged as openjdk-6-jre-zero
on x86, armel, powerpc.

- the ARM assembler interpreter, an optimized zero interpreter for ARM.

- cacao, a JIT integrated into openjdk-6, currently maybe usable on armel
and powerpc.

Hmm, these are already five ...

For experimenting, you can access the various jvms using the -cacao|-zero|-shark
options given to java (and installing the corresponding jre packages).


So the java situation looks more complicated than i.e. the python situation,
where we still have one default implementation of the default interpreter.


If you reduce the number of JREs and maybe converge on the one available on most
platforms (zero), you'll make java unusable on most platforms because of the
performance of the interpreter. If you rely on a JIT, you are bound to the
availability of the JIT on a specific architecture (both hotspot and shark
(using llvm) not supporting all architectures).


Updating gcj using openjdk instead of classpath might be another way to provide
a common jvm for all architectures.


Matthias


--
To UNSUBSCRIBE, email to debian-java-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 4BAD8BD9.4030609@ubuntu.com">http://lists.debian.org/4BAD8BD9.4030609@ubuntu.com
 
Old 03-27-2010, 10:17 AM
Mehdi Dogguy
 
Default Integrating the FOSDEM 06 Draft into the Java

Niels Thykier wrote:
>
> Personally I disagree here, openjdk-6 comes with a webplugin
> (icedtea6-plugin) that works very well for me.
>

Actually, you're right! The version in unstable does work for me. It
didn't work forme in the past. It was a good surprise

--
Mehdi Dogguy مهدي الدڤي
http://dogguy.org/


--
To UNSUBSCRIBE, email to debian-java-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 4BADE93E.9060804@dogguy.org">http://lists.debian.org/4BADE93E.9060804@dogguy.org
 

Thread Tools




All times are GMT. The time now is 04:45 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org