Linux Archive

Linux Archive (http://www.linux-archive.org/)
-   Debian Java (http://www.linux-archive.org/debian-java/)
-   -   Bug#456447: freeguide: missing dependency, needs file libgtkpeer.so (http://www.linux-archive.org/debian-java/20287-bug-456447-freeguide-missing-dependency-needs-file-libgtkpeer-so.html)

"Shaun Jackman" 12-15-2007 08:51 PM

Bug#456447: freeguide: missing dependency, needs file libgtkpeer.so
 
package freeguide
severity 456447 normal
tag 456447 confirmed
thanks

Freeguide does not yet work with the GNU Java interpreter. I suspect
the bugs you plan on filing will simply boil down to "does not work
with GNU Java interpreter". In which case, I'd suggest you simply file
one bug.

Freeguide itself does not depend on libgcj7-awt, however the GNU Java
interpreter does if you want to use the Swing GUI library. Since
Freeguide can be used with any compatible Java interpreter, your
problem is not specific to Freeguide. For what it's worth, the package
libgcj7-1 does recommend the package libgcj7-awt.

The problem you've recognized is real, but the solution isn't straight
forward. Perhaps there's a need for a virtual java-swing package that
is provided by libgcj7-awt and any other Java VM package that provides
Swing. I've cc'ed this email to the Debian Java team for their input.

Cheers,
Shaun

On Dec 15, 2007 2:19 PM, Paul Sundvall <slask@paulsundvall.net> wrote:
> Package: freeguide
> Version: 0.10.4-2
> Severity: important
>
> install of freeguide does not work right out of the box. If run, an error message containing
>
> (snip)
> at freeguide.plugins.program.freeguide.FreeGuide.show PleaseWait(FreeGuide.java:440)
> at freeguide.plugins.program.freeguide.FreeGuide.main (FreeGuide.java:398)
> at java.lang.reflect.Method.invoke(natMethod.cc:182)
> ...2 more
> Caused by: java.lang.UnsatisfiedLinkError: libgtkpeer: libgtkpeer.so: kan inte öppna delad objektfil: Filen eller katalogen finns inte
> at java.lang.Runtime._load(natRuntime.cc:211)
> at java.lang.Runtime.loadLibrary(Runtime.java:655)
> (snip)
>
> The problem goes away at least partly after install of package libgcj7-awt. Freeguide now starts.
> Other problems arise (filed in separate bug, as I believe it is another problem).
>
>
> cheers,
> paul
>
>
> -- System Information:
> Debian Release: 4.0
> APT prefers stable
> APT policy: (500, 'stable')
> Architecture: i386 (i686)
> Shell: /bin/sh linked to /bin/bash
> Kernel: Linux 2.6.18-5-686
> Locale: LANG=sv_SE.UTF-8, LC_CTYPE=sv_SE.UTF-8 (charmap=UTF-8)
>
> Versions of packages freeguide depends on:
> ii gij [java-virtual-machine] 4:4.1.1-15 The GNU Java bytecode interpreter
> ii gij-4.1 [java2-runtime] 4.1.1-20 The GNU Java bytecode interpreter
> ii xmltv-gui 0.5.44-1.1 Graphical user interface related t
>
> Versions of packages freeguide recommends:
> ii xmltv-util 0.5.44-1.1 Utilities related to the XMLTV fil
>
> -- no debconf information
>
>
>


All times are GMT. The time now is 05:24 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.