Linux Archive

Linux Archive (http://www.linux-archive.org/)
-   Debian Java (http://www.linux-archive.org/debian-java/)
-   -   maven2 2.0.8-1 fails to work at all. (http://www.linux-archive.org/debian-java/19794-maven2-2-0-8-1-fails-work-all.html)

Paul Cager 12-14-2007 07:53 PM

maven2 2.0.8-1 fails to work at all.
 
Fred Cooke wrote:
> Hi, this is the first time in 5 years of using debian i have had any
> issues that i couldnt solve, so I'm a little hesitant to post about it
> really.
>
> fred@rwdlsd:~$ mvn
> Exception in thread "main" java.lang.IllegalAccessError: tried to
> access field org.codehaus.plexus.util.Os.OS_NAME from class
> org.apache.maven.cli.MavenCli
> at org.apache.maven.cli.MavenCli.<clinit>(MavenCli.ja va:76)
> at sun.reflect.NativeMethodAccessorImpl.invoke0(Nativ e Method)
> at sun.reflect.NativeMethodAccessorImpl.invoke(Native MethodAccessorImpl.java:39)
> at sun.reflect.DelegatingMethodAccessorImpl.invoke(De legatingMethodAccessorImpl.java:25)
> at java.lang.reflect.Method.invoke(Method.java:597)
> at org.codehaus.classworlds.Launcher.launchEnhanced(L auncher.java:315)
> at org.codehaus.classworlds.Launcher.launch(Launcher. java:255)
> at org.codehaus.classworlds.Launcher.mainWithExitCode (Launcher.java:430)
> at org.codehaus.classworlds.Launcher.main(Launcher.ja va:375)
>
> is all it ever does regardless of arguments. i tried -X and -e and
> combined together also.
>
> i've got these java packages installed :
>
> rwdlsd:/var/cache/apt/archives# l sun-java6-*
> -rw-r--r-- 1 root root 26414096 2007-10-04 07:02 sun-java6-bin_6-03-2_i386.deb
> -rw-r--r-- 1 root root 40708 2007-10-04 07:02 sun-java6-doc_6-03-2_all.deb
> -rw-r--r-- 1 root root 1814 2007-10-04 07:02 sun-java6-fonts_6-03-2_all.deb
> -rw-r--r-- 1 root root 9508894 2007-10-04 07:02 sun-java6-jdk_6-03-2_i386.deb
> -rw-r--r-- 1 root root 6327332 2007-10-04 07:02 sun-java6-jre_6-03-2_all.deb
> -rw-r--r-- 1 root root 1596 2007-10-04 07:02
> sun-java6-plugin_6-03-2_i386.deb
>
> please let me know if there is anything else i can do to help diagnose this.
>
> 2.0.7-2 works fine for me in all ways, and i'll continue to use that
> for the time being.
>
> i also have some (more important to me) issues with eclipse which i
> will now post seperately.
>
> regards,
>
> fred.

Hi Fred,

Thanks for the report. Maven 2.0.8 requires a newer version of
plexus-utils - could you let me know what version of that jar you are
using, please?

On my system it looks like this:
$ ls -l /usr/share/java/libplexus-utils.jar
lrwxrwxrwx 1 root root 22 2007-12-05 23:23
/usr/share/java/libplexus-utils.jar -> plexus-utils-1.4.8.jar


Thanks,
Paul


--
To UNSUBSCRIBE, email to debian-java-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Paul Cager 12-14-2007 09:33 PM

maven2 2.0.8-1 fails to work at all.
 
Paul Cager wrote:
> Fred Cooke wrote:
>> Hi, this is the first time in 5 years of using debian i have had any
>> issues that i couldnt solve, so I'm a little hesitant to post about it
>> really.
>>
>> fred@rwdlsd:~$ mvn
>> Exception in thread "main" java.lang.IllegalAccessError: tried to
>> access field org.codehaus.plexus.util.Os.OS_NAME from class
>> org.apache.maven.cli.MavenCli
>> at org.apache.maven.cli.MavenCli.<clinit>(MavenCli.ja va:76)
>> at sun.reflect.NativeMethodAccessorImpl.invoke0(Nativ e Method)
>> at sun.reflect.NativeMethodAccessorImpl.invoke(Native MethodAccessorImpl.java:39)
>> at sun.reflect.DelegatingMethodAccessorImpl.invoke(De legatingMethodAccessorImpl.java:25)
>> at java.lang.reflect.Method.invoke(Method.java:597)
>> at org.codehaus.classworlds.Launcher.launchEnhanced(L auncher.java:315)
>> at org.codehaus.classworlds.Launcher.launch(Launcher. java:255)
>> at org.codehaus.classworlds.Launcher.mainWithExitCode (Launcher.java:430)
>> at org.codehaus.classworlds.Launcher.main(Launcher.ja va:375)
>>
>> is all it ever does regardless of arguments. i tried -X and -e and
>> combined together also.
>>
>> i've got these java packages installed :
>>
>> rwdlsd:/var/cache/apt/archives# l sun-java6-*
>> -rw-r--r-- 1 root root 26414096 2007-10-04 07:02 sun-java6-bin_6-03-2_i386.deb
>> -rw-r--r-- 1 root root 40708 2007-10-04 07:02 sun-java6-doc_6-03-2_all.deb
>> -rw-r--r-- 1 root root 1814 2007-10-04 07:02 sun-java6-fonts_6-03-2_all.deb
>> -rw-r--r-- 1 root root 9508894 2007-10-04 07:02 sun-java6-jdk_6-03-2_i386.deb
>> -rw-r--r-- 1 root root 6327332 2007-10-04 07:02 sun-java6-jre_6-03-2_all.deb
>> -rw-r--r-- 1 root root 1596 2007-10-04 07:02
>> sun-java6-plugin_6-03-2_i386.deb
>>
>> please let me know if there is anything else i can do to help diagnose this.
>>
>> 2.0.7-2 works fine for me in all ways, and i'll continue to use that
>> for the time being.
>>
>> i also have some (more important to me) issues with eclipse which i
>> will now post seperately.
>>
>> regards,
>>
>> fred.
>
> Hi Fred,
>
> Thanks for the report. Maven 2.0.8 requires a newer version of
> plexus-utils - could you let me know what version of that jar you are
> using, please?
>
> On my system it looks like this:
> $ ls -l /usr/share/java/libplexus-utils.jar
> lrwxrwxrwx 1 root root 22 2007-12-05 23:23
> /usr/share/java/libplexus-utils.jar -> plexus-utils-1.4.8.jar

I see my mistake now (thanks for pointing it out, Fred). I've added a
minimum version to the *build* dependency, but not the runtime
dependency. I'll fix that.

Thanks,
Paul


--
To UNSUBSCRIBE, email to debian-java-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org


All times are GMT. The time now is 06:38 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.