FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Debian > Debian ISP

 
 
LinkBack Thread Tools
 
Old 05-14-2008, 10:45 AM
Turbo Fredriksson
 
Default SIGBUS in Apache (Mysql client)

I thought I'd tripple check all my machines because
of the SSL problem reported yesterday. Noticed that
I was running Sarge (!!) on some machines.

Quickly started a dist-upgrade, which finnished quite
late (or early depending of view .

All my services work fine, exept PHPBB2/Apache...

A backtrace when starting 'apache -X' shows:

----- s n i p -----
#0 0xf73f76e4 in _nss_files_endhostent () from /lib/libnss_files.so.2
#1 0xf73f8048 in _nss_files_gethostbyname_r () from /lib/libnss_files.so.2
#2 0xf7cd7914 in gethostbyname_r () from /lib/libc.so.6
#3 0xf682c0d4 in my_gethostbyname_r () from /usr/lib/libmysqlclient.so.15
#4 0xf68497f0 in mysql_real_connect () from /usr/lib/libmysqlclient.so.15
#5 0xf69c399c in zif_mysql_errno () from /usr/lib/php4/20050606+lfs/mysql.so
#6 0xf78ffef8 in execute () from /usr/lib/apache/1.3/libphp4.so
#7 0xf78fa474 in execute () from /usr/lib/apache/1.3/libphp4.so
#8 0xf78fc7dc in execute () from /usr/lib/apache/1.3/libphp4.so
#9 0xf78fc7dc in execute () from /usr/lib/apache/1.3/libphp4.so
#10 0xf78e6bc8 in zend_execute_scripts () from /usr/lib/apache/1.3/libphp4.so
#11 0xf78b4cb0 in php_execute_script () from /usr/lib/apache/1.3/libphp4.so
#12 0xf79039f0 in apache_php_module_main () from /usr/lib/apache/1.3/libphp4.so
#13 0xf790494c in apache_php_module_main () from /usr/lib/apache/1.3/libphp4.so
#14 0xf7904be0 in apache_php_module_main () from /usr/lib/apache/1.3/libphp4.so
#15 0x0001e9e8 in ap_invoke_handler ()
#16 0x0002fa88 in ap_die ()
#17 0xf7b4cb70 in ?? () from /usr/lib/apache/1.3/mod_dir.so
#18 0xf7b4cb70 in ?? () from /usr/lib/apache/1.3/mod_dir.so
Previous frame identical to this frame (corrupt stack?)
----- s n i p -----

To me, it looks like it's a problem in the NSS stack... !?

Quickly setting up Apache2 didn't work either:

----- s n i p -----
#0 0xf7b0f608 in readv () from /lib/libc.so.6
#1 0xf7c8f160 in apr_socket_sendv () from /usr/lib/libapr-1.so.0
#2 0x0003910c in ap_bucket_eoc_create ()
#3 0x00039c24 in ap_core_output_filter ()
#4 0x00044128 in ap_pass_brigade ()
#5 0x00044128 in ap_pass_brigade ()
#6 0x0004c1f4 in ap_http_chunk_filter ()
#7 0x00044128 in ap_pass_brigade ()
#8 0x00044128 in ap_pass_brigade ()
#9 0x00030530 in ap_content_length_filter ()
#10 0x00044128 in ap_pass_brigade ()
#11 0x00044128 in ap_pass_brigade ()
#12 0x0004a18c in ap_process_request ()
#13 0x0004731c in ap_register_input_filter ()
#14 0x0004135c in ap_run_process_connection ()
#15 0x0004de28 in ap_graceful_stop_signalled ()
#16 0x0004de28 in ap_graceful_stop_signalled ()
Previous frame identical to this frame (corrupt stack?)
----- s n i p -----

ALSO libc!


I'm a little tired after only sleeping 3-4 hours this
morning, so any ideas?


This is a SPARC64, kernel 2.6.20.3 (from kernel-image-2.6.20.3-sparc64).

Here's nsswitch.conf if that matters:
----- s n i p -----
passwd: files
group: files
shadow: files
hosts: files dns [!UNAVAIL=return]
networks: files
protocols: db files
services: db files
ethers: db files
rpc: db files
netgroup: nis
----- s n i p -----

Using strace:

----- s n i p -----
[...]
read(30, "127.0.0.1 localhost.localdomain localhost
<IPADDRESS> <FQDN> <HOSTNAME>

# The following lines are desirable for IPv6 capable hosts
#::1 ip6-localhost ip6-loopback
#fe00::0 ip6-localnet
#ff00::0 ip6-mcastprefix
#ff02::1 ip6-allnodes
#ff02::2 ip6-allrouters
#ff02::3 ip6-allhosts
", 4096) = 290
--- SIGBUS (Bus error) @ 0 (0) ---
+++ killed by SIGBUS +++
Process 22778 detached
----- s n i p -----


The weird thing is that it seem to only affect
phpbb2 (via MySQL). I'm also running (amongst other
things) phpAlbum (http://www.phpalbum.net/) which
is a 'simple' PHP site (i.e. no MySQL or other modules
involved). In total, there's 24 VirtualHost directives,


Testing through all sites, I also get the bus error
when accessing the Anthill (http://freshmeat.net/projects/anthill/).
Same bt as above...


Trying to setup a very simple php5-mysql test shows
that the problem seems to bee in the mysql library.

----- s n i p -----
root@rigel# strace mysql -h <MYSQL_SERVER>
mmap(NULL, 8192, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0xf7fc4000
read(4, "127.0.0.1 localhost.localdomain "..., 4096) = 290
--- SIGBUS (Bus error) @ 0 (0) ---
+++ killed by SIGBUS +++
----- s n i p -----

There is no problem with the MySQL server (v5.0.32-7etch5),
since I can access and administrate it from localhost
on MYSQL_SERVER...
However, I have three SPARC64 (one of which is MYSQL_SERVER)
and two i386. On both the i386 mysql works (same version),
but on the two other SPARC64's I get a Bus error!


--
To UNSUBSCRIBE, email to debian-isp-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 

Thread Tools




All times are GMT. The time now is 05:59 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org