breaking the old versions of gcj-4.4-base seems to work fine in sid
(#677582). Thanks again for adding these.
Now I have discovered some more upgrade issues involving some old
libgnustep*, libobjc2 and gcc-4.4-base. apt chooses again to keep the
old (squeeze) version of gcc-4.4-base instead of removing libobjc2.
I think such "incomplete upgrades" of gcc-4.4-base could be "fixed"
(better "prevented") by adding another Breaks to gcc-4.7-base.
But I'm not sure which versions to break:
* gcc-4.4-base (<< 4.4.7) # because 4.4.7 is in wheezy
* gcc-4.4-base (<< 4.4.6-9~) # because we break gcj-4.4-base (<< 4.4.6-9~)
* gcc-4.4-base (<< 4.4.5-13~) # because libobjc2 was dropped in 4.4.5-13
and haven't made any tests with such a change so far.
Adding such a Breaks would have solved #677582 as well.
IMO distupgrades from squeeze should not involve "keeping back"
upgradable packages. Packages that are no longer available "are allowed"
to stay installed only if they don't block any other package from being
upgraded. And unfortunately we can't "fix" squeeze's apt to make better
PS: I think my first approach of adding the
Breaks: gcj-4.4-base (<< something)
in gcc-4.4-base stopped working at the time gcc-4.4-base got the
Priority downgraded from required to optional, which shuffled the
scores given by apt.
And these score changes may be the reason for the new libgnustep* related
To UNSUBSCRIBE, email to debian-gcc-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact firstname.lastname@example.org
Archive: email@example.com i-frankfurt.de">http://firstname.lastname@example.org i-frankfurt.de