FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Debian > Debian GCC

 
 
LinkBack Thread Tools
 
Old 07-09-2012, 03:19 PM
Reh Wanne
 
Default Bug#680966: gcc-4.7-base: Dist-Upgrade broke the Dependencies and its not fixable through the standard way

Package: gcc-4.7-base
Severity: normal
Tags: upstream

Dear Maintainer,
*** Please consider answering these questions, where appropriate ***

* What led up to the situation?
apt-get dist-upgrade
* What exactly did you do (or not do) that was effective (or
ineffective)?
apt-get -f install
apt-get -f upgrade
apt-get clean
apt-get update
apt-get upgrade
dpkg -i /var/apt/archive/*.deb
dpkg --configure -a

* What was the outcome of this action?
dpkg --configure -a
dpkg: Fehler beim Bearbeiten von libgcc1:amd64 (--configure):
Paket libgcc1:amd64 1:4.7.1-3 kann nicht konfiguriert werden, da libgcc1:i386
in einer anderen Version vorliegt (1:4.7.1-2)
dpkg: Fehler beim Bearbeiten von libgcc1:i386 (--configure):
Paket libgcc1:i386 1:4.7.1-2 kann nicht konfiguriert werden, da libgcc1:amd64
in einer anderen Version vorliegt (1:4.7.1-3)
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von libsnappy1:
libsnappy1 hängt ab von libgcc1 (>= 1:4.1.1); aber:
Paket libgcc1:amd64 ist noch nicht konfiguriert.

dpkg: Fehler beim Bearbeiten von libsnappy1 (--configure):
Abhängigkeitsprobleme - verbleibt unkonfiguriert
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von libopenexr6:
libopenexr6 hängt ab von libgcc1 (>= 1:4.1.1); aber:
Paket libgcc1:amd64 ist noch nicht konfiguriert.

dpkg: Fehler beim Bearbeiten von libopenexr6 (--configure):
Abhängigkeitsprobleme - verbleibt unkonfiguriert
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von libgfortran3:amd64:
libgfortran3:amd64 hängt ab von libgcc1 (>= 1:4.4.0); aber:
Paket libgcc1:amd64 ist noch nicht konfiguriert.

dpkg: Fehler beim Bearbeiten von libgfortran3:amd64 (--configure):
Abhängigkeitsprobleme - verbleibt unkonfiguriert
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von python-qt4:
python-qt4 hängt ab von libgcc1 (>= 1:4.1.1); aber:
Paket libgcc1:amd64 ist noch nicht konfiguriert.

dpkg: Fehler beim Bearbeiten von python-qt4 (--configure):
Abhängigkeitsprobleme - verbleibt unkonfiguriert
dpkg: Fehler beim Bearbeiten von gcc-4.7-base:amd64 (--configure):
Paket gcc-4.7-base:amd64 4.7.1-3 kann nicht konfiguriert werden, da
gcc-4.7-base:i386 in einer anderen Version vorliegt (4.7.1-2)
dpkg: Fehler beim Bearbeiten von gcc-4.7-base:i386 (--configure):
Paket gcc-4.7-base:i386 4.7.1-2 kann nicht konfiguriert werden, da
gcc-4.7-base:amd64 in einer anderen Version vorliegt (4.7.1-3)
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von mplayer:
mplayer hängt ab von libgcc1 (>= 1:4.1.1); aber:
Paket libgcc1:amd64 ist noch nicht konfiguriert.

dpkg: Fehler beim Bearbeiten von mplayer (--configure):
Abhängigkeitsprobleme - verbleibt unkonfiguriert
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von libstdc++6:amd64:
libstdc++6:amd64 hängt ab von gcc-4.7-base (= 4.7.1-3); aber:
Paket gcc-4.7-base:amd64 ist noch nicht konfiguriert.
libstdc++6:amd64 hängt ab von libgcc1 (>= 1:4.1.1); aber:
Paket libgcc1:amd64 ist noch nicht konfiguriert.

dpkg: Fehler beim Bearbeiten von libstdc++6:amd64 (--configure):
Abhängigkeitsprobleme - verbleibt unkonfiguriert
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von binutils:
binutils hängt ab von libgcc1 (>= 1:4.1.1); aber:
Paket libgcc1:amd64 ist noch nicht konfiguriert.
binutils hängt ab von libstdc++6 (>= 4.6); aber:
Paket libstdc++6:amd64 ist noch nicht konfiguriert.

dpkg: Fehler beim Bearbeiten von binutils (--configure):
Abhängigkeitsprobleme - verbleibt unkonfiguriert
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von libgomp1:amd64:
libgomp1:amd64 hängt ab von gcc-4.7-base (= 4.7.1-3); aber:
Paket gcc-4.7-base:amd64 ist noch nicht konfiguriert.

dpkg: Fehler beim Bearbeiten von libgomp1:amd64 (--configure):
Abhängigkeitsprobleme - verbleibt unkonfiguriert
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von libitm1:amd64:
libitm1:amd64 hängt ab von gcc-4.7-base (= 4.7.1-3); aber:
Paket gcc-4.7-base:amd64 ist noch nicht konfiguriert.
libitm1:amd64 hängt ab von libgcc1 (>= 1:4.1.1); aber:
Paket libgcc1:amd64 ist noch nicht konfiguriert.

dpkg: Fehler beim Bearbeiten von libitm1:amd64 (--configure):
Abhängigkeitsprobleme - verbleibt unkonfiguriert
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von libstdc++6-4.7-dev:
libstdc++6-4.7-dev hängt ab von gcc-4.7-base (= 4.7.1-3); aber:
Paket gcc-4.7-base:amd64 ist noch nicht konfiguriert.
libstdc++6-4.7-dev hängt ab von libstdc++6 (>= 4.7.1-3); aber:
Paket libstdc++6:amd64 ist noch nicht konfiguriert.

dpkg: Fehler beim Bearbeiten von libstdc++6-4.7-dev (--configure):
Abhängigkeitsprobleme - verbleibt unkonfiguriert
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von cpp-4.7:
cpp-4.7 hängt ab von gcc-4.7-base (= 4.7.1-3); aber:
Paket gcc-4.7-base:amd64 ist noch nicht konfiguriert.

dpkg: Fehler beim Bearbeiten von cpp-4.7 (--configure):
Abhängigkeitsprobleme - verbleibt unkonfiguriert
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von g++-4.7:
g++-4.7 hängt ab von gcc-4.7-base (= 4.7.1-3); aber:
Paket gcc-4.7-base:amd64 ist noch nicht konfiguriert.
g++-4.7 hängt ab von libstdc++6-4.7-dev (= 4.7.1-3); aber:
Paket libstdc++6-4.7-dev ist noch nicht konfiguriert.

dpkg: Fehler beim Bearbeiten von g++-4.7 (--configure):
Abhängigkeitsprobleme - verbleibt unkonfiguriert
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von gcc-4.7-multilib:
gcc-4.7-multilib hängt ab von gcc-4.7-base (= 4.7.1-3); aber:
Paket gcc-4.7-base:amd64 ist noch nicht konfiguriert.

dpkg: Fehler beim Bearbeiten von gcc-4.7-multilib (--configure):
Abhängigkeitsprobleme - verbleibt unkonfiguriert
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von lib32itm1:
lib32itm1 hängt ab von gcc-4.7-base (= 4.7.1-3); aber:
Paket gcc-4.7-base:amd64 ist noch nicht konfiguriert.

dpkg: Fehler beim Bearbeiten von lib32itm1 (--configure):
Abhängigkeitsprobleme - verbleibt unkonfiguriert
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von dpkg-dev:
dpkg-dev hängt ab von binutils; aber:
Paket binutils ist noch nicht konfiguriert.

dpkg: Fehler beim Bearbeiten von dpkg-dev (--configure):
Abhängigkeitsprobleme - verbleibt unkonfiguriert
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von lib32gomp1:
lib32gomp1 hängt ab von gcc-4.7-base (= 4.7.1-3); aber:
Paket gcc-4.7-base:amd64 ist noch nicht konfiguriert.

dpkg: Fehler beim Bearbeiten von lib32gomp1 (--configure):
Abhängigkeitsprobleme - verbleibt unkonfiguriert
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von lib32quadmath0:
lib32quadmath0 hängt ab von gcc-4.7-base (= 4.7.1-3); aber:
Paket gcc-4.7-base:amd64 ist noch nicht konfiguriert.

dpkg: Fehler beim Bearbeiten von lib32quadmath0 (--configure):
Abhängigkeitsprobleme - verbleibt unkonfiguriert
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von libquadmath0:amd64:
libquadmath0:amd64 hängt ab von gcc-4.7-base (= 4.7.1-3); aber:
Paket gcc-4.7-base:amd64 ist noch nicht konfiguriert.

dpkg: Fehler beim Bearbeiten von libquadmath0:amd64 (--configure):
Abhängigkeitsprobleme - verbleibt unkonfiguriert
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von lib32gcc1:
lib32gcc1 hängt ab von gcc-4.7-base (= 4.7.1-3); aber:
Paket gcc-4.7-base:amd64 ist noch nicht konfiguriert.

dpkg: Fehler beim Bearbeiten von lib32gcc1 (--configure):
Abhängigkeitsprobleme - verbleibt unkonfiguriert
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von liblapack3:
liblapack3 hängt ab von libgcc1 (>= 1:4.1.1); aber:
Paket libgcc1:amd64 ist noch nicht konfiguriert.
liblapack3 hängt ab von libgfortran3 (>= 4.6); aber:
Paket libgfortran3:amd64 ist noch nicht konfiguriert.
liblapack3 hängt ab von libquadmath0 (>= 4.6); aber:
Paket libquadmath0:amd64 ist noch nicht konfiguriert.

dpkg: Fehler beim Bearbeiten von liblapack3 (--configure):
Abhängigkeitsprobleme - verbleibt unkonfiguriert
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von gcc-4.7:
gcc-4.7 hängt ab von gcc-4.7-base (= 4.7.1-3); aber:
Paket gcc-4.7-base:amd64 ist noch nicht konfiguriert.
gcc-4.7 hängt ab von cpp-4.7 (= 4.7.1-3); aber:
Paket cpp-4.7 ist noch nicht konfiguriert.
gcc-4.7 hängt ab von binutils (>= 2.21.1); aber:
Paket binutils ist noch nicht konfiguriert.
gcc-4.7 hängt ab von libgcc1 (>= 1:4.7.1-3); aber:
Paket libgcc1:amd64 ist noch nicht konfiguriert.
gcc-4.7 hängt ab von libgomp1 (>= 4.7.1-3); aber:
Paket libgomp1:amd64 ist noch nicht konfiguriert.
gcc-4.7 hängt ab von libitm1 (>= 4.7.1-3); aber:
Paket libitm1:amd64 ist noch nicht konfiguriert.
gcc-4.7 hängt ab von libquadmath0 (>= 4.7.1-3); aber:
Paket libquadmath0:amd64 ist noch nicht konfiguriert.

dpkg: Fehler beim Bearbeiten von gcc-4.7 (--configure):
Abhängigkeitsprobleme - verbleibt unkonfiguriert
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von libsbsms10:amd64:
libsbsms10:amd64 hängt ab von libgcc1 (>= 1:4.1.1); aber:
Paket libgcc1:amd64 ist noch nicht konfiguriert.
libsbsms10:amd64 hängt ab von libstdc++6 (>= 4.6); aber:
Paket libstdc++6:amd64 ist noch nicht konfiguriert.

dpkg: Fehler beim Bearbeiten von libsbsms10:amd64 (--configure):
Abhängigkeitsprobleme - verbleibt unkonfiguriert
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von liblapack3gf:
liblapack3gf hängt ab von liblapack3; aber:
Paket liblapack3 ist noch nicht konfiguriert.

dpkg: Fehler beim Bearbeiten von liblapack3gf (--configure):
Abhängigkeitsprobleme - verbleibt unkonfiguriert
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von lib32stdc++6:
lib32stdc++6 hängt ab von gcc-4.7-base (= 4.7.1-3); aber:
Paket gcc-4.7-base:amd64 ist noch nicht konfiguriert.
lib32stdc++6 hängt ab von lib32gcc1 (>= 1:4.1.1); aber:
Paket lib32gcc1 ist noch nicht konfiguriert.

dpkg: Fehler beim Bearbeiten von lib32stdc++6 (--configure):
Abhängigkeitsprobleme - verbleibt unkonfiguriert
Fehler traten auf beim Bearbeiten von:
libgcc1:amd64
libgcc1:i386
libsnappy1
libopenexr6
libgfortran3:amd64
python-qt4
gcc-4.7-base:amd64
gcc-4.7-base:i386
mplayer
libstdc++6:amd64
binutils
libgomp1:amd64
libitm1:amd64
libstdc++6-4.7-dev
cpp-4.7
g++-4.7
gcc-4.7-multilib
lib32itm1
dpkg-dev
lib32gomp1
lib32quadmath0
libquadmath0:amd64
lib32gcc1
liblapack3
gcc-4.7
libsbsms10:amd64
liblapack3gf
lib32stdc++6



E: Internal Error, No file name for gcc-4.7-base

* What outcome did you expect instead?
The System should update



-- System Information:
Debian Release: wheezy/sid
APT prefers unstable
APT policy: (500, 'unstable')
Architecture: amd64 (x86_64)

Kernel: Linux 3.4.4 (SMP w/4 CPU cores)
Locale: LANG=de_DE.UTF-8, LC_CTYPE=de_DE.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash



--
To UNSUBSCRIBE, email to debian-gcc-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: http://lists.debian.org/20120709151938.31733.27782.reportbug@revpad
 

Thread Tools




All times are GMT. The time now is 05:13 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright ©2007 - 2008, www.linux-archive.org