FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Debian > Debian GCC

 
 
LinkBack Thread Tools
 
Old 07-02-2012, 11:49 PM
Kevin Locke
 
Default Bug#680022: g++-4.7-spu: Should conflict with previous g++-*-spu packages

Package: g++-4.7-spu
Version: 4.7.0-8
Severity: normal

Dear Maintainer,

When upgrading g++-spu from 4.6 to 4.7 (using aptitude), g++-4.7-spu
fails to install due to file conflicts with g++-4.6-spu. Although
g++-4.6-spu is marked for removal, it is not removed before
g++-4.7-spu is unpacked, which causes the error. Perhaps g++-4.7-spu
should Conflicts/Provides/Replaces spu-g++ or Conflicts/Replaces
g++-4.6-spu?

The error message from the install attempt is:

-8<------------------------------------------------------------------
Unpacking g++-4.7-spu (from .../g++-4.7-spu_4.7.0-8_powerpc.deb) ...
dpkg: error processing /var/cache/apt/archives/g++-4.7-spu_4.7.0-8_powerpc.deb (--unpack):
trying to overwrite '/usr/spu/lib/libsupc++.a', which is also in package g++-4.6-spu 4.6.3-1
configured to not write apport reports
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Errors were encountered while processing:
/var/cache/apt/archives/g++-4.7-spu_4.7.0-8_powerpc.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
A package failed to install. Trying to recover:
dpkg: dependency problems prevent configuration of g++-spu:
g++-spu depends on g++-4.7-spu (>= 4.7.0-1~); however:
Package g++-4.7-spu is not installed.
dpkg: error processing g++-spu (--configure):
dependency problems - leaving unconfigured
Errors were encountered while processing:
g++-spu
-8<------------------------------------------------------------------

I'm not sure if this bug should be severity serious, and didn't want
to mark it that way without certainty (especially during freeze), but
feel free to set the severity as you see fit.

Thanks,
Kevin


-- System Information:
Debian Release: wheezy/sid
APT prefers testing
APT policy: (990, 'testing'), (500, 'unstable')
Architecture: powerpc (ppc64)

Kernel: Linux 2.6.39.4-kevinoid2 (SMP w/2 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages g++-4.7-spu depends on:
ii gcc-4.7-base 4.7.0-8
ii gcc-4.7-spu 4.7.0-8
ii libc6 2.13-33
ii libgmp10 2:5.0.5+dfsg-2
ii libmpc2 0.9-4
ii libmpfr4 3.1.0-5
ii zlib1g 1:1.2.7.dfsg-13

g++-4.7-spu recommends no packages.

g++-4.7-spu suggests no packages.



--
To UNSUBSCRIBE, email to debian-gcc-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: http://lists.debian.org/20120702234948.GA29607@kevinzilla
 

Thread Tools




All times are GMT. The time now is 11:27 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org