FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Debian > Debian GCC

 
 
LinkBack Thread Tools
 
Old 06-30-2012, 07:33 PM
Gregor Jasny
 
Default Bug#669479: Time to upload fix for #669479

Hello Artur,

maybe you should just NMU upload to DELAYED/2.

Thanks,
Gregor



--
To UNSUBSCRIBE, email to debian-gcc-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 4FEF5470.3040607@googlemail.com">http://lists.debian.org/4FEF5470.3040607@googlemail.com
 
Old 07-08-2012, 11:12 PM
Artur Rona
 
Default Bug#669479: Time to upload fix for #669479

Hello Gregor,

unfortunately, my latest fix is not correct. We cannot just drop
libncurses5-dev from Build-Depends cause hurd-i386 and mips don't need
it. So I'd like straightforward add next library to B-D: libncursesw5-dev.


However, if ppl gets missing library, then next FTBFS happens. I've
filled new bug there: http://bugs.debian.org/680896


Well, above bug has to be fixed, as well. Also there are another bugs
related to Multi-Arch:

http://bugs.debian.org/670024
http://bugs.debian.org/670025
It would be nice to fix them all by one upload. So if someone can do it,
feel free to ignore my NMU and upload full fix. From my side, I'll try
to fix 2nd FTBFS bug but please don't wait for me.


I'm sorry for holding on with this one.

On 06/30/2012 09:33 PM, Gregor Jasny wrote:

Hello Artur,

maybe you should just NMU upload to DELAYED/2.

Thanks,
Gregor


--
Pozdrawiam / Kind Regards,
Artur Rona



diff -Nru ppl-0.11.2/debian/changelog ppl-0.11.2/debian/changelog
--- ppl-0.11.2/debian/changelog 2011-10-11 12:15:19.000000000 +0200
+++ ppl-0.11.2/debian/changelog 2012-07-08 16:31:21.000000000 +0200
@@ -1,3 +1,11 @@
+ppl (0.11.2-6.1) unstable; urgency=low
+
+ * Non-maintainer upload.
+ * debian/control: Add libncursesw5-dev to Build-Depends due to
+ missing library, fixes FTBFS. (Closes: #669479)
+
+ -- Artur Rona <ari-tczew@tlen.pl> Sun, 08 Jul 2012 16:30:36 +0200
+
ppl (0.11.2-6) unstable; urgency=low

* Build-depend on libncurses5-dev, until swi-prolog-nox depends on it.
diff -Nru ppl-0.11.2/debian/control ppl-0.11.2/debian/control
--- ppl-0.11.2/debian/control 2011-10-11 12:14:41.000000000 +0200
+++ ppl-0.11.2/debian/control 2012-07-08 16:30:22.000000000 +0200
@@ -4,7 +4,7 @@
Maintainer: Debian GCC Maintainers <debian-gcc@lists.debian.org>
Uploaders: Michael Tautschnig <mt@debian.org>, Arthur Loiret <aloiret@debian.org>, Matthias Klose <doko@debian.org>
Standards-Version: 3.9.2
-Build-Depends: debhelper (>= 6.0.7~), libgmp-dev, autoconf, libtool, autotools-dev, swi-prolog [!hurd-i386 !mips], chrpath, libncurses5-dev
+Build-Depends: debhelper (>= 6.0.7~), libgmp-dev, autoconf, libtool, autotools-dev, swi-prolog [!hurd-i386 !mips], chrpath, libncurses5-dev, libncursesw5-dev
Build-Depends-Indep: doxygen-latex, graphviz, poppler-utils, ghostscript, texlive-math-extra
Homepage: http://www.cs.unipr.it/ppl/
 

Thread Tools




All times are GMT. The time now is 12:37 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org