FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Debian > Debian GCC

 
 
LinkBack Thread Tools
 
Old 06-25-2012, 09:41 AM
Niels Thykier
 
Default Bug#678945: gcj-jdk: GCJ javadoc -source 1.5 fails but apppears to be supported

Package: gcj-jdk
Severity: normal

Hi,

Passing -source 1.5 to GCJ's javadoc implementation with an error saying
only 1.2, 1.3 and 1.4 is supported. However, it does seem to have support
for it[1].

It is possible that the file
libjava/classpath/tools/gnu/classpath/tools/gjdoc/Main.java
just needs a trivial patch to allow 1.5 in addition.

~Niels

[1] It claims to be able to run Java5 code and it does have a class
file for it (in gcc-4.7 at least):

./gcc-4.7.1/libjava/classpath/tools/resource/gnu/classpath/tools/gjdoc/java.lang-classes-1.5.txt



--
To UNSUBSCRIBE, email to debian-gcc-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 20120625094107.21667.84788.reportbug@mikazuki.thyk ier.net">http://lists.debian.org/20120625094107.21667.84788.reportbug@mikazuki.thyk ier.net
 

Thread Tools




All times are GMT. The time now is 06:12 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org