FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Debian > Debian GCC

 
 
LinkBack Thread Tools
 
Old 04-30-2012, 01:12 PM
Thorsten Glaser
 
Default Bug#670923: gcc-4.7-base: Multi-Arch breakage: differing content in shared files

Package: gcc-4.7-base
Version: 4.7.0-5
Severity: serious

Hi,

trying to upgrade my system breaks the package database, to a
point I have to uninstall all :i386 packages from the amd64
system… using dpkg, as apt goes on a strike.

tg@zigo:~ $ sudo apt-get --purge dist-upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Starting
Starting 2
Done
Done
The following packages have been kept back:
aranym
The following packages will be upgraded:
cpp-4.6-m68k-linux-gnu cvs debootstrap diffutils dpkg dpkg-dev dselect gcc-4.6-m68k-linux-gnu
gcc-4.6-m68k-linux-gnu-base gcc-4.7-base gcc-4.7-base:i386 gdb gdbserver ghostscript iceweasel iptables
isc-dhcp-client isc-dhcp-common ksh lib32gcc1 lib32gomp1 lib32quadmath0 lib32stdc++6 libc-bin libc-dev-bin
libc6 libc6:i386 libc6-dev libc6-dev-i386 libc6-dev-m68k-cross libc6-i386 libc6-m68k-cross libcairo2
libconfig-inifiles-perl libdpkg-perl libgcc1 libgcc1:i386 libgcc2-m68k-cross libglib2.0-0 libgomp1
libgomp1-m68k-cross libgs9 libgs9-common libmozjs10d libnet-ssleay-perl libnewt-dev libnewt0.52 libnss3-1d
libpython2.7 libquadmath0 libslang2 libslang2-dev libssl-dev libssl1.0.0 libstdc++6 libstdc++6-m68k-cross
libtiff4 libusb-1.0-0 libx11-6 libx11-data libx11-xcb1 libxen-4.1 libxenstore3.0 libxml2 libxml2-utils libxt6
libxtst6 libxv1 libyaml-perl linux-libc-dev locales lsb-base lsb-release multiarch-support openssl
python-decorator python2.7 python2.7-dev python2.7-minimal tex-common texlive-base texlive-common
texlive-doc-base texlive-extra-utils texlive-font-utils texlive-fonts-recommended texlive-latex-base
texlive-latex-extra texlive-latex-recommended texlive-pictures whiptail xulrunner-10.0
92 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.
Need to get 83.2 MB/172 MB of archives.
After this operation, 1836 kB of additional disk space will be used.
Do you want to continue [Y/n]?
Get:1 http://ftp.fr.debian.org/debian/ sid/main gcc-4.7-base i386 4.7.0-5 [140 kB]
Get:2 http://ftp.fr.debian.org/debian/ sid/main libgcc1 i386 1:4.7.0-5 [53.3 kB]
Get:3 http://ftp.fr.debian.org/debian/ sid/main libc6 i386 2.13-31 [3920 kB]
Get:4 http://ftp.fr.debian.org/debian/ sid/main libc6-dev-i386 amd64 2.13-31 [1574 kB]
Get:5 https://www.freewrt.org/~tg/debs68k/ cross/main libc6-dev-m68k-cross all 2.13-30 [1939 kB]
Get:6 http://ftp.fr.debian.org/debian/ sid/main libc6-i386 amd64 2.13-31 [4024 kB]
Get:7 http://ftp.fr.debian.org/debian/ sid/main lib32stdc++6 amd64 4.7.0-5 [347 kB]
Get:8 http://ftp.fr.debian.org/debian/ sid/main lib32quadmath0 amd64 4.7.0-5 [198 kB]
Get:9 http://ftp.fr.debian.org/debian/ sid/main lib32gomp1 amd64 4.7.0-5 [30.0 kB]
Get:10 http://ftp.fr.debian.org/debian/ sid/main lib32gcc1 amd64 1:4.7.0-5 [53.1 kB]
Get:11 https://www.freewrt.org/~tg/debs68k/ cross/main libc6-m68k-cross all 2.13-30 [1005 kB]
Get:12 http://ftp.fr.debian.org/debian/ sid/main libslang2-dev amd64 2.2.4-9 [627 kB]
Get:13 http://ftp.fr.debian.org/debian/ sid/main libnewt-dev amd64 0.52.14-9 [94.3 kB]
Get:14 http://ftp.fr.debian.org/debian/ sid/main libnewt0.52 amd64 0.52.14-9 [73.6 kB]
Get:15 http://ftp.fr.debian.org/debian/ sid/main libx11-data all 2:1.4.99.901-2 [186 kB]
Get:16 http://ftp.fr.debian.org/debian/ sid/main libx11-6 amd64 2:1.4.99.901-2 [898 kB]
Get:17 http://ftp.fr.debian.org/debian/ sid/main libnss3-1d amd64 3.13.4-1 [1309 kB]
Get:18 http://ftp.fr.debian.org/debian/ sid/main libusb-1.0-0 amd64 2:1.0.9-1 [39.3 kB]
Get:19 http://ftp.fr.debian.org/debian/ sid/main libx11-xcb1 amd64 2:1.4.99.901-2 [137 kB]
Get:20 http://ftp.fr.debian.org/debian/ sid/main libxv1 amd64 2:1.0.7-1 [21.6 kB]
Get:21 http://ftp.fr.debian.org/debian/ sid/main iptables amd64 1.4.13-1.1 [402 kB]
Get:22 http://ftp.fr.debian.org/debian/ sid/main isc-dhcp-client amd64 4.2.2.dfsg.1-5 [795 kB]
Get:23 http://ftp.fr.debian.org/debian/ sid/main isc-dhcp-common amd64 4.2.2.dfsg.1-5 [855 kB]
Get:24 http://ftp.fr.debian.org/debian/ sid/main whiptail amd64 0.52.14-9 [33.5 kB]
Get:25 http://ftp.fr.debian.org/debian/ sid/main locales all 2.13-31 [5710 kB]
Get:26 http://ftp.fr.debian.org/debian/ sid/main cvs amd64 2:1.12.13+real-9 [2755 kB]
Get:27 http://ftp.fr.debian.org/debian/ sid/main dselect amd64 1.16.3 [1079 kB]
Get:28 http://ftp.fr.debian.org/debian/ sid/main gdbserver amd64 7.4.1-1 [135 kB]
Get:29 http://ftp.fr.debian.org/debian/ sid/main gdb amd64 7.4.1-1 [2436 kB]
Get:30 http://ftp.fr.debian.org/debian/ sid/main ghostscript amd64 9.05~dfsg-5 [82.2 kB]
Get:31 http://ftp.fr.debian.org/debian/ sid/main libgs9 amd64 9.05~dfsg-5 [2316 kB]
Get:32 http://ftp.fr.debian.org/debian/ sid/main libgs9-common all 9.05~dfsg-5 [2187 kB]
Get:33 http://ftp.fr.debian.org/debian/ sid/main xulrunner-10.0 amd64 10.0.4esr-2 [12.0 MB]
Get:34 http://ftp.fr.debian.org/debian/ sid/main libmozjs10d amd64 10.0.4esr-2 [1497 kB]
Get:35 http://ftp.fr.debian.org/debian/ sid/main iceweasel amd64 10.0.4esr-2 [1833 kB]
Get:36 http://ftp.fr.debian.org/debian/ sid/main ksh amd64 93u+-1 [1558 kB]
Get:37 http://ftp.fr.debian.org/debian/ sid/main libxen-4.1 amd64 4.1.2-5 [137 kB]
Get:38 http://ftp.fr.debian.org/debian/ sid/main libxenstore3.0 amd64 4.1.2-5 [27.1 kB]
Get:39 http://ftp.fr.debian.org/debian/ sid/main libxml2-utils amd64 2.7.8.dfsg-9 [94.2 kB]
Get:40 http://ftp.fr.debian.org/debian/ sid/main libyaml-perl all 0.81-1 [72.4 kB]
Get:41 http://ftp.fr.debian.org/debian/ sid/main python-decorator all 3.3.3-1 [21.3 kB]
Get:42 http://ftp.fr.debian.org/debian/ sid/main texlive-extra-utils all 2011.20120424-1 [2414 kB]
Get:43 http://ftp.fr.debian.org/debian/ sid/main texlive-font-utils all 2011.20120424-1 [2045 kB]
Get:44 http://ftp.fr.debian.org/debian/ sid/main texlive-fonts-recommended all 2011.20120424-1 [7118 kB]
Get:45 http://ftp.fr.debian.org/debian/ sid/main texlive-latex-base all 2011.20120424-1 [1425 kB]
Get:46 http://ftp.fr.debian.org/debian/ sid/main texlive-latex-recommended all 2011.20120424-1 [7570 kB]
Get:47 http://ftp.fr.debian.org/debian/ sid/main texlive-pictures all 2011.20120424-1 [2738 kB]
Get:48 http://ftp.fr.debian.org/debian/ sid/main texlive-latex-extra all 2011.20120424-1 [7090 kB]
Get:49 http://ftp.fr.debian.org/debian/ sid/main debootstrap all 1.0.40 [59.3 kB]
Get:50 http://ftp.fr.debian.org/debian/ sid/main libconfig-inifiles-perl all 2.70-1 [52.7 kB]
Fetched 83.2 MB in 7s (11.4 MB/s)
Extracting templates from packages: 100%
Preconfiguring packages ...
(Reading database ... 64935 files and directories currently installed.)
Preparing to replace dpkg 1.16.2 (using .../aptcache/dpkg_1.16.3_amd64.deb) ...
Unpacking replacement dpkg ...
Processing triggers for man-db ...
Setting up dpkg (1.16.3) ...
(Reading database ... 64938 files and directories currently installed.)
Preparing to replace diffutils 1:3.2-3 (using .../diffutils_1%3a3.2-6_amd64.deb) ...
Unpacking replacement diffutils ...
Processing triggers for install-info ...
Processing triggers for man-db ...
Setting up diffutils (1:3.2-6) ...
(Reading database ... 64938 files and directories currently installed.)
Preparing to replace gcc-4.7-base:amd64 4.7.0-3 (using .../gcc-4.7-base_4.7.0-5_amd64.deb) ...
De-configuring gcc-4.7-base:i386 ...
Unpacking replacement gcc-4.7-base:amd64 ...
Preparing to replace gcc-4.7-base:i386 4.7.0-3 (using .../gcc-4.7-base_4.7.0-5_i386.deb) ...
Unpacking replacement gcc-4.7-base:i386 ...
dpkg: error processing /var/cache/pbuilder/aptcache/gcc-4.7-base_4.7.0-5_i386.deb (--unpack):
trying to overwrite shared '/usr/share/doc/gcc-4.7-base/changelog.Debian.gz', which is different from other instances of package gcc-4.7-base:i386
Errors were encountered while processing:
/var/cache/pbuilder/aptcache/gcc-4.7-base_4.7.0-5_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
100|tg@zigo:~ $ sudo apt-get --purge dist-upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
gcc-4.7-base : Breaks: gcc-4.7-base:i386 (!= 4.7.0-5) but 4.7.0-3 is installed
gcc-4.7-base:i386 : Breaks: gcc-4.7-base (!= 4.7.0-3) but 4.7.0-5 is installed
lib32gcc1 : Depends: gcc-4.7-base (= 4.7.0-3) but 4.7.0-5 is installed
lib32gomp1 : Depends: gcc-4.7-base (= 4.7.0-3) but 4.7.0-5 is installed
lib32quadmath0 : Depends: gcc-4.7-base (= 4.7.0-3) but 4.7.0-5 is installed
lib32stdc++6 : Depends: gcc-4.7-base (= 4.7.0-3) but 4.7.0-5 is installed
libgcc1 : Depends: gcc-4.7-base (= 4.7.0-3) but 4.7.0-5 is installed
libgomp1 : Depends: gcc-4.7-base (= 4.7.0-3) but 4.7.0-5 is installed
libquadmath0 : Depends: gcc-4.7-base (= 4.7.0-3) but 4.7.0-5 is installed
libstdc++6 : Depends: gcc-4.7-base (= 4.7.0-3) but 4.7.0-5 is installed
E: Unmet dependencies. Try using -f.
100|tg@zigo:~ $ sudo apt-get --purge -f install
Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies...Starting
Starting 2
Done
Done
Starting
Starting 2
Done
The following extra packages will be installed:
gcc-4.7-base:i386 lib32gcc1 lib32gomp1 lib32quadmath0 lib32stdc++6 libgcc1 libgcc1:i386 libgomp1 libquadmath0
libstdc++6
The following packages will be upgraded:
gcc-4.7-base:i386 lib32gcc1 lib32gomp1 lib32quadmath0 lib32stdc++6 libgcc1 libgcc1:i386 libgomp1 libquadmath0
libstdc++6
10 upgraded, 0 newly installed, 0 to remove and 80 not upgraded.
1 not fully installed or removed.
Need to get 0 B/1350 kB of archives.
After this operation, 0 B of additional disk space will be used.
Do you want to continue [Y/n]?
E: Internal Error, No file name for gcc-4.7-base
1|tg@zigo:~ $ apt-cache policy gcc-4.7-base
gcc-4.7-base:
Installed: 4.7.0-5
Candidate: 4.7.0-5
Version table:
*** 4.7.0-5 0
500 http://ftp.fr.debian.org/debian/ sid/main amd64 Packages
500 http://ftp.de.debian.org/debian/ unstable/main amd64 Packages
100 /var/lib/dpkg/status
4.7.0-3 0
500 http://ftp.fr.debian.org/debian/ wheezy/main amd64 Packages
tg@zigo:~ $ apt-cache policy gcc-4.7-base:i386
gcc-4.7-base:i386:
Installed: 4.7.0-3
Candidate: 4.7.0-5
Version table:
4.7.0-5 0
500 http://ftp.fr.debian.org/debian/ sid/main i386 Packages
*** 4.7.0-3 0
100 /var/lib/dpkg/status



--
To UNSUBSCRIBE, email to debian-gcc-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: Pine.BSM.4.64L.1204301310370.27737@herc.mirbsd.org ">http://lists.debian.org/Pine.BSM.4.64L.1204301310370.27737@herc.mirbsd.org
 

Thread Tools




All times are GMT. The time now is 06:50 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright ©2007 - 2008, www.linux-archive.org