FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Debian > Debian GCC

 
 
LinkBack Thread Tools
 
Old 04-24-2012, 02:23 PM
Vincent Lefevre
 
Default Bug#670264: gcc-snapshot: should be buildable with binutils-gold installed

Package: gcc-snapshot
Version: 20120407-1
Severity: wishlist

I can't build gcc-snapshot if binutils-gold is installed:

ypig:...snapshot-20120407> dpkg-buildpackage -b -uc
dpkg-buildpackage: source package gcc-snapshot
dpkg-buildpackage: source version 20120407-1
dpkg-buildpackage: source changed by Matthias Klose <doko@debian.org>
dpkg-buildpackage: host architecture amd64
dpkg-source --before-build gcc-snapshot-20120407
dpkg-checkbuilddeps: Build conflicts: binutils-gold
dpkg-buildpackage: warning: Build dependencies/conflicts unsatisfied; aborting.
dpkg-buildpackage: warning: (Use -d flag to override.)

It is annoying to remove a package just because to build some
other package.

BTW, binutils-gold just does a divert. There should be a way to
choose the wanted linker.

-- System Information:
Debian Release: wheezy/sid
APT prefers unstable
APT policy: (500, 'unstable'), (500, 'testing'), (500, 'stable'), (1, 'experimental')
Architecture: amd64 (x86_64)

Kernel: Linux 3.2.0-2-amd64 (SMP w/8 CPU cores)
Locale: LANG=POSIX, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages gcc-snapshot depends on:
ii binutils 2.22-6+local1
ii libasound2 1.0.25-2
ii libatk1.0-0 2.4.0-2
ii libc6 2.13-30
ii libc6-dev 2.13-30
ii libc6-dev-i386 2.13-30
ii libc6-i386 2.13-30
ii libcairo2 1.10.2-7
ii libcloog-ppl0 0.15.11-4
ii libecj-java 3.5.1-4
ii libfontconfig1 2.8.0-3.1
ii libfreetype6 2.4.9-1
ii libgdk-pixbuf2.0-0 2.26.1-1
ii libglib2.0-0 2.32.0-4
ii libgmp10 2:5.0.4+dfsg-1
ii libgmpxx4ldbl 2:5.0.4+dfsg-1
ii libgtk2.0-0 2.24.10-1
ii libice6 2:1.0.8-2
ii libmpc2 0.9-4
ii libmpfr4 3.1.0-4
ii libpango1.0-0 1.30.0-1
ii libppl-c4 0.11.2-6
ii libppl9 0.11.2-6
ii libpwl5 0.11.2-6
ii libsm6 2:1.2.1-2
ii libxrandr2 2:1.3.2-2
ii libxrender1 1:0.9.7-1
ii libxtst6 2:1.2.0-4
ii python 2.7.2-10
ii zlib1g 1:1.2.6.dfsg-2

gcc-snapshot recommends no packages.

Versions of packages gcc-snapshot suggests:
ii binutils-gold 2.22-6+local1

-- no debconf information



--
To UNSUBSCRIBE, email to debian-gcc-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 20120424142301.GA10015@ypig.lip.ens-lyon.fr">http://lists.debian.org/20120424142301.GA10015@ypig.lip.ens-lyon.fr
 

Thread Tools




All times are GMT. The time now is 11:54 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org