FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Debian > Debian GCC

 
 
LinkBack Thread Tools
 
Old 12-19-2011, 12:30 AM
 
Default Bug#652597: gcc-4.7-base trying to overwrite '/usr/lib/gcc/i486-linux-gnu/4.6.1'

Package: gcc-4.7-base
Version: 4.7-20111217-1
Severity: important

gcc-4.6-base and gcc-4.7-base disagree on the target of the symlink:
lrwxrwxrwx root/root 0 2011-12-17 07:54 ./usr/lib/gcc/i486-linux-gnu/4.6.1 -> 4.6
lrwxrwxrwx root/root 0 2011-12-17 18:11 ./usr/lib/gcc/i486-linux-gnu/4.6.1 -> 4.7

This renders it uninstallable (without some --force options to dpkg), thereby
breaking quite a few packages that depend on it.

It looks like the symlink in the 4.7 package is a mistake.
(For now, I have forced 4.6-base to overwrite 4.7-base.)

(Severity not serious because I can't find an explicit "must"
or "required" in Debian policy mandating Conflicts: declarations.
Section 3.5 requires declaration of prerequisites, but I cannot
find an explicit requirement for conflicts.)



--
To UNSUBSCRIBE, email to debian-gcc-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 20111219013025.20666.qmail@science.horizon.com">ht tp://lists.debian.org/20111219013025.20666.qmail@science.horizon.com
 

Thread Tools




All times are GMT. The time now is 11:33 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org