FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Debian > Debian GCC

 
 
LinkBack Thread Tools
 
Old 12-13-2011, 03:35 PM
The Wanderer
 
Default Bug#650238: libgcc1 (4.6.2-4) breaks gcc-4.3 << 4.3.6-1, but, there is no package for gcc-4.3(4.3.6-1)

Eh? How is this "wishlist"?

The bug here is that it is possible, using only Debian-provided packages and the
Debian dependencies system, to get the system into a state where it is not
possible to compile modules for the currently-running kernel.

That sounds like a pretty serious problem to me, and certainly not a wish-list
item; I'd think it would break packages which need to compile modules for each
install or upgrade of the package, e.g. dkms module packages.

If the problem can't (yet) be fixed by updating the packages in question to
actually work again, due to compile problems or whatever else, then it should at
the very least be fixed by modifying dependencies so that the system will refuse
to get into that state.


(Honestly, I think it might be a good idea for each linux-image-*
non-metapackage to at least Recommend the package for the compiler with which it
was built. But that's not quite this same problem.)



--
To UNSUBSCRIBE, email to debian-gcc-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 4EE77EC9.1000709@fastmail.fm">http://lists.debian.org/4EE77EC9.1000709@fastmail.fm
 
Old 12-13-2011, 03:43 PM
The Wanderer
 
Default Bug#650238: libgcc1 (4.6.2-4) breaks gcc-4.3 << 4.3.6-1, but, there is no package for gcc-4.3(4.3.6-1)

And one point I forgot: it might be simple enough to fix this by recompiling the
various linux-image-* packages with a newer GCC version, one which can still be
obtained via Debian. However, as far as I can tell by looking at changelogs,
that doesn't seem to have been done.



--
To UNSUBSCRIBE, email to debian-gcc-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 4EE780C1.80009@fastmail.fm">http://lists.debian.org/4EE780C1.80009@fastmail.fm
 
Old 12-17-2011, 01:25 AM
Miles Bader
 
Default Bug#650238: libgcc1 (4.6.2-4) breaks gcc-4.3 << 4.3.6-1, but, there is no package for gcc-4.3(4.3.6-1)

The Wanderer <wanderer@fastmail.fm> writes:
> Eh? How is this "wishlist"?
>
> The bug here is that it is possible, using only Debian-provided
> packages and the Debian dependencies system, to get the system into
> a state where it is not possible to compile modules for the
> currently-running kernel.

Wait, I'm confused... which version of debian/linux are you talking
about?

The kernel in sid/testing seems to be compiled with gcc 4.5.x ... so
what is gcc 4.3.x required for?

-Miles

--
((
(^.^)
(")")
*This is the cute bunny virus, please copy this into your sig so it can spread.


--
To UNSUBSCRIBE, email to debian-gcc-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 87obv8exz4.fsf@catnip.gol.com">http://lists.debian.org/87obv8exz4.fsf@catnip.gol.com
 

Thread Tools




All times are GMT. The time now is 09:51 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org