FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Debian > Debian GCC

 
 
LinkBack Thread Tools
 
Old 11-28-2011, 01:19 AM
Pete Lesko
 
Default Bug#650238: libgcc1 (4.6.2-4) breaks gcc-4.3 << 4.3.6-1, but there is no package for gcc-4.3(4.3.6-1)

Package: libgcc1
Version: 1:4.6.2-4
Severity: important

While trying to compile virtualbox-source, or virtualbox-dkms, I had no linux-headers installed.
I cannot install the headers because it expects gcc-4.3.
gcc-4.3 won't install because the current version of libgcc1 breaks gcc-4.3 before version 4.3.6-1.
As of today, I cannot seem to find a gcc-4.3 package at version 4.3.6-1 anywhere, including unstable.
If I attempt to downgrade libgcc1, it removes virtualbox-source and virtualbox-dkms.

If there is some kind of workaround someone could suggest, I'm more than willing to try it out

-- System Information:
Debian Release: wheezy/sid
APT prefers testing
APT policy: (500, 'testing'), (500, 'stable')
Architecture: i386 (i686)

Kernel: Linux 2.6.32-5-686 (SMP w/1 CPU core)
Locale: LANG=en_US, LC_CTYPE=en_US (charmap=ISO-8859-1)
Shell: /bin/sh linked to /bin/bash

Versions of packages libgcc1 depends on:
ii gcc-4.6-base 4.6.2-4
ii libc6 2.13-21
ii multiarch-support 2.13-21

libgcc1 recommends no packages.

libgcc1 suggests no packages.

-- no debconf information



--
To UNSUBSCRIBE, email to debian-gcc-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 20111128021902.24272.58595.reportbug@localhost">ht tp://lists.debian.org/20111128021902.24272.58595.reportbug@localhost
 
Old 12-03-2011, 01:32 PM
Matthias Klose
 
Default Bug#650238: libgcc1 (4.6.2-4) breaks gcc-4.3 << 4.3.6-1, but there is no package for gcc-4.3(4.3.6-1)

severity 650238 wishlist
tag 650238 + wontfix
thanks

On 11/28/2011 03:19 AM, Pete Lesko wrote:
> Package: libgcc1
> Version: 1:4.6.2-4
> Severity: important
>
> While trying to compile virtualbox-source, or virtualbox-dkms, I had no linux-headers installed.
> I cannot install the headers because it expects gcc-4.3.
> gcc-4.3 won't install because the current version of libgcc1 breaks gcc-4.3 before version 4.3.6-1.
> As of today, I cannot seem to find a gcc-4.3 package at version 4.3.6-1 anywhere, including unstable.
> If I attempt to downgrade libgcc1, it removes virtualbox-source and virtualbox-dkms.
>
> If there is some kind of workaround someone could suggest, I'm more than willing to try it out

http://people.debian.org/~doko/gcc/4.3/
will only be uploaded, if gpc-4.3 builds again. See the sources in this
directory, and send a patch.



--
To UNSUBSCRIBE, email to debian-gcc-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 4EDA32ED.1080708@debian.org">http://lists.debian.org/4EDA32ED.1080708@debian.org
 

Thread Tools




All times are GMT. The time now is 07:11 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org