FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Debian > Debian GCC

 
 
LinkBack Thread Tools
 
Old 11-03-2010, 08:21 PM
Debian FTP Masters
 
Default ppl_0.11-1_amd64.changes ACCEPTED into experimental

Accepted:
libppl-c4_0.11-1_amd64.deb
to main/p/ppl/libppl-c4_0.11-1_amd64.deb
libppl-doc_0.11-1_all.deb
to main/p/ppl/libppl-doc_0.11-1_all.deb
libppl-swi_0.11-1_amd64.deb
to main/p/ppl/libppl-swi_0.11-1_amd64.deb
libppl0.11-dev_0.11-1_amd64.deb
to main/p/ppl/libppl0.11-dev_0.11-1_amd64.deb
libppl9_0.11-1_amd64.deb
to main/p/ppl/libppl9_0.11-1_amd64.deb
libpwl-dev_0.11-1_amd64.deb
to main/p/ppl/libpwl-dev_0.11-1_amd64.deb
libpwl5_0.11-1_amd64.deb
to main/p/ppl/libpwl5_0.11-1_amd64.deb
ppl_0.11-1.debian.tar.gz
to main/p/ppl/ppl_0.11-1.debian.tar.gz
ppl_0.11-1.dsc
to main/p/ppl/ppl_0.11-1.dsc
ppl_0.11.orig.tar.bz2
to main/p/ppl/ppl_0.11.orig.tar.bz2


Override entries for your package:
libppl-c4_0.11-1_amd64.deb - optional libs
libppl-doc_0.11-1_all.deb - optional doc
libppl-swi_0.11-1_amd64.deb - optional libs
libppl0.11-dev_0.11-1_amd64.deb - optional libdevel
libppl9_0.11-1_amd64.deb - optional libs
libpwl-dev_0.11-1_amd64.deb - optional libdevel
libpwl5_0.11-1_amd64.deb - optional libs
ppl_0.11-1.dsc - source libs

Announcing to debian-devel-changes@lists.debian.org


Thank you for your contribution to Debian.


--
To UNSUBSCRIBE, email to debian-gcc-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: E1PDklg-0006RS-6u@franck.debian.org">http://lists.debian.org/E1PDklg-0006RS-6u@franck.debian.org
 
Old 11-04-2010, 04:18 PM
Matthias Klose
 
Default ppl_0.11-1_amd64.changes ACCEPTED into experimental

while you do provide versioned -dev packages, you didn't rename the source
package, so currently only 0.10 or 0.11 will be available. Not sure if I do want
to backport the ppl 0.11 support to 4.4 and 4.5.


Matthias

On 03.11.2010 22:21, Debian FTP Masters wrote:




Accepted:
libppl-c4_0.11-1_amd64.deb
to main/p/ppl/libppl-c4_0.11-1_amd64.deb
libppl-doc_0.11-1_all.deb
to main/p/ppl/libppl-doc_0.11-1_all.deb
libppl-swi_0.11-1_amd64.deb
to main/p/ppl/libppl-swi_0.11-1_amd64.deb
libppl0.11-dev_0.11-1_amd64.deb
to main/p/ppl/libppl0.11-dev_0.11-1_amd64.deb
libppl9_0.11-1_amd64.deb
to main/p/ppl/libppl9_0.11-1_amd64.deb
libpwl-dev_0.11-1_amd64.deb
to main/p/ppl/libpwl-dev_0.11-1_amd64.deb
libpwl5_0.11-1_amd64.deb
to main/p/ppl/libpwl5_0.11-1_amd64.deb
ppl_0.11-1.debian.tar.gz
to main/p/ppl/ppl_0.11-1.debian.tar.gz
ppl_0.11-1.dsc
to main/p/ppl/ppl_0.11-1.dsc
ppl_0.11.orig.tar.bz2
to main/p/ppl/ppl_0.11.orig.tar.bz2


Override entries for your package:
libppl-c4_0.11-1_amd64.deb - optional libs
libppl-doc_0.11-1_all.deb - optional doc
libppl-swi_0.11-1_amd64.deb - optional libs
libppl0.11-dev_0.11-1_amd64.deb - optional libdevel
libppl9_0.11-1_amd64.deb - optional libs
libpwl-dev_0.11-1_amd64.deb - optional libdevel
libpwl5_0.11-1_amd64.deb - optional libs
ppl_0.11-1.dsc - source libs

Announcing to debian-devel-changes@lists.debian.org


Thank you for your contribution to Debian.





--
To UNSUBSCRIBE, email to debian-gcc-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 4CD2EAEF.9090407@debian.org">http://lists.debian.org/4CD2EAEF.9090407@debian.org
 
Old 11-04-2010, 04:57 PM
Michael Tautschnig
 
Default ppl_0.11-1_amd64.changes ACCEPTED into experimental

> while you do provide versioned -dev packages, you didn't rename the
> source package, so currently only 0.10 or 0.11 will be available.
> Not sure if I do want to backport the ppl 0.11 support to 4.4 and
> 4.5.
>

[...]

Is there actually any backporting work necessary, or is it just recompiling?
I'll of course check this myself if you could just give me any hints which
package to try to build and, if you already know of any, which obstacles I might
find.

Thanks a lot,
Michael
 
Old 11-13-2010, 07:56 PM
Matthias Klose
 
Default ppl_0.11-1_amd64.changes ACCEPTED into experimental

On 04.11.2010 18:57, Michael Tautschnig wrote:

while you do provide versioned -dev packages, you didn't rename the
source package, so currently only 0.10 or 0.11 will be available.
Not sure if I do want to backport the ppl 0.11 support to 4.4 and
4.5.



[...]

Is there actually any backporting work necessary, or is it just recompiling?
I'll of course check this myself if you could just give me any hints which
package to try to build and, if you already know of any, which obstacles I might
find.


the old cloog-ppl won't be developed further. If you could check that the
current cloog-ppl still builds and works with the current ppl, and you can
assure this for the lifetime of gcc-4.4 in unstable, then you maybe can build
from the same source. If not, maybe renaming the source is easier


Matthias


--
To UNSUBSCRIBE, email to debian-gcc-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 4CDEFB78.9050208@debian.org">http://lists.debian.org/4CDEFB78.9050208@debian.org
 
Old 11-13-2010, 08:05 PM
Michael Tautschnig
 
Default ppl_0.11-1_amd64.changes ACCEPTED into experimental

Hi Matthias,

Thanks a lot for getting back to me.

[...]

> >
> >Is there actually any backporting work necessary, or is it just recompiling?
> >I'll of course check this myself if you could just give me any hints which
> >package to try to build and, if you already know of any, which obstacles I might
> >find.
>
> the old cloog-ppl won't be developed further. If you could check
> that the current cloog-ppl still builds and works with the current
> ppl, and you can assure this for the lifetime of gcc-4.4 in
> unstable, then you maybe can build from the same source. If not,
> maybe renaming the source is easier
>

Could you please only let me know which versions you refer to as "old" and
"new"? It seems that Debian has 0.15.9 while on the homepage of cloog I can only
find 0.14.1 (and git even has only 0.14.0 tagged) and some "Development
Version."

Thanks a lot,
Michael
 
Old 11-13-2010, 09:08 PM
Matthias Klose
 
Default ppl_0.11-1_amd64.changes ACCEPTED into experimental

On 13.11.2010 22:05, Michael Tautschnig wrote:

Hi Matthias,

Thanks a lot for getting back to me.

[...]



Is there actually any backporting work necessary, or is it just recompiling?
I'll of course check this myself if you could just give me any hints which
package to try to build and, if you already know of any, which obstacles I might
find.


the old cloog-ppl won't be developed further. If you could check
that the current cloog-ppl still builds and works with the current
ppl, and you can assure this for the lifetime of gcc-4.4 in
unstable, then you maybe can build from the same source. If not,
maybe renaming the source is easier



Could you please only let me know which versions you refer to as "old" and
"new"? It seems that Debian has 0.15.9 while on the homepage of cloog I can only
find 0.14.1 (and git even has only 0.14.0 tagged) and some "Development
Version."


see the GCC build requirements where to download 0.15.9. 0.15.10 just contains a
consistency check, no need to update.


afaics cloog-isl isn't yet released. please see the gcc-patches ML for further
information.


Matthias


--
To UNSUBSCRIBE, email to debian-gcc-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 4CDF0C6D.3060105@debian.org">http://lists.debian.org/4CDF0C6D.3060105@debian.org
 
Old 11-13-2010, 09:54 PM
Michael Tautschnig
 
Default ppl_0.11-1_amd64.changes ACCEPTED into experimental

[...]

>
> see the GCC build requirements where to download 0.15.9. 0.15.10
> just contains a consistency check, no need to update.
>

[...]

0.15.10 compiles fine with ppl 0.11 and passes all tests. Given that Roberto
Bagnara, head of PPL development, seems to be actively working with cloog
developers I don't expect this to change any time soon.

Best regards,
Michael
 
Old 12-31-2010, 12:51 AM
Matthias Klose
 
Default ppl_0.11-1_amd64.changes ACCEPTED into experimental

On 13.11.2010 23:54, Michael Tautschnig wrote:

[...]



see the GCC build requirements where to download 0.15.9. 0.15.10
just contains a consistency check, no need to update.



[...]

0.15.10 compiles fine with ppl 0.11 and passes all tests. Given that Roberto
Bagnara, head of PPL development, seems to be actively working with cloog
developers I don't expect this to change any time soon.


so looks like GCC-4.6 will require parma-ppl-0.16 and ppl-0.11, and for now I
don't see any backports/updates for both GCC-4.4 and GCC-4.5. So, we'll need to
have these in parallel. Please rename the source of one of these versions,
probably more easy to rename the one in experimental during the freeze.


Matthias


--
To UNSUBSCRIBE, email to debian-gcc-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 4D1D3734.3010300@debian.org">http://lists.debian.org/4D1D3734.3010300@debian.org
 

Thread Tools




All times are GMT. The time now is 07:18 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org