FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Debian > Debian GCC

 
 
LinkBack Thread Tools
 
Old 06-04-2010, 01:38 PM
Rene Engelhard
 
Default Bug#584545: unsatifisable >= in .shlibs, makes -gcj packages uninstallable

Package: libgcj-bc
Version: 4.4.4-1
Severity: serious

I was just testing OpenOffice.org 1:3.2.1-1 (built on uptodate sid):

rene@frodo:~/Debian/Pakete/openoffice.org$ sudo dpkg -i openoffice.org-gcj_3.2.1-1_amd64.deb
Selecting previously deselected package openoffice.org-gcj.
(Reading database ... 328585 files and directories currently installed.)
Unpacking openoffice.org-gcj (from openoffice.org-gcj_3.2.1-1_amd64.deb) ...
dpkg: dependency problems prevent configuration of openoffice.org-gcj:
openoffice.org-gcj depends on libgcj-bc (>= 4.4.4-2); however:
Version of libgcj-bc on system is 4.4.4-1.
dpkg: error processing openoffice.org-gcj (--install):
dependency problems - leaving unconfigured
Errors were encountered while processing:
openoffice.org-gcj

Let's see:

$ cat /var/lib/dpkg/info/libgcj-bc.shlibs
libgcj_bc 1 libgcj-bc (>= 4.4.4-2)

$ rmadison -s unstable libgcj-bc
libgcj-bc | 4.4.4-1 | unstable | alpha, amd64, armel, hppa, hurd-i386, i386, ia64, kfreebsd-amd64, kfreebsd-i386, mips, mipsel, powerpc, s390, sparc

So the .shlibs adds a dependency on a non-existing version and thus
makes built -gcj packages uninstallable.

-- System Information:
Debian Release: squeeze/sid
APT prefers unstable
APT policy: (500, 'unstable'), (1, 'experimental')
Architecture: amd64 (x86_64)

Kernel: Linux 2.6.32-5-amd64 (SMP w/2 CPU cores)
Locale: LANG=C, LC_CTYPE=C (charmap=ANSI_X3.4-1968)
Shell: /bin/sh linked to /bin/bash

Versions of packages libgcj-bc depends on:
ii libgcj-common 1:4.4.4-1 Java runtime library (common files
ii libgcj10 4.4.4-2 Java runtime library for use with

libgcj-bc recommends no packages.

libgcj-bc suggests no packages.

-- no debconf information

Regards,

Rene



--
To UNSUBSCRIBE, email to debian-gcc-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 20100604133841.GA9120@rene-engelhard.de">http://lists.debian.org/20100604133841.GA9120@rene-engelhard.de
 
Old 06-04-2010, 08:08 PM
Rene Engelhard
 
Default Bug#584545: unsatifisable >= in .shlibs, makes -gcj packages uninstallable

Hi,

On Fri, Jun 04, 2010 at 03:38:41PM +0200, Rene Engelhard wrote:
> So the .shlibs adds a dependency on a non-existing version and thus
> makes built -gcj packages uninstallable.

Thankfully any upload of gcc-defaults would most probably automagically
fix this, but I'd still prefer it saying >= 4.4.4-1.

René
--
.'`. René Engelhard -- Debian GNU/Linux Developer
: :' : http://www.debian.org | http://people.debian.org/~rene/
`. `' rene@debian.org | GnuPG-Key ID: D03E3E70
`- Fingerprint: E12D EA46 7506 70CF A960 801D 0AA0 4571 D03E 3E70



--
To UNSUBSCRIBE, email to debian-gcc-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 20100604200809.GB16875@rene-engelhard.de">http://lists.debian.org/20100604200809.GB16875@rene-engelhard.de
 

Thread Tools




All times are GMT. The time now is 11:50 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright ©2007 - 2008, www.linux-archive.org