FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Debian > Debian GCC

 
 
LinkBack Thread Tools
 
Old 05-26-2010, 01:35 AM
Nobuhiro Iwamatsu
 
Default Bug#583179: gcc-4.4: Cannot create libstdc++6 package on debian-ports.

Source: gcc-4.4
Version: 4.4.4-2
Severity: important
Tags: patch
User: debian-sh4@superh.org
Usertags: sh4
X-Debbugs-CC: debian-superh@lists.debian.org, brad@brad-smith.co.uk,
debian-sparc@lists.debian.org, debian-powerpcspe@breakpoint.cc

Hi,

The architecture in debian-ports cannot create libstdc++6 package.

sh4:
http://buildd.debian-ports.org/fetch.php?pkg=gcc-4.4&arch=sh4&ver=4.4.4-2&stamp=1274695413&file=log&as=raw
Checksums-Sha1:
d4e125c4ebf2456e06636b02fd4b26cd65c52d75 116580 gcc-4.4-base_4.4.4-2_sh4.deb
642d3ed8b89a4af94f7a2139e449530cf5f7ebb5 3462948 cpp-4.4_4.4.4-2_sh4.deb
6adde72bf313a3717a578852f7a48d6696a74526 113884
libmudflap0-4.4-dev_4.4.4-2_sh4.deb
3bce8de8fc62e96c81fc8e5e24bb5c7755da51c6 3772014 gobjc++-4.4_4.4.4-2_sh4.deb
09a5e6f32b5ccbb423b90ab08a30a33c4bc9aab8 3619622 gobjc-4.4_4.4.4-2_sh4.deb
7fc843071cd60886aeb6d976bee21e69cf011a48 4652232 g++-4.4_4.4.4-2_sh4.deb
e5d4b8b92d4dee4ffb69ac3c346e7d39d52702ee 1547646
libstdc++6-4.4-dev_4.4.4-2_sh4.deb
79a580d709c113e559f044147d243fd9f948fb02 539696
libstdc++6-4.4-pic_4.4.4-2_sh4.deb
437696b0c3eb8002513840ba7da2a465957dfe4b 5162760
libstdc++6-4.4-dbg_4.4.4-2_sh4.deb
3fed52b358cdfb0006f809f611c4b3ebc70bba57 3977224 gfortran-4.4_4.4.4-2_sh4.deb
be256cbdbdaf431854e0e66d2c701bfd13982320 498858 gcc-4.4_4.4.4-2_sh4.deb

sparc64:
http://buildd.debian-ports.org/fetch.php?pkg=gcc-4.4&arch=sparc64&ver=4.4.4-2&stamp=1274262351&file=log&as=raw

Checksums-Sha1:
8b06beca8df50df75a0d96db0d3196caa5747e2a 116552
gcc-4.4-base_4.4.4-2_sparc64.deb
92bd38a89105f800de8b3eb283707e09428dcf84 3181306 cpp-4.4_4.4.4-2_sparc64.deb
b2ff9b5bbc992f92bd5341a4ca6552690e80d6b5 128646
libmudflap0-4.4-dev_4.4.4-2_sparc64.deb
fbd487f06a18ec8b40841026df15fcd24912b97c 3472330
gobjc++-4.4_4.4.4-2_sparc64.deb
16892c4119251890c865c56d074537a3d78bbd5c 3347438 gobjc-4.4_4.4.4-2_sparc64.deb
4a6cabfdfa6b4ae531c15432188eafd4455902a2 4370776 g++-4.4_4.4.4-2_sparc64.deb
e1818c73e2d0ed391fdac0b90dc1b390c3f77850 1536252
libstdc++6-4.4-dev_4.4.4-2_sparc64.deb
3b8c4356a104628f3dfae55b54b66a947cddc4e4 520690
libstdc++6-4.4-pic_4.4.4-2_sparc64.deb
a226673e6c5e3149e55740a53aa6f6c93c852edb 5391958
libstdc++6-4.4-dbg_4.4.4-2_sparc64.deb
12a9fcedbbd10528b9fdf77053b47ee840f8a6e5 3753706
gfortran-4.4_4.4.4-2_sparc64.deb
5294980c9beb24c0951cd6b0e0b3452c5191684a 500886 gcc-4.4_4.4.4-2_sparc64.deb


Because these cannot get codename by lsb_release command,
with_common_pkgs and with_common_libs are set to "no".
And with_libcxx is not set to "yes".

I made patch to support this. Could you apply this patch?

Best regards,
Nobuhiro


--
Nobuhiro Iwamatsu
iwamatsu at {nigauri.org / debian.org}
GPG ID: 40AD1FA6
 
Old 05-26-2010, 07:08 AM
Aurelien Jarno
 
Default Bug#583179: gcc-4.4: Cannot create libstdc++6 package on debian-ports.

On Wed, May 26, 2010 at 10:35:56AM +0900, Nobuhiro Iwamatsu wrote:
> Source: gcc-4.4
> Version: 4.4.4-2
> Severity: important
> Tags: patch
> User: debian-sh4@superh.org
> Usertags: sh4
> X-Debbugs-CC: debian-superh@lists.debian.org, brad@brad-smith.co.uk,
> debian-sparc@lists.debian.org, debian-powerpcspe@breakpoint.cc
>
> Hi,
>
> The architecture in debian-ports cannot create libstdc++6 package.
>
> sh4:
> http://buildd.debian-ports.org/fetch.php?pkg=gcc-4.4&arch=sh4&ver=4.4.4-2&stamp=1274695413&file=log&as=raw
> Checksums-Sha1:
> d4e125c4ebf2456e06636b02fd4b26cd65c52d75 116580 gcc-4.4-base_4.4.4-2_sh4.deb
> 642d3ed8b89a4af94f7a2139e449530cf5f7ebb5 3462948 cpp-4.4_4.4.4-2_sh4.deb
> 6adde72bf313a3717a578852f7a48d6696a74526 113884
> libmudflap0-4.4-dev_4.4.4-2_sh4.deb
> 3bce8de8fc62e96c81fc8e5e24bb5c7755da51c6 3772014 gobjc++-4.4_4.4.4-2_sh4.deb
> 09a5e6f32b5ccbb423b90ab08a30a33c4bc9aab8 3619622 gobjc-4.4_4.4.4-2_sh4.deb
> 7fc843071cd60886aeb6d976bee21e69cf011a48 4652232 g++-4.4_4.4.4-2_sh4.deb
> e5d4b8b92d4dee4ffb69ac3c346e7d39d52702ee 1547646
> libstdc++6-4.4-dev_4.4.4-2_sh4.deb
> 79a580d709c113e559f044147d243fd9f948fb02 539696
> libstdc++6-4.4-pic_4.4.4-2_sh4.deb
> 437696b0c3eb8002513840ba7da2a465957dfe4b 5162760
> libstdc++6-4.4-dbg_4.4.4-2_sh4.deb
> 3fed52b358cdfb0006f809f611c4b3ebc70bba57 3977224 gfortran-4.4_4.4.4-2_sh4.deb
> be256cbdbdaf431854e0e66d2c701bfd13982320 498858 gcc-4.4_4.4.4-2_sh4.deb
>
> sparc64:
> http://buildd.debian-ports.org/fetch.php?pkg=gcc-4.4&arch=sparc64&ver=4.4.4-2&stamp=1274262351&file=log&as=raw
>
> Checksums-Sha1:
> 8b06beca8df50df75a0d96db0d3196caa5747e2a 116552
> gcc-4.4-base_4.4.4-2_sparc64.deb
> 92bd38a89105f800de8b3eb283707e09428dcf84 3181306 cpp-4.4_4.4.4-2_sparc64.deb
> b2ff9b5bbc992f92bd5341a4ca6552690e80d6b5 128646
> libmudflap0-4.4-dev_4.4.4-2_sparc64.deb
> fbd487f06a18ec8b40841026df15fcd24912b97c 3472330
> gobjc++-4.4_4.4.4-2_sparc64.deb
> 16892c4119251890c865c56d074537a3d78bbd5c 3347438 gobjc-4.4_4.4.4-2_sparc64.deb
> 4a6cabfdfa6b4ae531c15432188eafd4455902a2 4370776 g++-4.4_4.4.4-2_sparc64.deb
> e1818c73e2d0ed391fdac0b90dc1b390c3f77850 1536252
> libstdc++6-4.4-dev_4.4.4-2_sparc64.deb
> 3b8c4356a104628f3dfae55b54b66a947cddc4e4 520690
> libstdc++6-4.4-pic_4.4.4-2_sparc64.deb
> a226673e6c5e3149e55740a53aa6f6c93c852edb 5391958
> libstdc++6-4.4-dbg_4.4.4-2_sparc64.deb
> 12a9fcedbbd10528b9fdf77053b47ee840f8a6e5 3753706
> gfortran-4.4_4.4.4-2_sparc64.deb
> 5294980c9beb24c0951cd6b0e0b3452c5191684a 500886 gcc-4.4_4.4.4-2_sparc64.deb
>
>
> Because these cannot get codename by lsb_release command,
> with_common_pkgs and with_common_libs are set to "no".
> And with_libcxx is not set to "yes".
>
> I made patch to support this. Could you apply this patch?
>

I have committed a patch yesterday to fix this issue. It's a different
approach, but that should also work:

gcc-4.4 (4.4.4-2) unstable; urgency=low
Index: debian/rules.defs
================================================== =================
--- debian/rules.defs (révision 4438)
+++ debian/rules.defs (copie de travail)
@@ -8,13 +8,13 @@
builddir = $(PWD)/build
stampdir = stamps

-# FIXME: lsb_release triggers a kernel bug on the Debian mips/mipsel buildds
-ifneq (,$(filter $(DEB_TARGET_ARCH),mips mipsel))
- distribution := Debian
- distrelease := sid
-else
- distribution := $(shell lsb_release -is)
- distrelease := $(shell lsb_release -cs)
+distribution := $(shell lsb_release -is)
+distrelease := $(shell lsb_release -cs)
+
+# On non official archives, "lsb_release -cs" default to "n/a". Assume
+# sid in that case
+ifeq ($(distrelease),n/a)
+distrelease := sid
endif

# creates {srcdir,builddir}_{hppa64,ia6432,spu}


--
Aurelien Jarno GPG: 1024D/F1BCDB73
aurelien@aurel32.net http://www.aurel32.net



--
To UNSUBSCRIBE, email to debian-gcc-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 20100526070809.GA22083@volta.aurel32.net">http://lists.debian.org/20100526070809.GA22083@volta.aurel32.net
 
Old 05-26-2010, 07:15 AM
Nobuhiro Iwamatsu
 
Default Bug#583179: gcc-4.4: Cannot create libstdc++6 package on debian-ports.

Hi, Aurelien.

Your patch is simpler and is good, I think.
It is not necessary for this to support the new debian-ports architecture.
Thanks!

Best regards,
Nobuhiro


2010/5/26 Aurelien Jarno <aurelien@aurel32.net>:
> On Wed, May 26, 2010 at 10:35:56AM +0900, Nobuhiro Iwamatsu wrote:
>> Source: gcc-4.4
>> Version: 4.4.4-2
>> Severity: important
>> Tags: patch
>> User: debian-sh4@superh.org
>> Usertags: sh4
>> X-Debbugs-CC: debian-superh@lists.debian.org, brad@brad-smith.co.uk,
>> debian-sparc@lists.debian.org, debian-powerpcspe@breakpoint.cc
>>
>> Hi,
>>
>> The architecture in debian-ports cannot create libstdc++6 package.
>>
>> sh4:
>> http://buildd.debian-ports.org/fetch.php?pkg=gcc-4.4&arch=sh4&ver=4.4.4-2&stamp=1274695413&file=log&as=raw
>> Checksums-Sha1:
>> *d4e125c4ebf2456e06636b02fd4b26cd65c52d75 116580 gcc-4.4-base_4.4.4-2_sh4.deb
>> *642d3ed8b89a4af94f7a2139e449530cf5f7ebb5 3462948 cpp-4.4_4.4.4-2_sh4.deb
>> *6adde72bf313a3717a578852f7a48d6696a74526 113884
>> libmudflap0-4.4-dev_4.4.4-2_sh4.deb
>> *3bce8de8fc62e96c81fc8e5e24bb5c7755da51c6 3772014 gobjc++-4.4_4.4.4-2_sh4.deb
>> *09a5e6f32b5ccbb423b90ab08a30a33c4bc9aab8 3619622 gobjc-4.4_4.4.4-2_sh4.deb
>> *7fc843071cd60886aeb6d976bee21e69cf011a48 4652232 g++-4.4_4.4.4-2_sh4.deb
>> *e5d4b8b92d4dee4ffb69ac3c346e7d39d52702ee 1547646
>> libstdc++6-4.4-dev_4.4.4-2_sh4.deb
>> *79a580d709c113e559f044147d243fd9f948fb02 539696
>> libstdc++6-4.4-pic_4.4.4-2_sh4.deb
>> *437696b0c3eb8002513840ba7da2a465957dfe4b 5162760
>> libstdc++6-4.4-dbg_4.4.4-2_sh4.deb
>> *3fed52b358cdfb0006f809f611c4b3ebc70bba57 3977224 gfortran-4.4_4.4.4-2_sh4.deb
>> *be256cbdbdaf431854e0e66d2c701bfd13982320 498858 gcc-4.4_4.4.4-2_sh4.deb
>>
>> sparc64:
>> http://buildd.debian-ports.org/fetch.php?pkg=gcc-4.4&arch=sparc64&ver=4.4.4-2&stamp=1274262351&file=log&as=raw
>>
>> Checksums-Sha1:
>> *8b06beca8df50df75a0d96db0d3196caa5747e2a 116552
>> gcc-4.4-base_4.4.4-2_sparc64.deb
>> *92bd38a89105f800de8b3eb283707e09428dcf84 3181306 cpp-4.4_4.4.4-2_sparc64.deb
>> *b2ff9b5bbc992f92bd5341a4ca6552690e80d6b5 128646
>> libmudflap0-4.4-dev_4.4.4-2_sparc64.deb
>> *fbd487f06a18ec8b40841026df15fcd24912b97c 3472330
>> gobjc++-4.4_4.4.4-2_sparc64.deb
>> *16892c4119251890c865c56d074537a3d78bbd5c 3347438 gobjc-4.4_4.4.4-2_sparc64.deb
>> *4a6cabfdfa6b4ae531c15432188eafd4455902a2 4370776 g++-4.4_4.4.4-2_sparc64.deb
>> *e1818c73e2d0ed391fdac0b90dc1b390c3f77850 1536252
>> libstdc++6-4.4-dev_4.4.4-2_sparc64.deb
>> *3b8c4356a104628f3dfae55b54b66a947cddc4e4 520690
>> libstdc++6-4.4-pic_4.4.4-2_sparc64.deb
>> *a226673e6c5e3149e55740a53aa6f6c93c852edb 5391958
>> libstdc++6-4.4-dbg_4.4.4-2_sparc64.deb
>> *12a9fcedbbd10528b9fdf77053b47ee840f8a6e5 3753706
>> gfortran-4.4_4.4.4-2_sparc64.deb
>> *5294980c9beb24c0951cd6b0e0b3452c5191684a 500886 gcc-4.4_4.4.4-2_sparc64.deb
>>
>>
>> Because these cannot get codename by lsb_release command,
>> with_common_pkgs and with_common_libs are set to "no".
>> And with_libcxx is not set to "yes".
>>
>> I made patch to support this. Could you apply this patch?
>>
>
> I have committed a patch yesterday to fix this issue. It's a different
> approach, but that should also work:
>
> gcc-4.4 (4.4.4-2) unstable; urgency=low
> Index: debian/rules.defs
> ================================================== =================
> --- debian/rules.defs * (révision 4438)
> +++ debian/rules.defs * (copie de travail)
> @@ -8,13 +8,13 @@
> *builddir * * * = $(PWD)/build
> *stampdir * * * = stamps
>
> -# FIXME: lsb_release triggers a kernel bug on the Debian mips/mipsel buildds
> -ifneq (,$(filter $(DEB_TARGET_ARCH),mips mipsel))
> - *distribution := Debian
> - *distrelease *:= sid
> -else
> - *distribution := $(shell lsb_release -is)
> - *distrelease *:= $(shell lsb_release -cs)
> +distribution * := $(shell lsb_release -is)
> +distrelease * *:= $(shell lsb_release -cs)
> +
> +# On non official archives, "lsb_release -cs" default to "n/a". Assume
> +# sid in that case
> +ifeq ($(distrelease),n/a)
> +distrelease * *:= sid
> *endif
>
> *# creates {srcdir,builddir}_{hppa64,ia6432,spu}
>
>
> --
> Aurelien Jarno * * * * * * * * * * * * *GPG: 1024D/F1BCDB73
> aurelien@aurel32.net * * * * * * * * http://www.aurel32.net
>



--
Nobuhiro Iwamatsu
iwamatsu at {nigauri.org / debian.org}
GPG ID: 40AD1FA6



--
To UNSUBSCRIBE, email to debian-gcc-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: AANLkTilrom3TD8rvEggO1KZLZT0svmTNfHClT7PJ03Sd@mail .gmail.com">http://lists.debian.org/AANLkTilrom3TD8rvEggO1KZLZT0svmTNfHClT7PJ03Sd@mail .gmail.com
 

Thread Tools




All times are GMT. The time now is 06:30 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright ©2007 - 2008, www.linux-archive.org