Linux Archive

Linux Archive (http://www.linux-archive.org/)
-   Debian GCC (http://www.linux-archive.org/debian-gcc/)
-   -   Bug#573487: gdc-4.3 and gdc: error when trying to install together (http://www.linux-archive.org/debian-gcc/340134-bug-573487-gdc-4-3-gdc-error-when-trying-install-together.html)

Ralf Treinen 03-11-2010 07:25 PM

Bug#573487: gdc-4.3 and gdc: error when trying to install together
 
Package: gdc,gdc-4.3
Version: gdc/4.1.2-42
Version: gdc-4.3/2.015-4.3.4-1
Severity: serious
User: treinen@debian.org
Usertags: edos-file-overwrite

Date: 2010-03-11
Architecture: amd64
Distribution: sid

Hi,

automatic installation tests of packages that share a file and at the
same time do not conflict by their package dependency relationships has
detected the following problem:


WARNING: The following packages cannot be authenticated!
binutils gcc-4.1-base cpp-4.1 libgmp3c2 libmpfr1ldbl cpp-4.3 gcc-4.1
libc-dev-bin linux-libc-dev libc6-dev libstdc++6-4.1-dev g++-4.1 libgomp1
gcc-4.3 libstdc++6-4.3-dev g++-4.3 zlib1g-dev libphobos-4.1-dev gdc-4.1 gdc
gdc-4.3
W: cowdancer: unsupported operation flock, read-only open and fchown/fchmod/flock are not supported: tried openning dev:inode of 2055:5406756
W: cowdancer: unsupported operation flock, read-only open and fchown/fchmod/flock are not supported: tried openning dev:inode of 2055:5407760
W: cowdancer: unsupported operation flock, read-only open and fchown/fchmod/flock are not supported: tried openning dev:inode of 2055:5406730
Authentication warning overridden.
Can not write log, openpty() failed (/dev/pts not mounted?)
Selecting previously deselected package binutils.
(Reading database ... 12298 files and directories currently installed.)
Unpacking binutils (from .../binutils_2.20.1-2_amd64.deb) ...
Selecting previously deselected package gcc-4.1-base.
Unpacking gcc-4.1-base (from .../gcc-4.1-base_4.1.2-27_amd64.deb) ...
Selecting previously deselected package cpp-4.1.
Unpacking cpp-4.1 (from .../cpp-4.1_4.1.2-27_amd64.deb) ...
Selecting previously deselected package libgmp3c2.
Unpacking libgmp3c2 (from .../libgmp3c2_2%3a4.3.2+dfsg-1_amd64.deb) ...
Selecting previously deselected package libmpfr1ldbl.
Unpacking libmpfr1ldbl (from .../libmpfr1ldbl_2.4.2-3_amd64.deb) ...
Selecting previously deselected package cpp-4.3.
Unpacking cpp-4.3 (from .../cpp-4.3_4.3.4-8_amd64.deb) ...
Selecting previously deselected package gcc-4.1.
Unpacking gcc-4.1 (from .../gcc-4.1_4.1.2-27_amd64.deb) ...
Selecting previously deselected package libc-dev-bin.
Unpacking libc-dev-bin (from .../libc-dev-bin_2.10.2-6_amd64.deb) ...
Selecting previously deselected package linux-libc-dev.
Unpacking linux-libc-dev (from .../linux-libc-dev_2.6.32-9_amd64.deb) ...
Selecting previously deselected package libc6-dev.
Unpacking libc6-dev (from .../libc6-dev_2.10.2-6_amd64.deb) ...
Selecting previously deselected package libstdc++6-4.1-dev.
Unpacking libstdc++6-4.1-dev (from .../libstdc++6-4.1-dev_4.1.2-27_amd64.deb) ...
Selecting previously deselected package g++-4.1.
Unpacking g++-4.1 (from .../g++-4.1_4.1.2-27_amd64.deb) ...
Selecting previously deselected package libgomp1.
Unpacking libgomp1 (from .../libgomp1_4.4.3-3_amd64.deb) ...
Selecting previously deselected package gcc-4.3.
Unpacking gcc-4.3 (from .../gcc-4.3_4.3.4-8_amd64.deb) ...
Selecting previously deselected package libstdc++6-4.3-dev.
Unpacking libstdc++6-4.3-dev (from .../libstdc++6-4.3-dev_4.3.4-8_amd64.deb) ...
Selecting previously deselected package g++-4.3.
Unpacking g++-4.3 (from .../g++-4.3_4.3.4-8_amd64.deb) ...
Selecting previously deselected package zlib1g-dev.
Unpacking zlib1g-dev (from .../zlib1g-dev_1%3a1.2.3.4.dfsg-3_amd64.deb) ...
Selecting previously deselected package libphobos-4.1-dev.
Unpacking libphobos-4.1-dev (from .../libphobos-4.1-dev_0.25-4.1.2-27_amd64.deb) ...
Selecting previously deselected package gdc-4.1.
Unpacking gdc-4.1 (from .../gdc-4.1_0.25-4.1.2-27_amd64.deb) ...
Selecting previously deselected package gdc.
Unpacking gdc (from .../gdc_4.1.2-42_amd64.deb) ...
Selecting previously deselected package gdc-4.3.
Unpacking gdc-4.3 (from .../gdc-4.3_2.015-4.3.4-1_amd64.deb) ...
dpkg: error processing /var/cache/apt/archives/gdc-4.3_2.015-4.3.4-1_amd64.deb (--unpack):
trying to overwrite '/usr/share/man/man1/gdmd.1.gz', which is also in package gdc 0:4.1.2-42
Processing triggers for man-db ...
W: cowdancer: unsupported operation flock, read-only open and fchown/fchmod/flock are not supported: tried openning dev:inode of 2055:5406756
W: cowdancer: unsupported operation flock, read-only open and fchown/fchmod/flock are not supported: tried openning dev:inode of 2055:5407760
W: cowdancer: unsupported operation flock, read-only open and fchown/fchmod/flock are not supported: tried openning dev:inode of 2055:5406730
Errors were encountered while processing:
/var/cache/apt/archives/gdc-4.3_2.015-4.3.4-1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)


This is a serious bug as it makes installation fail, and violates
sections 7.6.1 and 10.1 of the policy. An optimal solution would
consist in only one of the packages installing that file, and renaming
or removing the file in the other package. Depending on the
circumstances you might also consider Replace relations or file
diversions. If the conflicting situation cannot be resolved then, as a
last resort, the two packages have to declare a mutual
Conflict. Please take into account that Replaces, Conflicts and
diversions should only be used when packages provide different
implementations for the same functionality.

Here is a list of files that are known to be shared by both packages
(according to the Contents file for sid/amd64, which may be
slightly out of sync):

/usr/bin/gdc
/usr/bin/gdmd
/usr/bin/x86_64-linux-gnu-gdc
/usr/bin/x86_64-linux-gnu-gdmd
/usr/share/man/man1/gdc.1.gz
/usr/share/man/man1/gdmd.1.gz

This bug is assigned to both packages. If you, the maintainers of
the two packages in question, have agreed on which of the packages will
resolve the problem please reassign the bug to that package.

-Ralf.

PS: for more information about the detection of file overwrite errors
of this kind see http://edos.debian.net/file-overwrites/.



--
To UNSUBSCRIBE, email to debian-gcc-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: E1Npown-0005WM-KG@seneca.free.fr">http://lists.debian.org/E1Npown-0005WM-KG@seneca.free.fr


All times are GMT. The time now is 03:55 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.