Linux Archive

Linux Archive (http://www.linux-archive.org/)
-   Debian GCC (http://www.linux-archive.org/debian-gcc/)
-   -   Bug#512473: gcj-4.3: Uses StringBuilder in 1.4 mode (http://www.linux-archive.org/debian-gcc/231474-bug-512473-gcj-4-3-uses-stringbuilder-1-4-mode.html)

"Adrian Lang" 01-21-2009 12:42 AM

Bug#512473: gcj-4.3: Uses StringBuilder in 1.4 mode
 
Package: gcj-4.3
Version: 4.3.2-2
Severity: normal

Consider the following class:
----
public class Testclass {
public void testfunc() {
int i = 5;
new String("i is " + i);
}
}
----

now compile with
----
gcj -fsource=1.4 -C Testclass.java
----

----
$ grep StringBuilder *
Binary file Testclass.class matches
----

As you may see, java.lang.StringBuilder is used in this classfile.
However, Java 2 Platform SE v1.4 has no such class.
(http://java.sun.com/j2se/1.4.2/docs/api/java/lang/package-summary.html)

A class compiled for 1.4 should use java.lang.StringBuffer instead.

-- System Information:
Debian Release: 5.0
APT prefers testing
APT policy: (500, 'testing')
Architecture: i386 (i686)

Kernel: Linux 2.6.26-1-486
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash

Versions of packages gcj-4.3 depends on:
ii gcc-4.3 4.3.2-1.1 The GNU C compiler
ii gcj-4.3-base 4.3.2-2 The GNU Compiler Collection (gcj b
ii gij-4.3 4.3.2-2 The GNU Java bytecode interpreter
ii java-common 0.30 Base of all Java packages
ii libc6 2.7-18 GNU C Library: Shared libraries
ii libc6-dev 2.7-18 GNU C Library: Development Librari
ii libecj-java 3.3.0+0728-9 Eclipse Java compiler (library)
ii libgcc1 1:4.3.2-1.1 GCC support library
ii libgcj-bc 4.3.2-2 Link time only library for use wit
ii libgcj9-0 4.3.2-2 Java runtime library for use with
ii libgcj9-dev 4.3.2-2 Java development headers for use w
ii libgcj9-jar 4.3.2-2 Java runtime library for use with
ii libgmp3c2 2:4.2.2+dfsg-3 Multiprecision arithmetic library
ii libmpfr1ldbl 2.3.1.dfsg.1-2 multiple precision floating-point
ii zlib1g 1:1.2.3.3.dfsg-12 compression library - runtime

Versions of packages gcj-4.3 recommends:
ii fastjar 2:0.95-4 Jar creation utility
ii libecj-java-gcj 3.3.0+0728-9 Eclipse Java compiler (native libr

Versions of packages gcj-4.3 suggests:
pn java-gcj-compat-dev <none> (no description available)
pn libgcj9-dbg <none> (no description available)

-- no debconf information




--
To UNSUBSCRIBE, email to debian-gcc-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org


All times are GMT. The time now is 04:17 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.