Linux Archive

Linux Archive (http://www.linux-archive.org/)
-   Debian dpkg (http://www.linux-archive.org/debian-dpkg/)
-   -   Important information regarding upcoming dpkg 1.16.2 upload (http://www.linux-archive.org/debian-dpkg/644453-important-information-regarding-upcoming-dpkg-1-16-2-upload.html)

Raphael Hertzog 03-14-2012 09:33 AM

Important information regarding upcoming dpkg 1.16.2 upload
 
On Wed, 14 Mar 2012, Raphael Hertzog wrote:
> If it outputs nothing on your system, then you're fine. Otherwise
> it should give you some instructions to follow to bring it back to a
> coherent state.

There was a bug in the script. An updated version is attached.

Note that it will list your foreign packages (on INFO: lines)
but if it outputs nothing else then you're fine. It will print
lines starting with "PROBLEM: " if it detects something wrong.

Cheers,
--
Raphaël Hertzog ◈ Debian Developer

Pre-order a copy of the Debian Administrator's Handbook and help
liberate it: http://debian-handbook.info/liberation/

Raphael Hertzog 03-14-2012 09:33 AM

Important information regarding upcoming dpkg 1.16.2 upload
 
On Wed, 14 Mar 2012, Raphael Hertzog wrote:
> If it outputs nothing on your system, then you're fine. Otherwise
> it should give you some instructions to follow to bring it back to a
> coherent state.

There was a bug in the script. An updated version is attached.

Note that it will list your foreign packages (on INFO: lines)
but if it outputs nothing else then you're fine. It will print
lines starting with "PROBLEM: " if it detects something wrong.

Cheers,
--
Raphaël Hertzog ◈ Debian Developer

Pre-order a copy of the Debian Administrator's Handbook and help
liberate it: http://debian-handbook.info/liberation/

David Greaves 03-14-2012 11:42 AM

Important information regarding upcoming dpkg 1.16.2 upload
 
Hi

I got the following results:

root@ash:~# dpkg --version
Debian `dpkg' package management program version 1.16.1.2 (amd64).

root@ash:~# perl ~david/tmp/dpkg-chk.pl | tail
PROBLEM: gcc-4.4-base:amd64 has missing info files
SOLUTION: apt-get --reinstall install gcc-4.4-base:amd64
PROBLEM: libpwl5:amd64 has missing info files
SOLUTION: apt-get --reinstall install libpwl5:amd64
PROBLEM: libwrap0:amd64 has missing info files
SOLUTION: apt-get --reinstall install libwrap0:amd64
PROBLEM: liblockfile1:amd64 has missing info files
SOLUTION: apt-get --reinstall install liblockfile1:amd64
PROBLEM: libxau6:amd64 has missing info files
SOLUTION: apt-get --reinstall install libxau6:amd64

root@ash:~# apt-get --reinstall install libxau6:amd64
Reading package lists... Done
Building dependency tree
Reading state information... Done
0 upgraded, 0 newly installed, 1 reinstalled, 0 to remove and 1114 not upgraded.
Need to get 0 B/17.1 kB of archives.
After this operation, 0 B of additional disk space will be used.
(Reading database ... 199685 files and directories currently installed.)
Preparing to replace libxau6 1:1.0.6-4 (using .../libxau6_1%3a1.0.6-4_amd64.deb) ...
Unpacking replacement libxau6 ...
Setting up libxau6 (1:1.0.6-4) ...

root@ash:~# perl ~david/tmp/dpkg-chk.pl | tail
PROBLEM: gcc-4.4-base:amd64 has missing info files
SOLUTION: apt-get --reinstall install gcc-4.4-base:amd64
PROBLEM: libpwl5:amd64 has missing info files
SOLUTION: apt-get --reinstall install libpwl5:amd64
PROBLEM: libwrap0:amd64 has missing info files
SOLUTION: apt-get --reinstall install libwrap0:amd64
PROBLEM: liblockfile1:amd64 has missing info files
SOLUTION: apt-get --reinstall install liblockfile1:amd64
PROBLEM: libxau6:amd64 has missing info files
SOLUTION: apt-get --reinstall install libxau6:amd64

David

--
"Don't worry, you'll be fine; I saw it work in a cartoon once..."


--
To UNSUBSCRIBE, email to debian-devel-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 4F609226.7030504@dgreaves.com">http://lists.debian.org/4F609226.7030504@dgreaves.com

Raphael Hertzog 03-14-2012 12:46 PM

Important information regarding upcoming dpkg 1.16.2 upload
 
On Wed, 14 Mar 2012, David Greaves wrote:
> I got the following results:
>
> root@ash:~# dpkg --version
> Debian `dpkg' package management program version 1.16.1.2 (amd64).

The script is meant for people who are using a version of dpkg with
multiarch support. You're using the current sid version which doesn't have
multiarch support yet.

So the script doesn't apply and the warnings are bogus. You have nothing
to worry about.

Cheers,
--
Raphaël Hertzog ◈ Debian Developer

Pre-order a copy of the Debian Administrator's Handbook and help
liberate it: http://debian-handbook.info/liberation/


--
To UNSUBSCRIBE, email to debian-devel-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 20120314134640.GB18410@rivendell.home.ouaza.com">h ttp://lists.debian.org/20120314134640.GB18410@rivendell.home.ouaza.com


All times are GMT. The time now is 11:15 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.