FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Debian > Debian dpkg

 
 
LinkBack Thread Tools
 
Old 08-25-2011, 09:19 AM
Rene Engelhard
 
Default Bug#639229: libreoffice-base: package not installable, dpkg fails to unpack

Hi,

On Thu, Aug 25, 2011 at 08:50:03AM +0200, Matthias Cramer wrote:
> When upgrading to the newest package, dpkg fails to unpack the .deb file:
>
> Preparing to replace libreoffice-base 1:3.3.4-1 (using .../libreoffice-
> base_1%3a3.3.4-2_amd64.deb) ...
> Unpacking replacement libreoffice-base ...
> dpkg: ../../src/archives.c:824: tarobject: Assertion `r == stab.st_size'
> failed.
> E: Sub-process /usr/bin/dpkg exited unexpectedly

If at all, this is a dpkg bug. What makes you think it's alibreoffice bug?
It got properly packed by dpkg-deb as anything else.

Grüße/Regards,

René
--
.'`. René Engelhard -- Debian GNU/Linux Developer
: :' : http://www.debian.org | http://people.debian.org/~rene/
`. `' rene@debian.org | GnuPG-Key ID: D03E3E70
`- Fingerprint: E12D EA46 7506 70CF A960 801D 0AA0 4571 D03E 3E70


--
To UNSUBSCRIBE, email to debian-dpkg-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 20110825091927.GC22163@rene-engelhard.de">http://lists.debian.org/20110825091927.GC22163@rene-engelhard.de
 
Old 08-25-2011, 09:28 AM
Rene Engelhard
 
Default Bug#639229: libreoffice-base: package not installable, dpkg fails to unpack

tag 639229 + moreinfo
tag 639229 + unreproducible
thanks

On Thu, Aug 25, 2011 at 11:19:27AM +0200, Rene Engelhard wrote:
> On Thu, Aug 25, 2011 at 08:50:03AM +0200, Matthias Cramer wrote:
> > When upgrading to the newest package, dpkg fails to unpack the .deb file:
> >
> > Preparing to replace libreoffice-base 1:3.3.4-1 (using .../libreoffice-
> > base_1%3a3.3.4-2_amd64.deb) ...
> > Unpacking replacement libreoffice-base ...
> > dpkg: ../../src/archives.c:824: tarobject: Assertion `r == stab.st_size'
> > failed.
> > E: Sub-process /usr/bin/dpkg exited unexpectedly
>
> If at all, this is a dpkg bug. What makes you think it's alibreoffice bug?
> It got properly packed by dpkg-deb as anything else.

And:

$ sudo dpkg -i --force-depends --root=/home/rene/pbuilder/build/11214 libreoffice-base_3.3.4-2_amd64.deb
Selecting previously deselected package libreoffice-base.
(Reading database ... 14579 files and directories currently installed.)
Unpacking libreoffice-base (from libreoffice-base_3.3.4-2_amd64.deb) ...
dpkg: libreoffice-base: dependency problems, but configuring anyway as you requested:
libreoffice-base depends on libreoffice-core (= 1:3.3.4-2); however:
Package libreoffice-core is not installed.
libreoffice-base depends on libreoffice-base-core (= 1:3.3.4-2); however:
Package libreoffice-base-core is not installed.
libreoffice-base depends on ure (>= 1.7.0+LibO3.3.0~beta3); however:
Package ure is not installed.
libreoffice-base depends on default-jre | gcj-jre | java-gcj-compat | openjdk-6-jre | sun-java5-jre | sun-java6-jre | java5-runtime | jre; however:
Package default-jre is not installed.
Package gcj-jre is not installed.
Package java-gcj-compat is not installed.
Package openjdk-6-jre is not installed.
Package sun-java5-jre is not installed.
Package sun-java6-jre is not installed.
Package java5-runtime is not installed.
Package jre is not installed.
libreoffice-base depends on libhsqldb-java (>> 1.8.0.10); however:
Package libhsqldb-java is not installed.
libreoffice-base depends on libhsqldb-java (<< 1.8.1~); however:
Package libhsqldb-java is not installed.
libreoffice-base depends on libreoffice-java-common (>= 1:3.3.4~); however:
Package libreoffice-java-common is not installed.
Setting up libreoffice-base (1:3.3.4-2) ...

unpacks fine. Are you sure the .deb didn't get corrupted on your hd
or so?

Grüße/Regards,

René


--
To UNSUBSCRIBE, email to debian-dpkg-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 20110825092847.GE22163@rene-engelhard.de">http://lists.debian.org/20110825092847.GE22163@rene-engelhard.de
 
Old 08-25-2011, 09:39 AM
Matthias Cramer
 
Default Bug#639229: libreoffice-base: package not installable, dpkg fails to unpack

Hi Rene

Deleted the file on the disk twice and let apt-get re download it. Same
issue. I was thinking probably the package on the ftp server is broken.
Other packages install fine...

Can you send me an MD5 sum of your package to verify or is this a stupid
idea because they are signed anyway ?

Regards

Matthias

On 08/25/11 11:28, Rene Engelhard wrote:
> tag 639229 + moreinfo
> tag 639229 + unreproducible
> thanks
>
> On Thu, Aug 25, 2011 at 11:19:27AM +0200, Rene Engelhard wrote:
>> On Thu, Aug 25, 2011 at 08:50:03AM +0200, Matthias Cramer wrote:
>>> When upgrading to the newest package, dpkg fails to unpack the .deb file:
>>>
>>> Preparing to replace libreoffice-base 1:3.3.4-1 (using .../libreoffice-
>>> base_1%3a3.3.4-2_amd64.deb) ...
>>> Unpacking replacement libreoffice-base ...
>>> dpkg: ../../src/archives.c:824: tarobject: Assertion `r == stab.st_size'
>>> failed.
>>> E: Sub-process /usr/bin/dpkg exited unexpectedly
>>
>> If at all, this is a dpkg bug. What makes you think it's alibreoffice bug?
>> It got properly packed by dpkg-deb as anything else.
>
> And:
>
> $ sudo dpkg -i --force-depends --root=/home/rene/pbuilder/build/11214 libreoffice-base_3.3.4-2_amd64.deb
> Selecting previously deselected package libreoffice-base.
> (Reading database ... 14579 files and directories currently installed.)
> Unpacking libreoffice-base (from libreoffice-base_3.3.4-2_amd64.deb) ...
> dpkg: libreoffice-base: dependency problems, but configuring anyway as you requested:
> libreoffice-base depends on libreoffice-core (= 1:3.3.4-2); however:
> Package libreoffice-core is not installed.
> libreoffice-base depends on libreoffice-base-core (= 1:3.3.4-2); however:
> Package libreoffice-base-core is not installed.
> libreoffice-base depends on ure (>= 1.7.0+LibO3.3.0~beta3); however:
> Package ure is not installed.
> libreoffice-base depends on default-jre | gcj-jre | java-gcj-compat | openjdk-6-jre | sun-java5-jre | sun-java6-jre | java5-runtime | jre; however:
> Package default-jre is not installed.
> Package gcj-jre is not installed.
> Package java-gcj-compat is not installed.
> Package openjdk-6-jre is not installed.
> Package sun-java5-jre is not installed.
> Package sun-java6-jre is not installed.
> Package java5-runtime is not installed.
> Package jre is not installed.
> libreoffice-base depends on libhsqldb-java (>> 1.8.0.10); however:
> Package libhsqldb-java is not installed.
> libreoffice-base depends on libhsqldb-java (<< 1.8.1~); however:
> Package libhsqldb-java is not installed.
> libreoffice-base depends on libreoffice-java-common (>= 1:3.3.4~); however:
> Package libreoffice-java-common is not installed.
> Setting up libreoffice-base (1:3.3.4-2) ...
>
> unpacks fine. Are you sure the .deb didn't get corrupted on your hd
> or so?
>
> Grüße/Regards,
>
> René


--
Matthias Cramer / mc322-ripe Senior Network & Security Engineer
iway AG Phone +41 43 500 1111
Badenerstrasse 569 Fax +41 44 271 3535
CH-8048 Zürich http://www.iway.ch/
GnuPG 1024D/2D208250 = DBC6 65B6 7083 1029 781E 3959 B62F DF1C 2D20 8250
 
Old 08-25-2011, 10:00 AM
Rene Engelhard
 
Default Bug#639229: libreoffice-base: package not installable, dpkg fails to unpack

On Thu, Aug 25, 2011 at 11:39:18AM +0200, Matthias Cramer wrote:
> Can you send me an MD5 sum of your package to verify or is this a stupid

I can: 24feffaed8597b1c5f8f47d0fb81456a libreoffice-base_3.3.4-2_amd64.deb
(which unsurprinsingly is the same with the file i get freshly from the ftp)

> idea because they are signed anyway ?

Well, the md5sum (and sha*sums) end up in the changes and that ends
up in the archive Release file, which is signed (and which then contains
the md5sums of the Packages file which again
contain the md5sums)

So yes, if the md5sum changed you should have been told...

Grüße/Regards,

René


--
To UNSUBSCRIBE, email to debian-dpkg-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 20110825100033.GF22163@rene-engelhard.de">http://lists.debian.org/20110825100033.GF22163@rene-engelhard.de
 

Thread Tools




All times are GMT. The time now is 10:17 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright ©2007 - 2008, www.linux-archive.org