Linux Archive

Linux Archive (http://www.linux-archive.org/)
-   Debian dpkg (http://www.linux-archive.org/debian-dpkg/)
-   -   Bug#603068: tex-common,texlive-binaries: can't be installed together (http://www.linux-archive.org/debian-dpkg/451323-bug-603068-tex-common-texlive-binaries-cant-installed-together.html)

Raphael Hertzog 11-11-2010 08:01 PM

Bug#603068: tex-common,texlive-binaries: can't be installed together
 
Hi,

On Thu, 11 Nov 2010, Norbert Preining wrote:
> Currently, when I call
> dpkg-query -W -f='${Status}' texlive-base
> it returns 1 (error) if texlive-base is not installed (or going to
> be installed).
>
> This breaks installation of tex-common with texlive-binaries, but without
> texlive-base.
>
> As far as I remember in former times this was working, so is this a
> recent change, and was it intended, or is this a coding error from
> our side.

It's not a recent change AFAIK, but nowadays dpkg is removing
entries of purged packages from the status file so maybe it's more
likely to happen than before due to this.

We recently documented that behaviour in dpkg-query however.

EXIT STATUS
0 The requested query was successfully performed.

1 Problems were encountered while parsing the command line or
performing the query, including no file or package being found
(except for --control-path).

> In principle what we are doing the in the tex-common trigger action
> is to check whether texlive-base is installed, and if it is we run
> some commands.

You should consider an error like an indication that the package
is not installed.

Cheers,
--
Raphaël Hertzog ◈ Debian Developer ◈ [Flattr=20693]

Follow my Debian News ▶ http://RaphaelHertzog.com (English)
▶ http://RaphaelHertzog.fr (Français)


--
To UNSUBSCRIBE, email to debian-dpkg-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 20101111210127.GA17824@rivendell.home.ouaza.com">h ttp://lists.debian.org/20101111210127.GA17824@rivendell.home.ouaza.com

Holger Levsen 11-12-2010 12:40 PM

Bug#603068: tex-common,texlive-binaries: can't be installed together
 
Hi,

On Freitag, 12. November 2010, Norbert Preining wrote:
> Sorry dpkg guys for involving you into that.
>
> I have seen the bug report, checked the code, missed the || true I had
> already added, and only afterwards realized the the bug report
> was done with an ancient version of tex-common - which I also missed.

I'm very sorry too, what else can I say. Running piuparts constantly against
the archive results in me see so many errors that sometimes I dont check
carefully enough, whether a reported problem still exists or if it is/was a
problem at all.

piuparts.d.o consists of 90k test logs, eg squeeze has an impressive number of
27526 successfully tests and only 108 failed ones - but then there are also
570 in other states...

And it's mostly only me trying to digg through all of this, deal with all
those bugs in our amazing package universe and those in piuparts, that I
sometimes make mistakes.

So once again, sorry for wasting your time and thanks for making Debian even
better!


cheers,
Holger

P.S.: about the problem at hand: piuparts.d.o regulary tests new versions of
packages, but doesnt detect, if new depends are available. This is obviously
fixable, but so are tons of things in piuparts...


All times are GMT. The time now is 06:05 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.