FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Debian > Debian Development

 
 
LinkBack Thread Tools
 
Old 09-17-2012, 03:47 PM
Karsten Merker
 
Default Radeon KMS without non-free firmware (was: Towards d-i wheezy beta 3)

On Tue, Sep 11, 2012 at 06:39:17AM +0100, Ben Hutchings wrote:
> On Mon, 2012-09-10 at 21:10 +0200, Philipp Kern wrote:

> > If we do that the same should also happen for firmware-linux-nonfree. Loading
> > the radeon KMS module without firmware available results in an unusable
> > (text) console. (Yes, it might be considered a bug that radeon is loadable
> > without.)
>
> Upstream has said repeatedly that radeon is supposed to fall-back and
> work without the microcode, and the driver certainly attempts to do
> that. With the older chips this seems to result in 3D acceleration
> being unavailable, but I agree that the fallback is broken for newer
> chips.
>
> I don't have any expectation of being able to fix the fallback, so any
> fix would result in aborting the driver probe if firmware files are not
> available. But I also don't want to push users to install from non-free
> if it's avoidable, so I want to get a clear picture of which chips this
> needs to be done for.

I have looked through various bug reports and I have done some
local testing to get an overview of which radeon families pose
this problem. If everybody on this list who has radeon cards
with chips which are not yet listed could follow up with their
experience, we might be able to build a reasonable overview of
the problematic chip models. Please follow up on debian-devel to
avoid cluttering multiple lists.

The results so far:

Systems working without firmware:
=================================

* RV710 (Radeon HD 4350), requested firmware file: radeon/RV710_pfp.bin
(local test)

* RV505 (Radeon X1550), requested firmware file: radeon/RS520_cp.bin
(local test)


Systems _not_ working without firmware:
=======================================

* Wrestler (Radeon HD 6310), part of the AMD E-350 APU
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=642389#5
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=642389#20

* RV620 (Radeon HD3450), requested firmware file: radeon/RV620_pfp.bin
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=642389#25


Systems probably not working without firmware
=============================================
(The bug reports hint that missing firmware might be the problem, but
this cannot be surely determined with the available information.)

* RV620 (Mobility Radeon HD 3400)
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=673548

* Caicos (Radeon HD 6470M)
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=642389#10


Regards,
Karsten
--
Gem. Par. 28 Abs. 4 Bundesdatenschutzgesetz widerspreche ich der Nutzung
sowie der Weitergabe meiner personenbezogenen Daten für Zwecke der
Werbung sowie der Markt- oder Meinungsforschung.


--
To UNSUBSCRIBE, email to debian-devel-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 20120917154726.GA6477@excalibur.cnev.de">http://lists.debian.org/20120917154726.GA6477@excalibur.cnev.de
 

Thread Tools




All times are GMT. The time now is 07:37 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright ©2007 - 2008, www.linux-archive.org