FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Debian > Debian Development

 
 
LinkBack Thread Tools
 
Old 09-13-2012, 01:07 PM
Ivan Shmakov
 
Default versioned dependency on the libhdf5-7 virtual package

This issue was already discussed [1], and I've filed the
respective bug report [2] (to which there was no reply so far,
though), but now I see that there's a few more packages in
Wheezy with a dependency on libhdf5-7. Consider, e. g.:

$ bzcat
< http.debian.net/debian/dists/wheezy/main/binary-amd64/Packages.bz2
| gawk '/^Package: / { pkg = $2; } /Version: / { vers = $2; }
/ libhdf5-7 (/ { printf("%-23s %s
", pkg, vers); }'
libhe5-hdfeos0 5.1.13.dfsg.1-3
libhdf5-7-dbg 1.8.8-9
libhdf5-dev 1.8.8-9
cgns-convert 3.1.3.4-1
libnexus0 4.2.1-svn1614-1+b1
libnexus0-java 4.2.1-svn1614-1+b1
nexus-tools 4.2.1-svn1614-1+b1
r-cran-hdf5 1.6.10-1
tessa 0.3.1-6
tessa-mpi 0.3.1-6
udav 0.7.1.2-3
$

Any chance this issue will be rectified? (Or should I file bug
reports against these packages?)

TIA.

[1] news:udlvci28as8.fsf@dr-wily.mit.edu
http://permalink.gmane.org/gmane.linux.debian.science/5353
[2] http://bugs.debian.org/680400

--
FSF associate member #7257 http://sfd.am-1.org/


--
To UNSUBSCRIBE, email to debian-devel-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 86a9wu9iky.fsf@gray.siamics.net">http://lists.debian.org/86a9wu9iky.fsf@gray.siamics.net
 
Old 09-14-2012, 10:48 AM
Alastair McKinstry
 
Default versioned dependency on the libhdf5-7 virtual package

For libhe5-hdfeos0, i'm working on this.

One thing I need to check is HDF5 dependencies. he5-hdfeos0 was built
and tested
against HDF5 1.8.7. Since then HDF5 has a new version 1.8.8 with some
significant
changes; a new HDFEOS5 upstream was released to use it (5.1.14).
HDF5 1.8.8 is in Debian. I need to confirm the old HDFEOS5 works with
the new HDF5,
if not i'll have to bump to the latest HDFEOS5 upstream (which I don't
want to do
unnecessarly in wheezy, because of the freeze).

So, the plan is to:
* rebuild hee5-hdfeos50 against hdf5 1.8.8 and fix the dependencies as
described.
If this works, fine.
* If not, build the new he5-hdfeos0 and ask the release admins nicely.

regards
Alastair


On 2012-09-13 14:07, Ivan Shmakov wrote:
> This issue was already discussed [1], and I've filed the
> respective bug report [2] (to which there was no reply so far,
> though), but now I see that there's a few more packages in
> Wheezy with a dependency on libhdf5-7. Consider, e. g.:
>
> $ bzcat
> < http.debian.net/debian/dists/wheezy/main/binary-amd64/Packages.bz2
> | gawk '/^Package: / { pkg = $2; } /Version: / { vers = $2; }
> / libhdf5-7 (/ { printf("%-23s %s
", pkg, vers); }'
> libhe5-hdfeos0 5.1.13.dfsg.1-3
> libhdf5-7-dbg 1.8.8-9
> libhdf5-dev 1.8.8-9
> cgns-convert 3.1.3.4-1
> libnexus0 4.2.1-svn1614-1+b1
> libnexus0-java 4.2.1-svn1614-1+b1
> nexus-tools 4.2.1-svn1614-1+b1
> r-cran-hdf5 1.6.10-1
> tessa 0.3.1-6
> tessa-mpi 0.3.1-6
> udav 0.7.1.2-3
> $
>
> Any chance this issue will be rectified? (Or should I file bug
> reports against these packages?)
>
> TIA.
>
> [1] news:udlvci28as8.fsf@dr-wily.mit.edu
> http://permalink.gmane.org/gmane.linux.debian.science/5353
> [2] http://bugs.debian.org/680400
>


--
Alastair McKinstry , Computational Scientist <alastair.mckinstry@ichec.ie>
ICHEC, Room 301, IT Building NUI Galway, Galway , Ireland
tel: +353 91 495946


--
To UNSUBSCRIBE, email to debian-devel-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 50530B92.4000801@ichec.ie">http://lists.debian.org/50530B92.4000801@ichec.ie
 
Old 09-15-2012, 11:39 AM
Salvatore Bonaccorso
 
Default versioned dependency on the libhdf5-7 virtual package

Hi Ivan

On Thu, Sep 13, 2012 at 08:07:57PM +0700, Ivan Shmakov wrote:
> This issue was already discussed [1], and I've filed the
> respective bug report [2] (to which there was no reply so far,
> though), but now I see that there's a few more packages in
> Wheezy with a dependency on libhdf5-7. Consider, e. g.:
>
> $ bzcat
> < http.debian.net/debian/dists/wheezy/main/binary-amd64/Packages.bz2
> | gawk '/^Package: / { pkg = $2; } /Version: / { vers = $2; }
> / libhdf5-7 (/ { printf("%-23s %s
", pkg, vers); }'
> libhe5-hdfeos0 5.1.13.dfsg.1-3
> libhdf5-7-dbg 1.8.8-9
> libhdf5-dev 1.8.8-9
> cgns-convert 3.1.3.4-1
> libnexus0 4.2.1-svn1614-1+b1
> libnexus0-java 4.2.1-svn1614-1+b1
> nexus-tools 4.2.1-svn1614-1+b1
> r-cran-hdf5 1.6.10-1
> tessa 0.3.1-6
> tessa-mpi 0.3.1-6
> udav 0.7.1.2-3
> $
>
> Any chance this issue will be rectified? (Or should I file bug
> reports against these packages?)
>
> TIA.
>
> [1] news:udlvci28as8.fsf@dr-wily.mit.edu
> http://permalink.gmane.org/gmane.linux.debian.science/5353
> [2] http://bugs.debian.org/680400

At least for udav it should be enough to schedule binNMU:

Control files: lines which differ (wdiff format)
------------------------------------------------
Depends: libc6 (>= 2.2.5), libgcc1 (>= 1:4.1.1), [-libhdf5-7 (>= 1.8.7),-] {+libhdf5-7,+} libmgl5 (>= 1.11), libqtcore4 (>= 4:4.7.0~beta1), libqtgui4 (>= 4:4.5.3), libstdc++6 (>= 4.1.1)
Installed-Size: [-791-] {+758+}

Regards,
Salvatore
 

Thread Tools




All times are GMT. The time now is 06:44 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org