FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Debian > Debian Development

 
 
LinkBack Thread Tools
 
Old 12-02-2011, 09:04 AM
Björn Esser
 
Default The --before option is deprecated. Use override targets instead.

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

Hello there!

When I'm building a package using

dh build --before configure
dh_testdir
dh_auto_configure -- --some-options-to-pass

I get a warning --> dh: The --before option is deprecated. Use
override targets instead.

How do I use/create those overrides?

Thanks to all in advance.

BR,

Björn Esser
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.18 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/

iF4EAREIAAYFAk7YoqgACgkQ3u1SIc8s7PXfwQD/fbSFwAayBwrv2/H7hGOWX4AA
pvrK2BUpZYbm1x3cacgBAKa1CBR7Ne0jXMj2nAKbcydK3TovWL zRrI2JaKuSlpd0
=wTp1
-----END PGP SIGNATURE-----


--
To UNSUBSCRIBE, email to debian-devel-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 4ED8A2A9.7040809@googlemail.com">http://lists.debian.org/4ED8A2A9.7040809@googlemail.com
 
Old 12-02-2011, 09:11 AM
Paul Wise
 
Default The --before option is deprecated. Use override targets instead.

2011/12/2 Björn Esser <bjoern.esser@googlemail.com>:

> How do I use/create those overrides?

This is documented in the manual page for dh.

--
bye,
pabs

http://wiki.debian.org/PaulWise


--
To UNSUBSCRIBE, email to debian-devel-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: CAKTje6FyEF3rSFepSegwyhTQ62YbD2sG+Niz97yRwBBXpWjUs w@mail.gmail.com">http://lists.debian.org/CAKTje6FyEF3rSFepSegwyhTQ62YbD2sG+Niz97yRwBBXpWjUs w@mail.gmail.com
 
Old 12-02-2011, 09:12 AM
Heiko Schlittermann
 
Default The --before option is deprecated. Use override targets instead.

Björn Esser <bjoern.esser@googlemail.com> (Fr 02 Dez 2011 11:04:25 CET):
> dh build --before configure
> dh_testdir
> dh_auto_configure -- --some-options-to-pass
>
> I get a warning --> dh: The --before option is deprecated. Use
> override targets instead.
>
> How do I use/create those overrides?

You're looking for dh(1)?

--
Heiko :: dresden : linux : SCHLITTERMANN.de
GPG Key 48D0359B : 3061 CFBF 2D88 F034 E8D2 7E92 EE4E AC98 48D0 359B
 

Thread Tools




All times are GMT. The time now is 07:17 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright ©2007 - 2008, www.linux-archive.org