FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Debian > Debian Development

 
 
LinkBack Thread Tools
 
Old 11-15-2011, 05:15 PM
Jonathan McCrohan
 
Default libconfig9 for Wheezy?

Hi,

libconfig [1] has not been updated since Squeeze, and is lagging
upstream by a major version.

Packaging the upstream release is not a problem, but an ABI change will
require a transition from libconfig8 to libconfig9.

The maintainer is aware of the problem, and this has been tracked as
wishlist bug #583528 since May 2010 [2].

Is there enough time left to have this updated before the Wheezy freeze
window?

Thanks,
Jon

[1] http://packages.qa.debian.org/libc/libconfig.html
[2] http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=583528


--
To UNSUBSCRIBE, email to debian-devel-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 4EC2AC54.2070600@gmail.com">http://lists.debian.org/4EC2AC54.2070600@gmail.com
 
Old 11-15-2011, 05:29 PM
Ben Hutchings
 
Default libconfig9 for Wheezy?

On Tue, Nov 15, 2011 at 06:15:48PM +0000, Jonathan McCrohan wrote:
> Hi,
>
> libconfig [1] has not been updated since Squeeze, and is lagging
> upstream by a major version.
>
> Packaging the upstream release is not a problem, but an ABI change will
> require a transition from libconfig8 to libconfig9.
>
> The maintainer is aware of the problem, and this has been tracked as
> wishlist bug #583528 since May 2010 [2].
>
> Is there enough time left to have this updated before the Wheezy freeze
> window?

Very likely, but release questions should be sent to debian-release.

Ben.

--
Ben Hutchings
We get into the habit of living before acquiring the habit of thinking.
- Albert Camus


--
To UNSUBSCRIBE, email to debian-devel-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 20111115182919.GB3366@decadent.org.uk">http://lists.debian.org/20111115182919.GB3366@decadent.org.uk
 
Old 11-15-2011, 10:20 PM
Jose Luis Tallón
 
Default libconfig9 for Wheezy?

El 15/11/11 19:29, Ben Hutchings escribió:

On Tue, Nov 15, 2011 at 06:15:48PM +0000, Jonathan McCrohan wrote:

Hi,

libconfig [1] has not been updated since Squeeze, and is lagging
upstream by a major version.

Packaging the upstream release is not a problem, but an ABI change will
require a transition from libconfig8 to libconfig9.

The maintainer is aware of the problem, and this has been tracked as
wishlist bug #583528 since May 2010 [2].

Any sponsor / uploader welcome.
It isn't updated because nobody agreed to upload it, and I gave up
eventually.




Is there enough time left to have this updated before the Wheezy freeze
window?


Very likely, but release questions should be sent to debian-release.

Yup.

/ J.L.


--
To UNSUBSCRIBE, email to debian-devel-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 4EC2F3B0.8020106@adv-solutions.net">http://lists.debian.org/4EC2F3B0.8020106@adv-solutions.net
 
Old 11-16-2011, 04:32 AM
Reinhard Tartler
 
Default libconfig9 for Wheezy?

CC'ing mentors, as this issue seems to be blocked by a missing sponsor.

On Mi, Nov 16, 2011 at 00:20:16 (CET), Jose Luis Tallón wrote:

> El 15/11/11 19:29, Ben Hutchings escribió:
>> On Tue, Nov 15, 2011 at 06:15:48PM +0000, Jonathan McCrohan wrote:
>>> Hi,
>>>
>>> libconfig [1] has not been updated since Squeeze, and is lagging
>>> upstream by a major version.
>>>
>>> Packaging the upstream release is not a problem, but an ABI change will
>>> require a transition from libconfig8 to libconfig9.
>>>
>>> The maintainer is aware of the problem, and this has been tracked as
>>> wishlist bug #583528 since May 2010 [2].
> Any sponsor / uploader welcome.
> It isn't updated because nobody agreed to upload it, and I gave up

I don't see the new version of the package on mentors. Please consider
uploading your new package there, it will then show up on
http://packages.qa.debian.org/libc/libconfig.html in the 'todo' box
AFAIUI.

Moreover, as this upload requires a transition, you'll need to
coordinate with the release team. These days, such transitions are
tracked in form of bugs against the 'release.debian.org' pseudo package:

http://bugs.debian.org/cgi-bin/pkgreport.cgi?pkg=release.debian.org;dist=unstable #_0_6_4

HTH,
Reinhard

--
Gruesse/greetings,
Reinhard Tartler, KeyID 945348A4


--
To UNSUBSCRIBE, email to debian-devel-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 878vngljid.fsf@faui43f.informatik.uni-erlangen.de">http://lists.debian.org/878vngljid.fsf@faui43f.informatik.uni-erlangen.de
 
Old 11-28-2011, 11:41 AM
Andrey Ponomarenko
 
Default libconfig9 for Wheezy?

The compatibility report for libconfig between libconfig8/1.3.2 and
libconfig9/1.4.8 versions (see attachment) generated by the
abi-compliance-checker [1] tool may be of help to upgrade this package.


[1] http://forge.ispras.ru/projects/abi-compliance-checker/files

On 11/15/2011 10:15 PM, Jonathan McCrohan wrote:

Hi,

libconfig [1] has not been updated since Squeeze, and is lagging
upstream by a major version.

Packaging the upstream release is not a problem, but an ABI change will
require a transition from libconfig8 to libconfig9.

The maintainer is aware of the problem, and this has been tracked as
wishlist bug #583528 since May 2010 [2].

Is there enough time left to have this updated before the Wheezy freeze
window?

Thanks,
Jon

[1]http://packages.qa.debian.org/libc/libconfig.html
[2]http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=583528




-- Andrey Ponomarenko
 
Old 12-02-2011, 12:13 AM
Jonathan McCrohan
 
Default libconfig9 for Wheezy?

Hi,

On 28/11/11 12:41, Andrey Ponomarenko wrote:
> The compatibility report for libconfig between libconfig8/1.3.2 and
> libconfig9/1.4.8 versions (see attachment) generated by the
> abi-compliance-checker [1] tool may be of help to upgrade this package.

Thanks. abi-compliance-checker looks very helpful.

On 16/11/11 05:32, Reinhard Tartler wrote:
> I don't see the new version of the package on mentors. Please consider
> uploading your new package there, it will then show up on
> http://packages.qa.debian.org/libc/libconfig.html in the 'todo' box
> AFAIUI.

The maintainer has not replied so I have uploaded an initial version of
libconfig9 to mentors.debian.net [1].

No VCS exists, so this is simply git-import-dsc of libconfig_1.3.2-2,
git-import-orig of libconfig-1.4.8 and resolving the conflicts. I will
work on fixing up the lintian warnings over the weekend.

Regards,
Jon

[1] http://mentors.debian.net/package/libconfig


--
To UNSUBSCRIBE, email to debian-devel-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 4ED8264A.7060907@gmail.com">http://lists.debian.org/4ED8264A.7060907@gmail.com
 

Thread Tools




All times are GMT. The time now is 04:42 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright ©2007 - 2008, www.linux-archive.org