FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Debian > Debian Development

 
 
LinkBack Thread Tools
 
Old 10-19-2011, 12:09 PM
olivier sallou
 
Default Build error form Ubuntu regarding xz compression

Hi,

I received an email error from Ubuntu regarding build of a package (extracted from debian):



Rejected:
Require Pre-Depends: dpkg (>= 1.15.6) when using xz compression.

Require Pre-Depends: dpkg (>= 1.15.6) when using xz compression.
Package indeed uses xz compression, but do you know what I should put in package for this on debian side?


Should I add in debian control a pre-depends on dpkg as said in message?

I think that someone else already the issue...

Thanks

Olivier
--
gpg key id: 4096R/326D8438 (pgp.mit.edu)
Key fingerprint = 5FB4 6F83 D3B9 5204 6335 D26D 78DC 68DB 326D 8438
 
Old 10-19-2011, 12:16 PM
Didier Raboud
 
Default Build error form Ubuntu regarding xz compression

olivier sallou wrote:

> Rejected:
> Require Pre-Depends: dpkg (>= 1.15.6) when using xz compression.
>
> Package indeed uses xz compression, but do you know what I should put
> in package for this on debian side?
>
> Should I add in debian control a pre-depends on dpkg as said in message?

Yes, you should. That's because no dpkg << 1.15.6 [0] is able to uncompress
xz-compressed data.tar members of binary packages, hence the Pre-Depends
(which implies that you have a fully configured dpkg >= 1.15.6 before your
package gets uncompressed).

Now, strictly speaking, this is not formally needed within Debian as our
current stable has a newer dpkg (1.15.8.11), but this cannot hurt.

Cheers,

OdyX

P.S. This would probably have been more suited for debian-mentors.

[0]
http://anonscm.debian.org/gitweb/?p=dpkg/dpkg.git;a=commit;h=9bb208a8338253a1c9e1d0642cf1ef 039a335951


--
To UNSUBSCRIBE, email to debian-devel-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: j7mf2b$rha$1@dough.gmane.org">http://lists.debian.org/j7mf2b$rha$1@dough.gmane.org
 
Old 10-19-2011, 12:50 PM
Colin Watson
 
Default Build error form Ubuntu regarding xz compression

On Wed, Oct 19, 2011 at 02:09:47PM +0200, olivier sallou wrote:
> I received an email error from Ubuntu regarding build of a package
> (extracted from debian):

I'm sorry you received this error; this is a Launchpad bug
(https://bugs.launchpad.net/launchpad/+bug/876594). We obviously don't
want to spam Debian developers with Ubuntu upload errors.

> Rejected:
> Require Pre-Depends: dpkg (>= 1.15.6) when using xz compression.
> Require Pre-Depends: dpkg (>= 1.15.6) when using xz compression.
>
>
> Package indeed uses xz compression, but do you know what I should put
> in package for this on debian side?
>
> Should I add in debian control a pre-depends on dpkg as said in message?

Didier has already answered this. Making such a change is indeed
harmless in Debian.

I would also add that I've been fixing all these in Ubuntu as we go
along (in changes that we'll be able to discard after Ubuntu 12.04 LTS)
on the grounds that it's basically our fault for not having managed to
get dpkg 1.15.6 into our last LTS release and thus we should cope with
the fallout; so while I certainly wouldn't say no if Debian developers
want to add the appropriate Pre-Depends, we'll cope if you don't.

Thanks,

--
Colin Watson [cjwatson@ubuntu.com]


--
To UNSUBSCRIBE, email to debian-devel-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 20111019125056.GA7777@riva.dynamic.greenend.org.uk ">http://lists.debian.org/20111019125056.GA7777@riva.dynamic.greenend.org.uk
 

Thread Tools




All times are GMT. The time now is 04:19 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org