FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Debian > Debian Development

 
 
LinkBack Thread Tools
 
Old 09-29-2011, 04:50 PM
Raphael Hertzog
 
Default dpkg predependency against tar >= 1.23, objections?

Hello,

On Sun, 25 Sep 2011, Guillem Jover wrote:
> > $ sudo apt-get install dpkg-dev
[...]
> > tar: unrecognized option `--warning=no-timestamp'
> > Try `tar --help' or `tar --usage' for more information.
> > dpkg-deb: error: subprocess tar returned error exit status 64
> > dpkg: error processing /var/cache/apt/archives/dpkg-dev_1.16.1_all.deb (--unpack):
> > subprocess dpkg-deb --control returned error exit status 2
[...]
> > I manually unpacked the latest tar package (version 1.26-2) with ar
> > and tar, and overwrote /bin/tar . dpkg worked again.
>
> The tar version introducing those options was 1.23, present in
> squeeze. So it seems you are trying to upgrade a system with packages
> still from lenny to a mix of squeeze and sid?
>
> This is generally not supported, but I also agree this outcome is not
> desirable either, I'll probably add a versioned Pre-Depends on the
> required tar, after running it through debian-devel.

So cc-ing debian-devel with this mail. Does anyone have an objection
against dpkg adding this "tar (>= 1.23)" pre-dependency?

For reference it's the fix for #640298 that added the --warning=no-timestamp
option.

Cheers,
--
Raphaël Hertzog ◈ Debian Developer

Follow my Debian News ▶ http://RaphaelHertzog.com (English)
▶ http://RaphaelHertzog.fr (Français)


--
To UNSUBSCRIBE, email to debian-devel-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 20110929165035.GF6403@rivendell.home.ouaza.com">ht tp://lists.debian.org/20110929165035.GF6403@rivendell.home.ouaza.com
 
Old 09-29-2011, 06:02 PM
Julien Cristau
 
Default dpkg predependency against tar >= 1.23, objections?

On Thu, Sep 29, 2011 at 18:50:35 +0200, Raphael Hertzog wrote:

> Hello,
>
> On Sun, 25 Sep 2011, Guillem Jover wrote:
> > > $ sudo apt-get install dpkg-dev
> [...]
> > > tar: unrecognized option `--warning=no-timestamp'
> > > Try `tar --help' or `tar --usage' for more information.
> > > dpkg-deb: error: subprocess tar returned error exit status 64
> > > dpkg: error processing /var/cache/apt/archives/dpkg-dev_1.16.1_all.deb (--unpack):
> > > subprocess dpkg-deb --control returned error exit status 2
> [...]
> > > I manually unpacked the latest tar package (version 1.26-2) with ar
> > > and tar, and overwrote /bin/tar . dpkg worked again.
> >
> > The tar version introducing those options was 1.23, present in
> > squeeze. So it seems you are trying to upgrade a system with packages
> > still from lenny to a mix of squeeze and sid?
> >
> > This is generally not supported, but I also agree this outcome is not
> > desirable either, I'll probably add a versioned Pre-Depends on the
> > required tar, after running it through debian-devel.
>
> So cc-ing debian-devel with this mail. Does anyone have an objection
> against dpkg adding this "tar (>= 1.23)" pre-dependency?
>
> For reference it's the fix for #640298 that added the --warning=no-timestamp
> option.
>
Couldn't dpkg figure out from tar --version whether it can add the
option?

Cheers,
Julien


--
To UNSUBSCRIBE, email to debian-devel-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 20110929180216.GG24256@radis.liafa.jussieu.fr">htt p://lists.debian.org/20110929180216.GG24256@radis.liafa.jussieu.fr
 
Old 09-29-2011, 06:50 PM
Guillem Jover
 
Default dpkg predependency against tar >= 1.23, objections?

On Thu, 2011-09-29 at 20:02:16 +0200, Julien Cristau wrote:
> Couldn't dpkg figure out from tar --version whether it can add the
> option?

Well it could, but then I'd rather remove the warning suppression (or
the equivalent of postponing adding the option until after wheezy) than
doing something like that.

regards,
guillem


--
To UNSUBSCRIBE, email to debian-devel-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 20110929185026.GA16007@gaara.hadrons.org">http://lists.debian.org/20110929185026.GA16007@gaara.hadrons.org
 
Old 09-29-2011, 07:19 PM
Steve Langasek
 
Default dpkg predependency against tar >= 1.23, objections?

On Thu, Sep 29, 2011 at 06:50:35PM +0200, Raphael Hertzog wrote:
> > The tar version introducing those options was 1.23, present in
> > squeeze. So it seems you are trying to upgrade a system with packages
> > still from lenny to a mix of squeeze and sid?

> > This is generally not supported, but I also agree this outcome is not
> > desirable either, I'll probably add a versioned Pre-Depends on the
> > required tar, after running it through debian-devel.

> So cc-ing debian-devel with this mail. Does anyone have an objection
> against dpkg adding this "tar (>= 1.23)" pre-dependency?

> For reference it's the fix for #640298 that added the --warning=no-timestamp
> option.

FWIW, the previous Ubuntu LTS release included tar 1.22, so using a
pre-dependency in Debian probably means Ubuntu will have to carry a delta
for this for 12.04. A solution that works for both Debian and Ubuntu would
be welcome.

I don't see any reason that this pre-dependency would be a problem for
Debian itself given that the required version of tar is in squeeze.

--
Steve Langasek Give me a lever long enough and a Free OS
Debian Developer to set it on, and I can move the world.
Ubuntu Developer http://www.debian.org/
slangasek@ubuntu.com vorlon@debian.org
 
Old 09-29-2011, 07:28 PM
Raphael Hertzog
 
Default dpkg predependency against tar >= 1.23, objections?

Hi,

On Thu, 29 Sep 2011, Steve Langasek wrote:
> FWIW, the previous Ubuntu LTS release included tar 1.22, so using a
> pre-dependency in Debian probably means Ubuntu will have to carry a delta
> for this for 12.04. A solution that works for both Debian and Ubuntu would
> be welcome.

Why would that be the case? It just means that tar will be upgraded
early... but it depends only on "libc6 (>= 2.6)" which is satisfied
in 12.04 so it can be upgraded without dragging anything else.

Cheers,
--
Raphaël Hertzog ◈ Debian Developer

Follow my Debian News ▶ http://RaphaelHertzog.com (English)
▶ http://RaphaelHertzog.fr (Français)


--
To UNSUBSCRIBE, email to debian-devel-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 20110929192811.GE7329@rivendell.home.ouaza.com">ht tp://lists.debian.org/20110929192811.GE7329@rivendell.home.ouaza.com
 

Thread Tools




All times are GMT. The time now is 10:25 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org