FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Debian > Debian Development

 
 
LinkBack Thread Tools
 
Old 07-13-2011, 08:01 PM
Max Tsepkov
 
Default Bug#633795: ITP: evolution-tray -- Plugin for Evolution to put it in notification area

Package: wnpp
Severity: wishlist
Owner: Max Tsepkov <max@garygolden.me>

* Package name : evolution-tray
Version : 0.0.7
Upstream Author : Lucian Langa <lucilanga@gnome.org>
* URL : http://gnome.eu.org/evo/index.php/Evolution_Tray
* License : GPL2
Programming Lang: C
Description : Plugin for Evolution to put it in notification area

This plugin is useful when you want to put evolution in "tray" (notification area).
While in tray evolution in minimized and it's windows skips the pager.
You can restore evolution on any workspace.



--
To UNSUBSCRIBE, email to debian-devel-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 20110713200139.7209.13463.reportbug@localhost.loca ldomain">http://lists.debian.org/20110713200139.7209.13463.reportbug@localhost.loca ldomain
 
Old 07-14-2011, 12:17 AM
Micah Gersten
 
Default Bug#633795: ITP: evolution-tray -- Plugin for Evolution to put it in notification area

On 07/13/2011 03:01 PM, Max Tsepkov wrote:
> Package: wnpp
> Severity: wishlist
> Owner: Max Tsepkov <max@garygolden.me>
>
> * Package name : evolution-tray
> Version : 0.0.7
> Upstream Author : Lucian Langa <lucilanga@gnome.org>
> * URL : http://gnome.eu.org/evo/index.php/Evolution_Tray
> * License : GPL2
> Programming Lang: C
> Description : Plugin for Evolution to put it in notification area
>
> This plugin is useful when you want to put evolution in "tray" (notification area).
> While in tray evolution in minimized and it's windows skips the pager.
> You can restore evolution on any workspace.

Wasn't the notification area deprecated [1] in GNOME 3?
Micah

[1]
http://live.gnome.org/GnomeShell/Design/Guidelines/MessageTray/Compatibility


--
To UNSUBSCRIBE, email to debian-devel-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 4E1E3597.7090208@ubuntu.com">http://lists.debian.org/4E1E3597.7090208@ubuntu.com
 
Old 07-14-2011, 12:19 AM
Micah Gersten
 
Default Bug#633795: ITP: evolution-tray -- Plugin for Evolution to put it in notification area

On 07/13/2011 07:17 PM, Micah Gersten wrote:
> On 07/13/2011 03:01 PM, Max Tsepkov wrote:
>> Package: wnpp
>> Severity: wishlist
>> Owner: Max Tsepkov <max@garygolden.me>
>>
>> * Package name : evolution-tray
>> Version : 0.0.7
>> Upstream Author : Lucian Langa <lucilanga@gnome.org>
>> * URL : http://gnome.eu.org/evo/index.php/Evolution_Tray
>> * License : GPL2
>> Programming Lang: C
>> Description : Plugin for Evolution to put it in notification area
>>
>> This plugin is useful when you want to put evolution in "tray" (notification area).
>> While in tray evolution in minimized and it's windows skips the pager.
>> You can restore evolution on any workspace.
> Wasn't the notification area deprecated [1] in GNOME 3?
> Micah
>
> [1]
> http://live.gnome.org/GnomeShell/Design/Guidelines/MessageTray/Compatibility
Sorry, I don't think that's the correct link to what I was making the
point of, but I think the question is still valid.
Micah


--
To UNSUBSCRIBE, email to debian-devel-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 4E1E360B.7050603@ubuntu.com">http://lists.debian.org/4E1E360B.7050603@ubuntu.com
 
Old 07-14-2011, 08:48 AM
Max Tsepkov
 
Default Bug#633795: ITP: evolution-tray -- Plugin for Evolution to put it in notification area

> Wasn't the notification area deprecated [1] in GNOME 3?
> Micah
>
> [1]
> http://live.gnome.org/GnomeShell/Design/Guidelines/MessageTray/Compatibility
>
>

I just sent an email to the upstream author asking whether he plan to
upgrade the plugin or not.
Anyway, the plugin is still useful and demand by many people.
Besides Gnome 2 will be still in use for long time.

Until it fixed I'll add
Breaks: gnome (>=3)
to not use deprecated features.

What do you think?

--
cheers


--
To UNSUBSCRIBE, email to debian-devel-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 1310633308.16382.13.camel@sewers">http://lists.debian.org/1310633308.16382.13.camel@sewers
 
Old 07-14-2011, 09:05 AM
Arno Töll
 
Default Bug#633795: ITP: evolution-tray -- Plugin for Evolution to put it in notification area

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Hi,

On 14.07.2011 10:48, Max Tsepkov wrote:
> Until it fixed I'll add
> Breaks: gnome (>=3)
> to not use deprecated features.

this sounds like a very bad idea. Even if such a package would exist, it
would be a meta package to install /actual/ Gnome 3 packages. Moreover
you don't actually break as by definition of the policy [1].

Presuming your package works on Gnome 2 /only/, depend with a versioned
dependency declaring a <=/<< relation [2] on the actual package
providing the tray area container in Gnome 2. I can't believe Gnome 3
wouldn't support older legacy tray widgets though, I'd assume it would,
similar to KDE 4, supports older tray widgets through some legacy wrapping.

[1] http://www.debian.org/doc/debian-policy/ch-relationships.html#s-breaks
[2]
http://www.debian.org/doc/debian-policy/ch-relationships.html#s-depsyntax

- --
with kind regards,
Arno Töll
IRC: daemonkeeper on Freenode/OFTC
GnuPG Key-ID: 0x9D80F36D
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.11 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/

iQIcBAEBAgAGBQJOHrFxAAoJEMcrUe6dgPNtWpAQANRk6H2P8n KY2rkCBD1DhQYL
yELI5u/jN47X8DANJ7vwbK2hZiP7XVZX+6uCOaWD35JV9YEUJL4SLVUii I8+6k/j
Mjat/gWYAf6gIDsT9q0folAnqrAsp4Et8EVwvbsndSbOtXFaEC8ytd5 jrZZxolsr
AEQgTBk4MepSg6ZmiwMrbLR9Q/vSqN6yCG5F8nYh1XrIQsb2azhuM88L1kYFvMpd
c4Acs6K62I3V/g3ROUJZEch5hC+ffnBhXxBjltN7MBQoYTZWxm7BIkWkDytvG6Y R
rO11hJr8F+ha8DcglG5fxJ9Eceixp6xFp81ZdpsSIxPvcYtd8h L22p4txaJO4GMe
huGVO7fJOQL1RccaDraGM1TVFA80b4sOrOZKHyRMcHe4v++5iG jb7J6dzqZ5hZ/Q
2soROdBH3VvK6cHH7PMQe3/7ufsVJg4GQ754RDlIeW8UNoRv0bXOlvvcVLmiml/V
85ZFoh3z76h++BYqDXL2/QG8qfkKR9zYg/Bk0/rSaLSZIfmat+vMy/2kF+u5v5jb
1wqgH4MQkp07fhp+uwjwAJ6A4C4ZrbStRHPQv0e9DqA+s6Qb7C fKkpj4lgFZ1OHk
t79943OaS3x8H/jK0nI8aF3IetaJOjekb2X5dhpI196dplaIoi2rdX1t/0jC8HQa
XTPpiGDmQ6k4bYm3ejLT
=ATh5
-----END PGP SIGNATURE-----


--
To UNSUBSCRIBE, email to debian-devel-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 4E1EB171.1090806@toell.net">http://lists.debian.org/4E1EB171.1090806@toell.net
 
Old 07-14-2011, 09:26 AM
Max Tsepkov
 
Default Bug#633795: ITP: evolution-tray -- Plugin for Evolution to put it in notification area

> this sounds like a very bad idea. Even if such a package would exist, it
> would be a meta package to install /actual/ Gnome 3 packages. Moreover
> you don't actually break as by definition of the policy [1].

Oh. Thanks for clarification.

> I can't believe Gnome 3 wouldn't support older legacy tray widgets though,
> I'd assume it would

Me too.

Well. I'm going to package it relying on mentors, who won't allow error
packages into the archive :P

--
cheers


--
To UNSUBSCRIBE, email to debian-devel-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 1310635560.16382.17.camel@sewers">http://lists.debian.org/1310635560.16382.17.camel@sewers
 
Old 07-14-2011, 10:21 AM
Simon McVittie
 
Default Bug#633795: ITP: evolution-tray -- Plugin for Evolution to put it in notification area

On Thu, 14 Jul 2011 at 11:05:53 +0200, Arno Töll wrote:
> I can't believe Gnome 3
> wouldn't support older legacy tray widgets though, I'd assume it would,
> similar to KDE 4, supports older tray widgets through some legacy wrapping.

GNOME 3 has a freedesktop-compatible notification area ("tray") (although
it's less visible than it used to be - the status icons only appear when a
notification is shown or the mouse pointer hits the bottom of the screen),
so technically, this will work. The deprecation isn't technical, it's social
(following the GNOME 3 UI design). The notification area was meant to be for
notifications, but in practice nearly everyone used it as a dumping ground
for persistent things: background applications, status indications
(battery, wifi, ...), and so on.

The recommended thing in GNOME 3 is to use persistent notifications, which
stay around until the user has read them, and so don't need to be associated
with a status icon.
<http://live.gnome.org/GnomeShell/Design/Guidelines/MessageTray>

The GNOME 2 HIG also discouraged use of the notification area for
non-notification things, but less strongly, and in practice everyone puts
them there anyway because it's easier and more cross-desktop than writing
a panel applet... (HIG reference:
<http://developer.gnome.org/hig-book/2.32/desktop-notification-area.html.en>)

This isn't unique to GNOME 3 - Unity has a similar design (persistent
notifications, and dedicated UI widgets for "core UI" things like
battery/wifi indicators), and Windows suffers particularly badly from
developers misusing the notification area in the same way, although Microsoft's
attempts to solve it have been a bit different
(<http://msdn.microsoft.com/en-us/library/aa511448.aspx>).

It wouldn't surprise me to learn that KDE 4 has a similar solution, but I
haven't used KDE much since 2.x, so I don't know how they dealt with this.

S


--
To UNSUBSCRIBE, email to debian-devel-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 20110714102142.GB25011@reptile.pseudorandom.co.uk" >http://lists.debian.org/20110714102142.GB25011@reptile.pseudorandom.co.uk
 
Old 07-14-2011, 11:58 AM
Max Tsepkov
 
Default Bug#633795: ITP: evolution-tray -- Plugin for Evolution to put it in notification area

The software is packaged, but lintian is not clean:
E: evolution-tray: pkg-has-shlibs-control-file-but-no-actual-shared-libs
W: evolution-tray: postinst-has-useless-call-to-ldconfig
W: evolution-tray: postrm-has-useless-call-to-ldconfig

I need help with these. Please, suggest.

The package can be found on mentors.debian.net:
- URL: http://mentors.debian.net/debian/pool/main/e/evolution-tray
- Source repository: deb-src http://mentors.debian.net/debian unstable
main contrib non-free
- dget
http://mentors.debian.net/debian/pool/main/e/evolution-tray/evolution-tray_0.0.7-1.dsc


--
To UNSUBSCRIBE, email to debian-devel-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 1310644684.16382.30.camel@sewers">http://lists.debian.org/1310644684.16382.30.camel@sewers
 
Old 07-14-2011, 12:22 PM
Paul Wise
 
Default Bug#633795: ITP: evolution-tray -- Plugin for Evolution to put it in notification area

On Thu, Jul 14, 2011 at 1:58 PM, Max Tsepkov wrote:

> The software is packaged, but lintian is not clean:
> E: evolution-tray: pkg-has-shlibs-control-file-but-no-actual-shared-libs
> W: evolution-tray: postinst-has-useless-call-to-ldconfig
> W: evolution-tray: postrm-has-useless-call-to-ldconfig

I tried to reproduce these, but I could not even build the package:

checking for intltool >= 0.21... ./configure: line 3855:
intltool-update: command not found
configure: error: Your intltool is too old. You need intltool 0.21 or later.

Also, debian/README.source needs to be deleted.

--
bye,
pabs

http://wiki.debian.org/PaulWise


--
To UNSUBSCRIBE, email to debian-devel-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: CAKTje6ELO8P9SS-A92LcHEjV51LcBfUn_cSif=TOB-uOySm89A@mail.gmail.com">http://lists.debian.org/CAKTje6ELO8P9SS-A92LcHEjV51LcBfUn_cSif=TOB-uOySm89A@mail.gmail.com
 
Old 07-14-2011, 12:46 PM
Max Tsepkov
 
Default Bug#633795: ITP: evolution-tray -- Plugin for Evolution to put it in notification area

> I tried to reproduce these, but I could not even build the package:
>
> checking for intltool >= 0.21... ./configure: line 3855:
> intltool-update: command not found
> configure: error: Your intltool is too old. You need intltool 0.21 or later.

I've added gnome-core-devel to Build-Depends.
It depends on gnome-common, which depends on intltool.
I'm not sure which software the build process uses therefore included
gnome-core-devel instead of gnome-common or just intltool.

> Also, debian/README.source needs to be deleted.
done

I've reuploaded the package to mentors.debian.org

Thanks.

--
cheers


--
To UNSUBSCRIBE, email to debian-devel-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 1310647605.16382.34.camel@sewers">http://lists.debian.org/1310647605.16382.34.camel@sewers
 

Thread Tools




All times are GMT. The time now is 04:07 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright ©2007 - 2008, www.linux-archive.org