FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Debian > Debian Development

 
 
LinkBack Thread Tools
 
Old 02-10-2008, 07:28 AM
Eric Dorland
 
Default Periodic automake cleanup: removal of automake1.8

As has become custom, it's time for removal of another old automake
version. This time I've picked automake1.8. Why not automake1.7?
Mostly because only 27 packages build depend on automake1.8 versus 72
on automake1.7.

Attached is a list of packages that build depend on
automake1.8. Please fix them by:

1. Not build depending on automake in the first place. It may be
completely unnecessary, or you can ship the generated Makefile.in's in
the diff.gz. You will never have to deal with these transition
problems again.

2. Upgrade to the latest version of automake, automake1.10, to stave
off obsolescence.

In a couple of weeks I will be filing wishlist bugs with patches to
remove the automake1.8. Probably about a month after that I will start
NMUing any packages who haven't acted on the bugs. Then I will ask for
automake1.8's removal. Thanks in advance for your help.

Anibal Avelar (Fixxxer) <aavelar@cofradia.org>
gsetroot

Stefan Hornburg (Racke) <racke@linuxia.de>
courier

K?stutis Biliūnas <kebil@kaunas.init.lt>
liblingoteach
lingoteach-ui

Rudi Cilibrasi <cilibrar@debian.org>
libcomplearn-mod-lzmax
libcomplearn-mod-ppmd
libcomplearn-mod-ppmdx
libcomplearn-ruby

Debian FDT tools team <pkg-fdt-tools-team@lists.alioth.debian.org>
asn1c

Debian KDE Extras Team <pkg-kde-extras@lists.alioth.debian.org>
kasablanca

Debian Maemo Maintainers
<pkg-maemo-maintainers@lists.alioth.debian.org>
sapwood

Debian QA Group <packages@qa.debian.org>
lineakd

Carlos Alberto Silombria Ibarra <silverdog@gmail.com>
libpam-blue

Robert Jordens <jordens@debian.org>
dvbackup
liblrdf

Kilian Krause <kilian@debian.org>
ekiga

Anand Kumria <wildfire@progsoc.org>
sweep

Mad Maintainers <pkg-mad-maintainers@lists.alioth.debian.org>
madplay

Marcelo E. Magallon <mmagallo@debian.org>
devil

Bart Martens <bartm@knars.be>
par2cmdline

Parted Maintainer Team <parted-maintainers@lists.alioth.debian.org>
parted

Steve M. Robbins <smr@debian.org>
gmp

Emanuele Rocca <ema@debian.org>
urlview

Benjamin Seidenberg <astronut@dlgeek.net>
pork

Paul Slootman <paul@debian.org>
isdnutils

J?¶rg Sommer <joerg@alea.gnuu.de>
slrn

Jamie Wilkinson <jaq@debian.org>
freeglut



--
Eric Dorland <eric@kuroneko.ca>
ICQ: #61138586, Jabber: hooty@jabber.com
 
Old 02-10-2008, 02:58 PM
Frank Lichtenheld
 
Default Periodic automake cleanup: removal of automake1.8

On Sun, Feb 10, 2008 at 03:28:18AM -0500, Eric Dorland wrote:
> Debian QA Group <packages@qa.debian.org>
> lineakd

Fixed version uploaded.

Gruesse,
--
Frank Lichtenheld <djpig@debian.org>
www: http://www.djpig.de/


--
To UNSUBSCRIBE, email to debian-devel-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 
Old 02-10-2008, 05:23 PM
Adeodato Sim
 
Default Periodic automake cleanup: removal of automake1.8

* Eric Dorland [Sun, 10 Feb 2008 03:28:18 -0500]:

> 2. Upgrade to the latest version of automake, automake1.10, to stave
> off obsolescence.

For those not finding automake1.10, it's in the "automake" binary
package.

HTH,

--
Adeodato Sim dato at net.com.org.es
Debian Developer adeodato at debian.org

Listening to: Andrs Calamaro - Elvis est vivo


--
To UNSUBSCRIBE, email to debian-devel-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 
Old 02-10-2008, 06:04 PM
Eric Dorland
 
Default Periodic automake cleanup: removal of automake1.8

* Adeodato Sim? (dato@net.com.org.es) wrote:
> * Eric Dorland [Sun, 10 Feb 2008 03:28:18 -0500]:
>
> > 2. Upgrade to the latest version of automake, automake1.10, to stave
> > off obsolescence.
>
> For those not finding automake1.10, it's in the "automake" binary
> package.

automake currently provides automake1.10. The automake package is
meant to track the latest upstream release of automake, so directly
build depending on it is probably not a good idea, unless your
Makefile.am's are very simple.

--
Eric Dorland <eric@kuroneko.ca>
ICQ: #61138586, Jabber: hooty@jabber.com
 
Old 02-10-2008, 08:24 PM
Jrg Sommer
 
Default Periodic automake cleanup: removal of automake1.8

Hallo Eric,

Eric Dorland <eric@debian.org> wrote:
> Jrg Sommer <joerg@alea.gnuu.de>
> slrn

Fixed in experimental. I will soon provide a new version for unstable.

Bye, Jrg.
--
[dpkg] We are the apt. Resistance is futile. You will be packaged.


--
To UNSUBSCRIBE, email to debian-devel-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 

Thread Tools




All times are GMT. The time now is 03:29 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org