Bug#464766: ITP: squirrelmail-compatibility -- Squirrelmail plugin used by other plugins to work with older SM versions
On Sat, 2008-02-09 at 12:10 +0100, Jan Hauke Rahm wrote:
> Can't those plugins use
> Depends: squirrelmail-compatibility (<= 2.0)
> to solve that?
No, because both dpkg and apt generally assume only one version of
something is installable at the same time. This is why we have gcc4.2-*,
gcc4.3-* etcetera instead of just multiple versions of the same package.
On another note: it sure would be nice if dpkg and apt supported the
notion of slotting somehow, but I don't expect that to ever happen.
As such, you need to distinguish between the different API versions. If
they can't co-exist, then use Conflicts: appropriately.