Linux Archive

Linux Archive (http://www.linux-archive.org/)
-   Debian Development (http://www.linux-archive.org/debian-development/)
-   -   Bug#464766: ITP: squirrelmail-compatibility -- Squirrelmail plugin used by other plugins to work with older SM versions (http://www.linux-archive.org/debian-development/51000-bug-464766-itp-squirrelmail-compatibility-squirrelmail-plugin-used-other-plugins-work-older-sm-versions.html)

Christian Perrier 02-09-2008 05:54 AM

Bug#464766: ITP: squirrelmail-compatibility -- Squirrelmail plugin used by other plugins to work with older SM versions
 
Quoting Jan Hauke Rahm (info@jhr-online.de):
> Package: wnpp
> Severity: wishlist
> Owner: Jan Hauke Rahm <info@jhr-online.de>
>
> * Package name : squirrelmail-compatibility
> Version : 2.0.9
> Upstream Author : Paul Lesniewski <paul@squirrelmail.org>
> * URL : http://www.squirrelmail.org/plugin_view.php?id=152
> * License : GPL
> Programming Lang: PHP
> Description : Squirrelmail plugin used by other plugins to work with older SM versions

I suggest something like "compatibility plugin for old SquirrelMail
versions"

...and develop more in the long description, maybe.

What is the proper capitalization of SM?
SquirrelMail or Squirrelmail?

William Pitcock 02-09-2008 08:01 AM

Bug#464766: ITP: squirrelmail-compatibility -- Squirrelmail plugin used by other plugins to work with older SM versions
 
On Sat, 2008-02-09 at 07:54 +0100, Christian Perrier wrote:
> Quoting Jan Hauke Rahm (info@jhr-online.de):
> > Package: wnpp
> > Severity: wishlist
> > Owner: Jan Hauke Rahm <info@jhr-online.de>
> >
> > * Package name : squirrelmail-compatibility
> > Version : 2.0.9
> > Upstream Author : Paul Lesniewski <paul@squirrelmail.org>
> > * URL : http://www.squirrelmail.org/plugin_view.php?id=152
> > * License : GPL
> > Programming Lang: PHP
> > Description : Squirrelmail plugin used by other plugins to work with older SM versions
>
> I suggest something like "compatibility plugin for old SquirrelMail
> versions"
>
> ...and develop more in the long description, maybe.
>
> What is the proper capitalization of SM?
> SquirrelMail or Squirrelmail?
>
>

Also from reading the documentation of this plugin, it seems some
plugins explicitly need version 1.x. As such, shouldn't this be
squirrelmail-compatibility2 or something?

William

William Pitcock 02-09-2008 10:21 AM

Bug#464766: ITP: squirrelmail-compatibility -- Squirrelmail plugin used by other plugins to work with older SM versions
 
On Sat, 2008-02-09 at 12:10 +0100, Jan Hauke Rahm wrote:
> Can't those plugins use
> Depends: squirrelmail-compatibility (<= 2.0)
> to solve that?

No, because both dpkg and apt generally assume only one version of
something is installable at the same time. This is why we have gcc4.2-*,
gcc4.3-* etcetera instead of just multiple versions of the same package.

On another note: it sure would be nice if dpkg and apt supported the
notion of slotting somehow, but I don't expect that to ever happen.

As such, you need to distinguish between the different API versions. If
they can't co-exist, then use Conflicts: appropriately.

William


All times are GMT. The time now is 01:06 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.