FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Debian > Debian Development

 
 
LinkBack Thread Tools
 
Old 02-08-2008, 08:25 PM
Jan Hauke Rahm
 
Default Bug#464766: ITP: squirrelmail-compatibility -- Squirrelmail plugin used by other plugins to work with older SM versions

Package: wnpp
Severity: wishlist
Owner: Jan Hauke Rahm <info@jhr-online.de>

* Package name : squirrelmail-compatibility
Version : 2.0.9
Upstream Author : Paul Lesniewski <paul@squirrelmail.org>
* URL : http://www.squirrelmail.org/plugin_view.php?id=152
* License : GPL
Programming Lang: PHP
Description : Squirrelmail plugin used by other plugins to work with older SM versions

This plugin allows any other plugin access to the functions and special
variables needed to make it backward (and forward) compatible with most
versions of SM in wide use. This eliminates the need for duplication of
certain functions throughout many plugins. It also provides
functionality that helps check that plugins have been installed and set
up correctly.

-- System Information:
Debian Release: lenny/sid
APT prefers testing
APT policy: (500, 'testing')
Architecture: i386 (i686)

Kernel: Linux 2.6.22-3-686 (SMP w/1 CPU core)
Locale: LANG=de_DE.UTF-8, LC_CTYPE=de_DE.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash



--
To UNSUBSCRIBE, email to debian-devel-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 
Old 02-09-2008, 09:51 AM
Thijs Kinkhorst
 
Default Bug#464766: ITP: squirrelmail-compatibility -- Squirrelmail plugin used by other plugins to work with older SM versions

On Saturday 9 February 2008 07:54, Christian Perrier wrote:
> What is the proper capitalization of SM?
> SquirrelMail or Squirrelmail?

It's "SquirrelMail", unfortunately.


Thijs
 
Old 02-09-2008, 10:10 AM
Jan Hauke Rahm
 
Default Bug#464766: ITP: squirrelmail-compatibility -- Squirrelmail plugin used by other plugins to work with older SM versions

Hey Christian and William,

first of all thanks for your thoughts!

On Sat, Feb 09, 2008 at 03:01:48AM -0600, William Pitcock wrote:
> On Sat, 2008-02-09 at 07:54 +0100, Christian Perrier wrote:
> > I suggest something like "compatibility plugin for old SquirrelMail
> > versions"
> >
> > ...and develop more in the long description, maybe.

I'll consider that. In fact the plugin is also useful for future
versions of SM. I don't know how to describe that...

> > What is the proper capitalization of SM?
> > SquirrelMail or Squirrelmail?

SquirrelMail (seen on squirrelmail.org)

> Also from reading the documentation of this plugin, it seems some
> plugins explicitly need version 1.x. As such, shouldn't this be
> squirrelmail-compatibility2 or something?

Can't those plugins use
Depends: squirrelmail-compatibility (<= 2.0)
to solve that?

Hauke
 

Thread Tools




All times are GMT. The time now is 04:26 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org