FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Debian > Debian Development

 
 
LinkBack Thread Tools
 
Old 03-20-2011, 05:35 AM
"Nikita V. Youshchenko"
 
Default Bug#618965: libetpan15: Breaks build system on Debian Sid

[CCing -devel because there are several questions below]

> Package: libetpan15
> Version: 1.0-3
> Severity: critical
> Justification: breaks unrelated software
>
> Installing libetpan15(-dev) causes libdb-4.8 libdb-4.7 libdb-4.6 to be
> removed since libetpan depends on libdb-5.1. libdb5.1-dev cannot
> coexists with libdb > libdb-5.1. Package should always be build against
> latest version in Sid.

There are actually several separate issues here.


*) libdb*-dev packages do conflict with each other.

As soon as any package depends on one of libdb*-dev, none of others could
be installed, and none of package depending on one of others.

Don't know if it is a bug or a feature.

#618965 is just an example of this.
At least I doubt it is of severity critical.


*) Generic question about dependences of libdev packages.

If libfoo is linked against libbar, should libfoo-dev depend on libbar-dev?

It is a question of policy.
In old days, there was a requirement for such a dependency, to support
static linking. But today very few people care about static linking.

Is current policy on this documented anywhere? A pointer will be helpful...


*) libetpan15 is linked against libdb4.8, but libetpan-dev depends on
libdb5.1-dev

This is a real bug (although not of severity critical!), and is caused by:
- libetpan's configure script is not aware of libdb5.1, but knows about 4.8
and previous versions
- in build environment, libdb4.8 package is pushed by some recursive
dependences,
- libdb4.8 provides libdb-4.8.so
- so build successfully finishes against libdb-4.8, although libdb4.8-dev
is not installed in build chroot
- as for libetpan-dev dependency, it is computed by checking libdb-dev
dependency [this was once implemented to support backporting], which
currently is libdb5.1-dev

So at least
- I will fix libetpan to become aware of libdb5.1
- I will fix how libetpan-dev dependency is computed, to check actually
used libdb instead of using libdb5.1 package dependeny

Open question is - isn't it a bug in libdb4.8 that link against libdb4.8
suceeds when libdb4.8-dev is not installed? I don't know

One more question: is it safe to have package linked against libdb4.8, and
then re-link against libdb5.1? Won't that break things because of
incompatible database format?
[but AFAIK in case of libetpan this should be safe because libdb is used to
cache things only]
 
Old 03-20-2011, 07:53 AM
Michael Rasmussen
 
Default Bug#618965: libetpan15: Breaks build system on Debian Sid

On Sun, 20 Mar 2011 09:35:40 +0300
"Nikita V. Youshchenko" <yoush@debian.org> wrote:

> *) libetpan15 is linked against libdb4.8, but libetpan-dev depends on
> libdb5.1-dev
>
This is a real issue since building packages against libetpan15 pulls
in a dependency for libdb5.1-dev but at the same time since libetpan15
is build against libdb4.8 other builds will then require libdb4.8-dev.
The consequences is that other builds fails since you cannot fulfill
the requirements of libdb4.8-dev and libdb5.1-dev at the same time.

--
Hilsen/Regards
Michael Rasmussen

Get my public GnuPG keys:
michael <at> rasmussen <dot> cc
http://pgp.mit.edu:11371/pks/lookup?op=get&search=0xD3C9A00E
mir <at> datanom <dot> net
http://pgp.mit.edu:11371/pks/lookup?op=get&search=0xE501F51C
mir <at> miras <dot> org
http://pgp.mit.edu:11371/pks/lookup?op=get&search=0xE3E80917
--------------------------------------------------------------
You will be awarded a medal for disregarding safety in saving someone.
 
Old 03-20-2011, 10:47 AM
"Nikita V. Youshchenko"
 
Default Bug#618965: libetpan15: Breaks build system on Debian Sid

> On Sun, 20 Mar 2011 09:35:40 +0300
>
> "Nikita V. Youshchenko" <yoush@debian.org> wrote:
> > *) libetpan15 is linked against libdb4.8, but libetpan-dev depends on
> > libdb5.1-dev
>
> This is a real issue since building packages against libetpan15 pulls
> in a dependency for libdb5.1-dev but at the same time since libetpan15
> is build against libdb4.8 other builds will then require libdb4.8-dev.
> The consequences is that other builds fails since you cannot fulfill
> the requirements of libdb4.8-dev and libdb5.1-dev at the same time.

I've just uploaded 1.0-4 with libetpan linked against libdb5.1 and
libetpan-dev depending in libdb5.1-dev

But you still won't be able to install libetpan-dev together with
libdb4.x-dev.

Nikita
 

Thread Tools




All times are GMT. The time now is 05:19 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org