FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Debian > Debian Development

 
 
LinkBack Thread Tools
 
Old 02-18-2011, 12:07 PM
Josselin Mouette
 
Default What should we do with iceweasel/xulrunner/libmozjs?

Le vendredi 18 février 2011 * 13:34 +0100, Mike Hommey a écrit :
> On Fri, Feb 18, 2011 at 12:59:46PM +0100, Josselin Mouette wrote:
> > I’d favor that one too. The sooner we can adapt reverse dependencies to
> > 4.0 in experimental, the better. And no need to do the work twice.
>
> There have been almost a year to adapt reverse dependencies to 3.6 in
> experimental. And I don't think most rdeps are ready for 3.6. Do you
> expect things to be significantly different?

Yes. We’re no longer in a freeze but at the beginning of a development
cycle.

Note that we’re mostly doing the same for GNOME; skipping most of 2.32
in unstable, to work on 2.91 in experimental.

--
.'`.
: :' : “You would need to ask a lawyer if you don't know
`. `' that a handshake of course makes a valid contract.”
`- -- J???rg Schilling


--
To UNSUBSCRIBE, email to debian-devel-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 1298034464.18394.72.camel@meh">http://lists.debian.org/1298034464.18394.72.camel@meh
 
Old 02-18-2011, 06:00 PM
Ron Johnson
 
Default What should we do with iceweasel/xulrunner/libmozjs?

On 02/18/2011 05:42 AM, Axel Beckert wrote:

Hi,

Mike Hommey wrote:

- Push 3.6 to unstable and the last 4.0 betas/rc to experimental. Push
4.0 to unstable when it's out.


That would be my favourite.

I use Conkeror (which is a XULRunner application and hence depends on
xulrunner) with 3.6 since it is in experimental and it works without
problems since a year or so. Ubuntu has the Debian package with just
slight modification of some defaults together with xulrunner-1.9.2 in
Lucid 10.04 LTS. They just had to backport a few upstream fixes.


[snip]



Cons: We lose version 3.6, which has several advantages over 3.5, and
keep 3.5, which is already very outdated.


Right. That's why I want to see 3.6 in unstable as soon as possible
independently of the state of 4.0.



I concur with Axel. Been using iceweasel 3.6 since soon after it
hit experimental, and stuff like vlc/unstable work like a champ.


--
"The normal condition of mankind is tyranny and misery."
Milton Friedman


--
To UNSUBSCRIBE, email to debian-devel-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 4D5EC1E9.2040201@cox.net">http://lists.debian.org/4D5EC1E9.2040201@cox.net
 

Thread Tools




All times are GMT. The time now is 02:25 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org